Bug 11667 - nfs not starting up properly
nfs not starting up properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-25 14:43 EDT by fchinchi
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 18:34:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fchinchi 2000-05-25 14:43:59 EDT
When I upgraded from 6.0 to 6.2 the nfs exported directories couldn't be
seen on the machines we exported to.  The /etc/exports file was properly
set and so was everything else.  After trying many different changes in
the init.d directory, rc.local file and rc3.d, I noticed that if I
checked that status and then tried to start nfs, it worked.  I undid all
the changes I had made and executed:

" /etc/rc.d/init.d/nfslock status" and then
"/etc/rc.d/init.d/nfs start".  For some reason that did the trick.  I
tried stopping both nfslock and nfs, starting them again, and looking
for their status in many orders and configurations and I found those to
be the minimal and necessary lines on all the machines I have upgraded.
A simple 'nfs start' would not do it, but for some reason if I checked
the 'nfslock status' and then 'nfs start' it worked.  I had to
incorporate to the rc.local file because I couldn't make it work
anywhere else.  The differences that I saw btwn 6.0 and 6.2 is that
stat.d is started in nfs in 6.0 and in nfslock in 6.2.  I thought that
it may have been for security reasons that nfs wasn't loaded at boot
time and that that is why we had to put it in rc.local, but it sounds
more like a bug of some sort.  I searched for bugs of this type and
found that 10646 is very similar and 10669 is similar as well, but this one
seemed like a different one since my exports file is not empty.  Do you
know why 'nfslock status' enables the machine to nfs export properly?
thanks
Comment 1 fchinchi 2000-07-31 16:26:03 EDT
Problem was fixed.  Since nfs was not executed in the init sequence, the nfslock
was hanging in limbo not doing anything.  That is why the "nfslock status" was
necessary.  A simpler and preferred way of fixing this is to add a "S15nfs" to
the appropriate rc#.d directory, where 15 was chosen because it is usually
S14nfslock.
Comment 2 Cristian Gafton 2000-08-08 22:34:08 EDT
assigned to johnsonm

Note You need to log in before you can comment on or make changes to this bug.