Bug 1166730 - No error message displayed in GUI when bootloader embedding area is too small
No error message displayed in GUI when bootloader embedding area is too small
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-21 10:16 EST by Kamil Páral
Modified: 2014-12-05 05:37 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-21.48.21-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-04 22:26:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (585.80 KB, application/ogg)
2014-11-21 10:16 EST, Kamil Páral
no flags Details
anaconda.log (13.60 KB, text/plain)
2014-11-21 10:16 EST, Kamil Páral
no flags Details
program.log (40.81 KB, text/plain)
2014-11-21 10:16 EST, Kamil Páral
no flags Details
storage.log (159.43 KB, text/plain)
2014-11-21 10:16 EST, Kamil Páral
no flags Details
anaconda fixed (75.66 KB, image/png)
2014-12-05 05:37 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2014-11-21 10:16:06 EST
Created attachment 959803 [details]
bug demonstration video

Description of problem:
I have created a single small (100MB) unaligned partition on my disk using parted. If I run anaconda, in guided partition I see that I have enough space on my disk, anaconda does not ask me to reclaim any more (that is correct), but after I arrive back to the main hub, I see "Error checking storage configuration". There is no explanation anywhere, neither in the main hub nor in the partition dialog if I enter it again. See video. I can begin installation.

The unaligned partition is reported to be not "opt aligned", but correctly "min aligned" by parted, whatever that means. I created it like this:

[root@localhost ~]# parted /dev/vda
GNU Parted 3.2
Using /dev/vda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mklabel msdos
Warning: The existing disk label on /dev/vda will be destroyed and all data on this disk will be lost. Do you
want to continue?
Yes/No? yes                                                               
(parted) mkpart p ext4 512B 100000000B
Warning: The resulting partition is not properly aligned for best performance.
Ignore/Cancel? ignore                                                     
(parted) p                                                                
Model: Virtio Block Device (virtblk)
Disk /dev/vda: 10.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start  End    Size   Type     File system  Flags
 1      512B   100MB  100MB  primary  ext4         lba

(parted) q                                                                
Information: You may need to update /etc/fstab.

[root@localhost ~]# mkfs.ext4 /dev/vda1
...


Version-Release number of selected component (if applicable):
anaconda-21.48.14-1.fc21.x86_64
python-blivet-0.61.9-1.fc21.noarch
F21 TC2 Workstation Live x86_64

How reproducible:
always

Steps to Reproduce:
1. follow the steps in description to create a single small unaligned partition
2. run anaconda
3. try to complete guided partition accepting all defaults
4. see error in the main hub
Comment 1 Kamil Páral 2014-11-21 10:16:33 EST
Created attachment 959804 [details]
anaconda.log
Comment 2 Kamil Páral 2014-11-21 10:16:36 EST
Created attachment 959805 [details]
program.log
Comment 3 Kamil Páral 2014-11-21 10:16:39 EST
Created attachment 959806 [details]
storage.log
Comment 4 Kamil Páral 2014-11-21 10:19:01 EST
I'm not sure whether this is again another edge case or not. But to be safe, proposing for blocker bug discussion. Criterion is:
"When using the guided partitioning flow, the installer must be able to:
    Cleanly install to a disk with a valid ms-dos or gpt disk label and partition table which contains existing data and sufficient unpartitioned space for a Fedora installation "
https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Guided_partitioning
Comment 5 Adam Williamson 2014-11-24 12:47:14 EST
This bug changed quite a lot under investigation during blocker review. It turns out the problem wasn't that the partition was unaligned, it was that kparal created it such that the embedding area on the disk (between the MBR and the start of the partition) was too small. program.log shows:

10:06:56,548 ERR anaconda: vda may not have enough space for grub2 to embed core.img when using the ext4 file system on partition
10:06:56,549 ERR anaconda: storage configuration failed: autopart failed:
vda may not have enough space for grub2 to embed core.img when using the ext4 file system on partition

however, as the video shows, no specific error message was shown in the GUI - only the generic error condition at the hub. There's no red error bar at the bottom of the Installation Destination spoke when kparal revisits it.
Comment 6 Adam Williamson 2014-11-24 12:48:44 EST
Discussed at 2014-11-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-24/f21-blocker-review.2014-11-24-17.01.log.txt . Rejected as a blocker as this is no new error condition and really is something we want to error on, but accepted as a freeze exception - we would accept a small, safe-looking and tested change to make an error message appear in the GUI if it lands relatively soon.
Comment 7 Kamil Páral 2014-11-24 13:04:13 EST
I tested again with "mkpart p ext4 1M 100000000B" and anaconda behaves correctly. The problem really was in insufficient space at the beginning of the disk.
Comment 8 Brian Lane 2014-11-24 17:41:02 EST
Not that this happens with autopart, it is shown correctly when in custom.
Comment 9 Fedora Update System 2014-11-26 15:40:18 EST
anaconda-21.48.17-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.17-1.fc21
Comment 10 Fedora Update System 2014-11-27 14:28:58 EST
Package anaconda-21.48.17-1.fc21, python-blivet-0.61.11-1.fc21, pyparted-3.10.2-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.17-1.fc21 python-blivet-0.61.11-1.fc21 pyparted-3.10.2-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.11-1.fc21,anaconda-21.48.17-1.fc21
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2014-11-29 15:59:21 EST
Package pyparted-3.10.2-1.fc21, python-blivet-0.61.12-1.fc21, anaconda-21.48.18-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.10.2-1.fc21 python-blivet-0.61.12-1.fc21 anaconda-21.48.18-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.12-1.fc21,anaconda-21.48.18-1.fc21
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2014-12-01 20:04:14 EST
Package pyparted-3.10.2-1.fc21, python-blivet-0.61.12-1.fc21, anaconda-21.48.20-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.10.2-1.fc21 python-blivet-0.61.12-1.fc21 anaconda-21.48.20-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.12-1.fc21,anaconda-21.48.20-1.fc21
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2014-12-03 01:06:01 EST
Package python-blivet-0.61.12-1.fc21, anaconda-21.48.21-1.fc21, pyparted-3.9.5-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.61.12-1.fc21 anaconda-21.48.21-1.fc21 pyparted-3.9.5-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/anaconda-21.48.21-1.fc21,pyparted-3.9.5-3.fc21,python-blivet-0.61.12-1.fc21
then log in and leave karma (feedback).
Comment 14 Adam Williamson 2014-12-04 19:04:40 EST
Kamil, can you please confirm this fixed in Final?

Dropping FE status as it's moot.
Comment 15 Fedora Update System 2014-12-04 22:26:41 EST
anaconda-21.48.21-1.fc21, python-blivet-0.61.13-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Kamil Páral 2014-12-05 05:37:01 EST
Created attachment 965056 [details]
anaconda fixed

Yes, this has been fixed in RC5. Attaching screenshot.

Note You need to log in before you can comment on or make changes to this bug.