This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 116677 - (IEEE1394 SBP2)sbp2 won't recognize Maxtor 5000DV any more
(IEEE1394 SBP2)sbp2 won't recognize Maxtor 5000DV any more
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-24 05:55 EST by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.6-1.435
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 21:25:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-02-24 05:55:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
Plugging in a Maxtor 5000DV external hard disk causes the ohci1394 to
load sbp2, and sbp2 to report there's something in there, but it
doesn't recognize the disk or set up /dev/sda like kernel-2.6.3-1.91 did.

Version-Release number of selected component (if applicable):
kernel-2.6.3-1.97

How reproducible:
Always

Steps to Reproduce:
1.Boot 2.6.3-1.97
2.Plug the disk in
3.Reboot into 2.6.3-1.91
    

Actual Results:  2. doesn't get the disk to work; 3. does.

Expected Results:  I'd prefer if updates didn't break working
configurations :-) :-)

Additional info:

Here's what I get with 2.6.3-1.97:

Feb 23 00:56:59 livre kernel: ohci1394: $Rev: 1131 $ Ben Collins
<bcollins@debian.org>
Feb 23 00:56:59 livre kernel: ohci1394: fw-host0: OHCI-1394 1.0 (PCI):
IRQ=[11]  MMIO=[f6ffd800-f6ffdfff]  Max Packet=[2048]
Feb 23 00:57:00 livre ieee1394.agent[3128]: ... no drivers for
IEEE1394 product 0x000000/0x0010b9/0xceb001
Feb 23 00:57:03 livre kernel: sbp2: $Rev: 1144 $ Ben Collins
<bcollins@debian.org>

but here's what I get with 2.6.3-1.91

Feb 23 01:04:00 livre kernel: ohci1394: fw-host0: SelfID received, but
NodeID invalid (probably new bus reset occurred): 0000FFC0
Feb 23 01:04:03 livre kernel: ieee1394: ConfigROM quadlet transaction
error for node 0-01:1023
Feb 23 01:04:03 livre ieee1394.agent[2954]: ... no drivers for
IEEE1394 product 0x000000/0x0010b9/0xceb001
Feb 23 01:04:04 livre kernel: sbp2: $Rev: 1096 $ Ben Collins
<bcollins@debian.org>
Feb 23 01:04:04 livre kernel: scsi0 : SCSI emulation for IEEE-1394
SBP-2 Devices
Feb 23 01:04:05 livre kernel: ieee1394: sbp2: Logged into SBP-2 device
Feb 23 01:04:05 livre kernel: ieee1394: sbp2: Node 0-00:1023: Max
speed [S400] - Max payload [2048]
Feb 23 01:04:05 livre kernel:   Vendor: Maxtor    Model: 5000DV      
     Rev: 0100
Feb 23 01:04:05 livre kernel:   Type:   Direct-Access                
     ANSI SCSI revision: 06
Feb 23 01:04:05 livre kernel: SCSI device sda: 320171008 512-byte hdwr
sectors (163928 MB)
Feb 23 01:04:05 livre kernel: sda: asking for cache data failed
Feb 23 01:04:05 livre kernel: sda: assuming drive cache: write through
Feb 23 01:04:05 livre scsi.agent[2990]: how to add device type= at
/devices/platform/host0/0:0:0:0 ??
Feb 23 01:04:05 livre kernel:  sda: sda1 sda2 sda3 sda4 < sda5 sda6
sda7 sda8 sda9 sda10 sda11 sda12 sda13 >
Feb 23 01:04:05 livre kernel: Attached scsi disk sda at scsi0, channel
0, id 0, lun 0
Feb 23 01:04:05 livre kernel: Attached scsi generic sg0 at scsi0,
channel 0, id 0, lun 0,  type 0

I've already reported this upstream.  It's apparently going to require
some debugging on my end.
Comment 1 Dave Jones 2004-02-24 07:19:53 EST
there were some small ieee1394 updates in 1.99 / 1.100, do they fix it
for you ?
Comment 2 Alexandre Oliva 2004-02-24 17:23:41 EST
No luck :-(  I'll try to debug it one of these days.
Comment 3 Alexandre Oliva 2004-02-26 22:09:38 EST
For starters, I took the sources in drivers/ieee1394 from 2.6.3-1.91
and dropped that into 2.6.3-1.109 (effectively rolling ieee1394 back
to original 2.6.3), and then it worked.  Well, at least it recognized
the drive.  I haven't done any additional testing so far, but I'll try
to narrow down what introduced the problem.
Comment 4 Alexandre Oliva 2004-03-08 13:22:49 EST
Some newer kernels based on 2.6.4-rc1 or newer do recognize the
firewire hard disk, but present crashes within DMA code when under
high sequential disk activity (e.g., dd if=/dev/zero
of=/mnt/raid-on-firewire-HD/bigfile bs=1024k count=2048, on a box with
512MB of memory).  the stack trace has hpsb_packet_sent called by
dma_trm_tasklet called by tasklet_action called by __do_softirq called
by do_softirq.  hpsb_packet_sent crashes because
list_del(&packet->list) attempts to dereference 0x100100. This
indicates this list entry has been already removed.
Comment 5 Alexandre Oliva 2004-04-08 17:05:37 EDT
The failure mode above is gone.  2.6.5-rc kernels with linux1394
-r1203 worked very reliably on my laptop, but not as reliably on my
desktop :-(  Here's the kernel stack trace.  This was a bug that was
thought to be fixed in -r1203, but that clearly wasn't :-(

Warning: kfree_skb passed an skb still on a list (from 00000000).
------------[ cut here ]------------
kernel BUG at net/core/skbuff.c:225!
invalid operand: 0000 [#1]
CPU:    0
EIP:    0060:[<02287d89>]    Not tainted
EFLAGS: 00010206   (2.6.4-1.305)
EIP is at __kfree_skb+0x19/0xe6
eax: 00000045   ebx: 1d62d780   ecx: 023b043c   edx: 0232f3f8
esi: 42908e80   edi: 00000246   ebp: 00000000   esp: 4146cfd0
ds: 007b   es: 007b   ss: 0068
Process khpsbpkt (pid: 15, threadinfo=4146c000 task=41f5cd00)
Stack: 0231921f 00000000 1d62d780 1d62d780 428c4aca 428c4a9b 00000000
00000000
       021071d9 00000000 00000000 00000000
Call Trace:
 [<428c4aca>] hpsbpkt_thread+0x2f/0x1a7 [ieee1394]
 [<428c4a9b>] hpsbpkt_thread+0x0/0x1a7 [ieee1394]
 [<021071d9>] kernel_thread_helper+0x5/0xb
Apr  8 17:47:58 free kernel:
Code: 0f 0b e1 00 e9 91 31 02 5b 58 8b 04 24 8b 58 2c 85 db 74 21
Comment 6 Dave Jones 2004-06-14 19:49:15 EDT
How are things looking in the current update kernel ?

Note You need to log in before you can comment on or make changes to this bug.