Bug 11669 - 8-bit characters should probably be enabled by default.
Summary: 8-bit characters should probably be enabled by default.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: joe   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-25 19:20 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 20:32:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-05-25 19:20:03 UTC
Joe doesn't show 8-bit characters properly by default.

Removing the space before -asis in /usr/lib/joe/joerc will fix that.

Comment 1 Trond Eivind Glomsrxd 2000-05-26 20:43:59 UTC
Can you send me a file? It works for me, with a Norwegian text (with Norwegian
characters). Finnish may or may not work - that's not iso-8859-1, which may (or
may not - I'm not sure) complicate things further.

Comment 2 Pekka Savola 2000-05-27 20:29:59 UTC
Without this, e.g. 'd' is shown as 'd' on gray background.

Diff against latest rawhide /usr/lib/joe/joerc.
-- joerc~      Thu May 25 22:17:21 2000
+++ joerc       Thu May 25 22:17:30 2000
@@ -25,7 +25,7 @@

  -marking      Text between ^KB and cursor is highlighted (use with -lightoff)

- -asis         Characters 128 - 255 shown as-is
+-asis          Characters 128 - 255 shown as-is

  -force                Force final newline when files are saved
-------

Or did you mean some other file?

Comment 3 Trond Eivind Glomsrxd 2000-05-30 20:32:59 UTC
I can't reproduce it when loading a text with many Norwegian (and some Swedish)
characters.

Comment 4 Pekka Savola 2000-05-31 15:16:18 UTC
This seems to be caused by LC_CTYPE, LC_ALL, or some such environment variable.

If you set e.g. LC_CTYPE="" and LC_ALL="", this will surface. 
By default, Redhat 6.2 at least didn't set any LC_* variables.


Comment 5 Trond Eivind Glomsrxd 2000-05-31 15:31:27 UTC
That's expected behaviour - the LC_CTYPE (or LANG/LC_ALL, which affects more
settings) is there for exactly this kind of problem. Red Hat Linux should set
some of these settings (possibly only LANG, which is suffcient) during install -
it's changeable with locale_config.


Note You need to log in before you can comment on or make changes to this bug.