Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1167014 - Manual partitioning using single partition: unable to escape from Partitioning page except with workaround
Manual partitioning using single partition: unable to escape from Partitionin...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedFreezeException RejectedBlock...
: CommonBugs
Depends On:
Blocks: F21FinalFreezeException
  Show dependency treegraph
 
Reported: 2014-11-22 11:40 EST by Marian Csontos
Modified: 2014-12-07 18:46 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-04 19:05:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (56.87 KB, text/plain)
2014-11-24 08:47 EST, Marian Csontos
no flags Details
journal.log (652.90 KB, text/plain)
2014-11-24 08:48 EST, Marian Csontos
no flags Details
program.log (22.34 KB, text/plain)
2014-11-24 08:48 EST, Marian Csontos
no flags Details
storage.log (115.58 KB, text/plain)
2014-11-24 08:49 EST, Marian Csontos
no flags Details
the rest of /var/log/anaconda/ files (118.43 KB, application/x-gzip)
2014-11-24 08:49 EST, Marian Csontos
no flags Details

  None (edit)
Description Marian Csontos 2014-11-22 11:40:57 EST
Description of problem:
Just tried installing F21_TC3 - everything on single partition, without creating swap.
I have seen a warning stripe about no swap but pressing Done several times did not allow me to complete the screen.

Version-Release number of selected component (if applicable):
F21_TC3
anaconda-21.48.16-1

How reproducible:
2/2

Steps to Reproduce:
1. try to install without swap partition
2. press Done
3. warning is presented instructing user to press Done again to force install

Actual results:
Pressing Done does not proceed with installation

Expected results:
Pressing Done should proceed with installation

Additional info:
Comment 1 Marian Csontos 2014-11-22 11:47:54 EST
IMO failing Final Blocker criterion:

Disk layouts

The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration.
Comment 2 Kamil Páral 2014-11-24 08:00:46 EST
Everything works correctly for me - if I press Done for the second time, I get a confirmation dialog and I'm returned to the main hub. Please provide exact reproduction steps (or a video) and logs, thanks.
Comment 3 Kamil Páral 2014-11-24 08:01:12 EST
(Tested with TC3 as well, Server DVD)
Comment 4 Marian Csontos 2014-11-24 08:47:13 EST
Installed using netinst image and custom partitioning. I tried twice with TC3 - both real HW and VM. Using partitions only. Attaching logs from the VM install.
Comment 5 Marian Csontos 2014-11-24 08:47:46 EST
Created attachment 960786 [details]
anaconda.log
Comment 6 Marian Csontos 2014-11-24 08:48:16 EST
Created attachment 960787 [details]
journal.log
Comment 7 Marian Csontos 2014-11-24 08:48:43 EST
Created attachment 960788 [details]
program.log
Comment 8 Marian Csontos 2014-11-24 08:49:06 EST
Created attachment 960789 [details]
storage.log
Comment 9 Marian Csontos 2014-11-24 08:49:53 EST
Created attachment 960790 [details]
the rest of /var/log/anaconda/ files
Comment 10 Kamil Páral 2014-11-24 09:27:37 EST
Can you also append exact steps to reproduce?

What I tried:
1. enter custom part with an empty disk
2. click "create layout automatically"
3. delete swap
4. confirm (Done twice)
and
1. enter custom part with an empty disk
2. create a root partition (nothing else)
3. confirm (Done twice)

All done using LVM (the default).
Comment 11 Marian Csontos 2014-11-24 10:29:44 EST
Prerequisite:
- single empty disk (thin-provisioned - should be all zeros, no MBR)
- using virt-manager to create new VM with current TC3 netinstall iso

In installation destination - Device Selection
1. pick "I will configure partitioning"
2. Done
In manual patitioning:
3. +: Mountpoint "/", size "8G". Add mount point. (The only mountpoint.)
4. Device type to standard patition
5. Done.
6. goto 5.

After adding /boot it works as expected and the configuration is accepted after pressing Done second time.

When I remove /boot now it still works.

Same happens when I add /home.

So looks like it does not work only when using single partition.

That may be non-standard partitioning today - I used this to check installation on a NB which did not have enough space in VG while enough to create a partition.
Comment 12 Marian Csontos 2014-11-24 10:36:42 EST
Alternative path: In manual patitioning:
3. Change partitioning scheme to "Standard Partition" instead of "LVM".
4. +: Mountpoint "/", size "8G". Add mount point. (The only mountpoint.)
5. Done
6. goto 5.

OTOH if instead of 4 I do:
4.1 +: Mountpoint "/", size "8G". Add mount point.
4.2 +: Mountpoint "/home", size "1G". Add mount point.
4.3 -: /home
5. Done
6. Warning. Press Done. and it is Done.

Creating and removing a partition changes some internal state.
Comment 13 Kamil Páral 2014-11-24 10:54:51 EST
I tried both approaches in comment 11 and comment 12, all of them work for me as expected.
Comment 14 Marian Csontos 2014-11-24 11:01:23 EST
It works for LVM. Does not for partitions.
Comment 15 Adam Williamson 2014-11-24 12:57:22 EST
Discussed at 2014-11-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-24/f21-blocker-review.2014-11-24-17.01.log.txt . It seems that no-one but Marian can reproduce this even with the steps provided (bcl says he can't either), and even in the event that we do find a reproducer approximately matching the description, we felt it's enough of an unusual case that it would be OK to just document the 'create a partition then remove it' workaround.

If a clear reproducer can be found and confirmed it would be OK to propose this for freeze exception consideration, but we didn't want to vote on FE while it wasn't clear if we could even reliably reproduce a problem here.
Comment 16 Brian Lane 2014-11-24 13:25:07 EST
This can be reproduced by adding a label to the mountpoint and not hitting 'Update Settings'. Clicking Done shows the warning, but doesn't clear the need for hitting 'Update Settings'.
Comment 17 Kamil Páral 2014-11-25 03:53:24 EST
(In reply to bcl@redhat.com from comment #16)
> This can be reproduced by adding a label to the mountpoint and not hitting
> 'Update Settings'. Clicking Done shows the warning, but doesn't clear the
> need for hitting 'Update Settings'.

Reproduced with TC3.
1. enter custom part
2. delete all existing partitions
3. create a single / partition covering the whole disk
4. type something into Label
5. hit Done repeatedly, nothing happens, can't escape
6. erase everything from Label
7. hit Done repeatedly, still can't escape

If you change something, Update Settings is required in order to escape the dialog. It would be nice if anaconda told you something like "you still have pending changes, please confirm them first" or some other approach.

Proposing as a freeze exception.
Comment 18 Marian Csontos 2014-11-25 05:49:37 EST
(In reply to Marian Csontos from comment #11)
> Prerequisite:
> - single empty disk (thin-provisioned - should be all zeros, no MBR)

At the end the error gets triggered _only_ when using thin-volume as backing device. I verified the device IS all zeros. I will try to find out more.
Comment 19 Brian Lane 2014-11-25 12:20:12 EST
(In reply to Kamil Páral from comment #17)

> If you change something, Update Settings is required in order to escape the
> dialog. It would be nice if anaconda told you something like "you still have
> pending changes, please confirm them first" or some other approach.
> 

The solution is even simpler than that. It needs to reset the state of the button. When you click Done the current settings get saved as if you pushed update settings.

> Proposing as a freeze exception.

+1 -- I have a fix on master.


(In reply to Marian Csontos from comment #18)
> At the end the error gets triggered _only_ when using thin-volume as backing
> device. I verified the device IS all zeros. I will try to find out more.

This doesn't have anything to do with thin, it is because something in the right side (like label) has been changed and done is hit without hitting update setttings.
Comment 20 Scott Suehle 2014-11-26 15:10:26 EST
Discussed at today's blocker review meeting [1]. Accepted as a Freeze Exception. A fix for this would be considered during freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/
Comment 21 Marian Csontos 2014-11-27 05:53:07 EST
(In reply to bcl@redhat.com from comment #19)
> (In reply to Marian Csontos from comment #18)
> > At the end the error gets triggered _only_ when using thin-volume as backing
> > device. I verified the device IS all zeros. I will try to find out more.
> 
> This doesn't have anything to do with thin, it is because something in the
> right side (like label) has been changed and done is hit without hitting
> update setttings.

I am the reporter and I am pretty positive the original issue I reported has something to do with thin as I were able to reproduce it 100% while Kamil were not until the label trick was invented but I am prone to believe these are two unrelated issues.

I am letting this report be hijacked for the "label" issue and I will open another bug when I have data on thin-related part and/or if still reproducible with the next TC or GA. This is a specific configuration and it will not be worth of blocker or exception.
Comment 22 Adam Williamson 2014-12-04 19:05:53 EST
Not clear on whether this landed in 21 or not, but it certainly landed in master, so let's close this by setting it to Rawhide.

Note You need to log in before you can comment on or make changes to this bug.