Bug 1167016 - ark-4.14.3-1 : crash on exit
Summary: ark-4.14.3-1 : crash on exit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ark
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F21FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-11-22 16:47 UTC by Rex Dieter
Modified: 2014-12-04 18:45 UTC (History)
9 users (show)

Fixed In Version: ark-4.14.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-25 03:05:41 UTC
Type: Bug


Attachments (Terms of Use)
Click on the "test.docx" file and then close ark to crash it. (10.00 KB, application/x-tar)
2014-11-30 13:35 UTC, Arjun A.K.
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 340991 None None None Never

Description Rex Dieter 2014-11-22 16:47:22 UTC
ark-4.14.3-1 crashes on exiting the program.  The cause is upstream introduced a fix in 4.14.3 that we had patched in a different way causing an incompatibilty.

See also:
https://bugs.kde.org/show_bug.cgi?id=340991

Comment 1 Fedora Update System 2014-11-22 16:48:31 UTC
ark-4.14.3-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-15442/ark-4.14.3-2.fc21

Comment 2 Fedora Blocker Bugs Application 2014-11-22 16:52:41 UTC
Proposed as a Freeze Exception for 21-final by Fedora user rdieter using the blocker tracking app because:

 Ark application as shipped on fedora live spin crashes on exit.  Would like to ship non-crashing default applications.

Comment 3 Adam Williamson 2014-11-24 18:24:06 UTC
Discussed at 2014-11-24 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-24/f21-blocker-review.2014-11-24-17.01.log.txt . Accepted as a freeze exception issue - obviously good to fix crasher bugs in apps on the live image.

Comment 4 Fedora Update System 2014-11-25 03:05:41 UTC
ark-4.14.3-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Rex Dieter 2014-11-25 13:11:04 UTC
*** Bug 1167752 has been marked as a duplicate of this bug. ***

Comment 6 Arjun A.K. 2014-11-30 13:33:21 UTC
I can still reproduce this in ark-4.14.3-2.

#6  0x00007f80948672a0 in KXMLGUIFactory::removeClient(KXMLGUIClient*) (this=0x0, client=client@entry=0x2003448) at /usr/src/debug/kdelibs-4.14.3/kdeui/xmlgui/kxmlguifactory.cpp:419
#7  0x00007f807a9549d4 in Ark::Part::~Part() (this=0x20033b0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/ark-4.14.3/part/part.cpp:141
#8  0x00007f807a954a59 in Ark::Part::~Part() (this=0x20033b0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/ark-4.14.3/part/part.cpp:146
#9  0x00007f8095b4c479 in KParts::Part::slotWidgetDestroyed() (this=0x20033b0) at /usr/src/debug/kdelibs-4.14.3/kparts/part.cpp:353
#10 0x00007f809281cf8c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x2003220, m=m@entry=0x7f8092b65240 <QObject::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff9cd35340) at kernel/qobject.cpp:3567
#11 0x00007f809281d9ff in QObject::destroyed(QObject*) (this=this@entry=0x2003220, _t1=_t1@entry=0x2003220) at .moc/release-shared/moc_qobject.cpp:148
#12 0x00007f8092821b97 in QObject::~QObject() (this=0x2003220, __in_chrg=<optimized out>) at kernel/qobject.cpp:871
#13 0x00007f8093a3aaa7 in QWidget::~QWidget() (this=0x2003220, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554

Comment 7 Arjun A.K. 2014-11-30 13:35:49 UTC
Created attachment 962920 [details]
Click on the "test.docx" file and then close ark to crash it.

Comment 8 Rex Dieter 2014-12-04 14:52:35 UTC
Please open a new, preferably upstream, bug report... the crash you're experiencing is similar, but different.

(I think this is precisely why we chose to carry a different KXMLGUIFactory patch, the one upstream chose to use may fail in this case)

Comment 9 Kevin Kofler 2014-12-04 18:45:54 UTC
Should we revert the upstream patch and apply our previous one instead?


Note You need to log in before you can comment on or make changes to this bug.