Bug 116711 - kernel not completing interface initialization when network script finished
kernel not completing interface initialization when network script finished
Status: CLOSED DUPLICATE of bug 97610
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 11:20 EST by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output from the problematic machine (5.26 KB, text/plain)
2004-02-24 11:21 EST, Joshua Jensen
no flags Details

  None (edit)
Description Joshua Jensen 2004-02-24 11:20:29 EST
Description of problem:

The problem is that when the network script initializes the cards, the
actual initialization of the cards isn't yet finished by the time the
netfs script runs.  A bad work-around is to rig the random script
(which runs after the network but before the netfs script) to simply
sleep for 10 seconds.  This works well, isn't pretty.  Shouldn't the
kernel initialize the driver and card immediately?


Version-Release number of selected component (if applicable):

RHEL3 AS with all updates


How reproducible:

tg3 driver being used for two NICs


Additional info:

lspci -v output attached
Comment 1 Joshua Jensen 2004-02-24 11:21:12 EST
Created attachment 97996 [details]
lspci -v output from the problematic machine

lspci -v output from the problematic machine
Comment 2 Joshua Jensen 2004-02-26 12:33:28 EST
This is causing BIG problems on Oracle servers.... nfs mounts don't
mount when the machine is rebooted.  Please address!
Comment 3 Bill Nottingham 2004-02-26 16:00:11 EST

*** This bug has been marked as a duplicate of 97610 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.