Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1167197 - qemu-kvm can not cancel migration in src host when network of dst host failed
Summary: qemu-kvm can not cancel migration in src host when network of dst host failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1168790 (view as bug list)
Depends On: 1086168 1168790
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-24 08:05 UTC by Qian Guo
Modified: 2015-12-04 16:21 UTC (History)
13 users (show)

Fixed In Version: qemu-2.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1086168
Environment:
Last Closed: 2015-12-04 16:21:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Comment 1 Qian Guo 2014-11-24 08:07:12 UTC
Clone the original bug to qemu-kvm-rhev component for rhel7.1
hit it with qemu-kvm-rhev-2.1.2-8.el7.x86_64

Comment 3 Dr. David Alan Gilbert 2014-11-24 11:41:24 UTC
Please try waiting ~15mins after the migration_cancel command is issued and see whether it eventually cancels (I think the TCP timeouts should happen by then).

Comment 4 Qian Guo 2014-11-26 06:49:37 UTC
(In reply to Dr. David Alan Gilbert from comment #3)
> Please try waiting ~15mins after the migration_cancel command is issued and
> see whether it eventually cancels (I think the TCP timeouts should happen by
> then).

Yes, after long time, it change to cancelled.

Comment 5 Shaolong Hu 2014-11-28 03:02:37 UTC
*** Bug 1168790 has been marked as a duplicate of this bug. ***

Comment 6 Xu Han 2014-12-23 06:46:15 UTC
It is easy to reproduce this bug on ppc64 build, so set Hardware to Unspecified.

Version-Release number of selected component:
qemu-kvm-rhev-2.1.2-16.el7.ppc64

Comment 10 Shaolong Hu 2015-06-18 09:12:22 UTC
Verified on qemu-kvm-rhev-2.3.0-2.el7.x86_64:

1. cmd:

/usr/libexec/qemu-kvm -enable-kvm -M pc -smp 4 -m 4G -name rhel6.3-64 -uuid 3f2ea5cd-3d29-48ff-aab2-23df1b6ae213 -drive file=/root/RHEL-Server-7.2-64-virtio.qcow2,cache=none,if=none,rerror=stop,werror=stop,id=drive-virtio-disk0,format=qcow2,aio=native -device virtio-blk-pci,drive=drive-virtio-disk0,id=device-virtio-disk0,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0,mac=aa:54:00:11:22:33 -boot order=cd -monitor stdio -usb -device usb-tablet,id=input0 -chardev socket,id=s1,path=/tmp/s1,server,nowait -device isa-serial,chardev=s1 -monitor tcp::1234,server,nowait -vga qxl -global qxl-vga.revision=3 -spice port=5920,disable-ticketing -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -vnc :10 -qmp tcp:0:5555,server,nowait

2. start migration, on des host, drop migration incoming packet with:
iptables -A INPUT -p tcp -d 10.66.84.12 --dport 5556 -j DROP

3. cancel migration on src host, migration cancelled immediately:

(qemu) migrate_cancel 
(qemu) info migrate
capabilities: xbzrle: off rdma-pin-all: off auto-converge: off zero-blocks: off 
Migration status: cancelled
total time: 0 milliseconds

Comment 14 errata-xmlrpc 2015-12-04 16:21:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.