Bug 1167286 - [RFE] add an event which would inform about host problem before the host is set to Non Responding
Summary: [RFE] add an event which would inform about host problem before the host is s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Eli Mesika
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-24 11:28 UTC by Jiri Belka
Modified: 2016-03-09 20:51 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:51:41 UTC
oVirt Team: Infra
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Jiri Belka 2014-11-24 11:28:50 UTC
Description of problem:

add an event which would inform about host problem before the host is set to Non Responding. in fact, the host is in Connecting state with red arrow down icon but there's no event for this. it would be nice if any host's status change would be tracked in events.

2014-Nov-24, 12:20
Host ibm-p8-rhevm-02.rhts.eng.brq.redhat.com is non responsive.
	
2014-Nov-24, 12:18
VM test was started by admin (Host: ibm-p8-rhevm-02.rhts.eng.brq.redhat.com).
	
2014-Nov-24, 12:12
Host ibm-p8-rhevm-02.rhts.eng.brq.redhat.com power management was verified successfully.
	
2014-Nov-24, 12:12
Host ibm-p8-rhevm-01.rhts.eng.brq.redhat.com from cluster ppc64-clstr was chosen as a proxy to execute Status command on Host ibm-p8-rhevm-02.rhts.eng.brq.redhat.com.
	
+++ here it is in state 'Connecting' with red arrow down icon, so i'd like to see an even like:

  Host $host from cluster ppc64-clstr is in problematic state, trying to figure
  out what's going on...

2014-Nov-24, 12:12
State was set to Up for host ibm-p8-rhevm-02.rhts.eng.brq.redhat.com.

Version-Release number of selected component (if applicable):
3.4.4/av13.2

How reproducible:
100%

Steps to Reproduce:
1. 2 hosts with working PM, block ssh from engine to a host, stop on that host (super)vdsmd
2. observe events in Admin Portal and status on the host
3.

Actual results:
there's no event about host's status change, first event is PM event about status (one could ask himself: why is PM involved?)

Expected results:
add an event about why the host is in Connecting, so one can understand that PM status event is executed because there's something wrong

Additional info:

Comment 1 Eli Mesika 2015-04-27 10:05:30 UTC
This was probably resolved indirectly by the PM re-factoring patches that Martin P pushed , setting this to MODIFIED , please test again 

(Original patch was abandoned since it seeems irrelevant after Martin patches)

Comment 2 Pavol Brilla 2016-01-12 12:03:07 UTC
verified on 3.6.2-0.1.el6

Engine informs about issues with host in events before trying to bring it up and eventually put host to non-responsive

Comment 4 errata-xmlrpc 2016-03-09 20:51:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.