Bug 1167297 - After exporting VM based on a template, the VM gets blocked with a status showing image is locked
Summary: After exporting VM based on a template, the VM gets blocked with a status sho...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: lkuchlan
URL:
Whiteboard: storage
: 1167298 (view as bug list)
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-24 12:14 UTC by lkuchlan
Modified: 2016-02-10 20:21 UTC (History)
11 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage


Attachments (Terms of Use)
image+logs (513.14 KB, application/x-gzip)
2014-11-24 12:14 UTC, lkuchlan
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35664 master MERGED core: Add try/catch block in end action of ExportVmCommand Never
oVirt gerrit 35699 ovirt-engine-3.5 MERGED core: Add try/catch block in end action of ExportVmCommand Never

Description lkuchlan 2014-11-24 12:14:59 UTC
Created attachment 960705 [details]
image+logs

Description of problem:
After exporting VM based on a template, the VM gets blocked with a status showing image is locked

Version-Release number of selected component (if applicable):
3.5 vt11

How reproducible:
100%

Steps to Reproduce:
1. Create a VM based on a template
2. Create a Snapshot of the VM
3. Export the VM to an export domain

Actual results:
VM gets blocked with a status showing image is locked

Expected results:
The export process should succeed

Additional info:
Attach screenshot

Comment 1 Gil Klein 2014-11-24 13:09:11 UTC
*** Bug 1167298 has been marked as a duplicate of this bug. ***

Comment 2 Tal Nisan 2014-11-24 17:10:30 UTC
This occurs not on every export operation, only when the export ended and the getImageInfo in the end command part is failing (most likely on communication error with VDSM)

Comment 3 Allon Mureinik 2014-11-26 19:42:23 UTC
This isn't a blocker - it happens only in a very rare negative case (copying all the disks succeeds and only then vdsm fails just before the last getImageInfo is sent). Additionally, it's been there since 3.3, at least.

It definitely needs fixing, and we'll treat it as an exception, but it's not blocker-worthy.

Comment 4 Tal Nisan 2014-11-27 13:59:57 UTC
Patch posted, just to clarify - this occurs in the extremely rare scenario where the import of the images succeeded with copy collapse and connection problems to the host are occurring right after the export task completed and before the OVF image on the export domain is getting updated with the new info (since the snapshots have been collapsed)

Comment 5 lkuchlan 2014-12-16 07:44:58 UTC
Tested using RHEVM 3.5 vt13.3
The export process succeeds

Comment 6 Allon Mureinik 2015-02-16 19:13:47 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 7 Allon Mureinik 2015-02-16 19:13:52 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.