Bug 116733 - kernel hangs or crashes when hugetbl is on and Oracle 10g uses it
kernel hangs or crashes when hugetbl is on and Oracle 10g uses it
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 14:04 EST by Gunther Schadow
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 17:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gunther Schadow 2004-02-24 14:04:48 EST
Description of problem:

On a system with 20GB ram running the RHEL3 hugemem kernel
and hugetbl_max set to 8192 (which strangely enough 
/proc/meminfo reports as being just 4096 pages, and it 
looks like meminfo is right) when I run Oracle 10g using
lots of memory the kernel suddenly panics or just simply 
locks up.

Version-Release number of selected component (if applicable):


How reproducible:

Happens every other time I start Oracle (with a configuration
that really uses lots of memory)

Steps to Reproduce:
1. Install Oracle 10g
2. modify oracle to lower-mapped-base specs (optional)
3. modify oracle to enable aio (optional)
4. echo 8192 > /proc/sys/kern/hugetbl_max
5. specify sga_max_size = 3500M
6. specify db_buffer_cache = 2000M

--> of course I don't expect you to do all this, just to 
    debug a kernel error. I would make a program that 
    actually allocates lots of hugetbl shared memory
    and uses it heavily.

Actual results:

system crashes/hangs

Expected results:

system runs happily :-)

Additional info:
Comment 1 Suzanne Hillman 2004-02-26 17:21:29 EST
Please include information about the hardware being used, as well as
information about whether or not it happens on multiple machines.
Comment 2 Gunther Schadow 2004-03-03 20:51:13 EST
Hardware is a ProLiant DL780 (?) or so, it's got 4 CPUs.
I can't tell whether it happens on multiple machines. What
I do know is that when it actually panics and I get to
see the dump output, it does mumble something about hugetbl
stuff.
Comment 3 Larry Woodman 2004-04-05 11:50:33 EDT
Can you please get several "AltSysrq M" outputs when the system is
hung while running 10g with hugltlb pages?  I cant reproduce this
problem locally.

Thanks, Larry Woodman
 
Comment 4 Larry Woodman 2004-04-20 11:04:17 EDT
Please try to reproduce this problem with the latest RHEL3-U2 kernel
(2.4.21-14.EL).  We found and fixed a problem which sounds exactly
like this one in that kernel.

Larry Woodman
Comment 5 Larry Woodman 2004-08-02 17:07:49 EDT
Gunther, whats the status of this bug?  I havent seen any update in
the last 3 months.

Larry
Comment 6 Suzanne Hillman 2004-10-20 17:21:37 EDT
Closing due to lack of activity. If there is additional information, please
reopen and provide the information.

Note You need to log in before you can comment on or make changes to this bug.