Bug 116744 - Missing explicit requires for neon-devel...
Summary: Missing explicit requires for neon-devel...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: neon (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-02-24 20:57 UTC by Dams
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 0.24.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 09:36:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dams 2004-02-24 20:58:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1)
Gecko/20031114 Galeon/1.3.13

Description of problem:
Hello. 

This concerns FC1 neon package and current neon package in development
tree. Actually the neon-devel should explicitly requires
"openssl-devel" and "zlib-devel".

[root@gruyere ~]# pkg-config neon --libs
-L/usr/kerberos/lib -lneon -lssl -lcrypto -ldl -lz -lgssapi_krb5
-lkrb5 -lk5crypto -lcom_err -lresolv -lexpat

I tried to rebuild 'rawhide' subversion package (which build-requires
neon-devel) and the build failed because openssl-devel and zlib-devel
werent installed.

About current neon spec file, iirc, "BuildPreReq" is obsolete and
should be replaced by "BuildRequires". And autoconf doesnt seem to be
needed to rebuild neon (never invoked during build..)

Version-Release number of selected component (if applicable):
neon 0.24.4-2

How reproducible: Always. Every day.

Comment 1 Joe Orton 2004-02-25 09:36:30 UTC
Thanks for the report, I've committed the following for 0.24.4-3:

-BuildPreReq: expat-devel, openssl-devel, zlib-devel, krb5-devel
-BuildPreReq: autoconf, libtool, pkgconfig
+BuildRequires: expat-devel, openssl-devel, zlib-devel, krb5-devel
+BuildRequires: pkgconfig

...
 Group: Development/Libraries
-Requires: neon = %{version}
+Requires: neon = %{version}, openssl-devel, zlib-devel



Note You need to log in before you can comment on or make changes to this bug.