Bug 116749 - up2date slows down, stalls and then crashes while fetching rpm header info
up2date slows down, stalls and then crashes while fetching rpm header info
Status: CLOSED DUPLICATE of bug 119568
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 16:31 EST by Amin Shahidi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amin Shahidi 2004-02-24 16:31:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
[root@localhost root]# up2date

** (up2date:2563): WARNING **: `GtkTextSearchFlags' is not an enum type
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-rawhide
using mirror:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1360, in
onChannelsPageNext
    self.pkgList = self.pList.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 580, in
getPackagesToInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 609, in
__skipPackages
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 630, in
__skipFiles
    ignoreMsgCallback = self.ignoreMsgCallback)
  File "/usr/share/rhn/up2date_client/packageList.py", line 669, in
buildHeaderList
    hdr = headerList[pkg]
  File "/usr/share/rhn/up2date_client/headers.py", line 37, in __getitem__
    self.__retrievePackage(item)
  File "/usr/share/rhn/up2date_client/headers.py", line 42, in
__retrievePackage
    hdr, sourceType = rpcServer.doCall(self.repos.getHeader, item)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 112, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 31, in
getHeader
    return self.handlers[channel['type']].getHeader(pkg, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 210, in
getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
93, in getHeader
    hdrBuf = fh.read()
  File "/usr/lib/python2.3/gzip.py", line 217, in read
    self._read(readsize)
  File "/usr/lib/python2.3/gzip.py", line 272, in _read
    self._read_eof()
  File "/usr/lib/python2.3/gzip.py", line 308, in _read_eof
    raise IOError, "CRC check failed"
IOError: CRC check failed
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1439, in
onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence
TypeError: hide() takes no arguments (2 given)


Version-Release number of selected component (if applicable):
up2date 4.3.11-2

How reproducible:
Always

Steps to Reproduce:
1. Install a fresh copy of Fedora Test 1
2. Launch up2date via command line
3. With appoximately 1400 package headers to download, at some point
it will during the rpm header info download, it will slow down, stall,
and spew Traceback info in the Terminal screen.

    

Actual Results:  After the 10 attempt, it will finally get all of the
headers and proceed to the next stage.

Expected Results:  It should have not crashed.

Additional info:
Comment 1 Adrian Likins 2004-04-07 16:51:35 EDT

*** This bug has been marked as a duplicate of 119568 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.