Bug 1167539 - win8.1.32 guest BSOD with error ' MEMORY_MANAGEMENT'
Summary: win8.1.32 guest BSOD with error ' MEMORY_MANAGEMENT'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On:
Blocks: 1069309
TreeView+ depends on / blocked
 
Reported: 2014-11-25 03:12 UTC by ShupingCui
Modified: 2015-11-24 08:46 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:46:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (21.02 KB, image/jpeg)
2014-11-25 03:12 UTC, ShupingCui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description ShupingCui 2014-11-25 03:12:07 UTC
Created attachment 960997 [details]
screenshot

Description of problem:
win8.1.32 guest BSOD with error ' MEMORY_MANAGEMENT' when boot up

Version-Release number of selected component (if applicable):
# rpm -q kernel
kernel-3.10.0-201.el7.x86_64
# rpm -q qemu-kvm
qemu-kvm-1.5.3-79.el7.x86_64

virtio-win-prewhql-0.1-94

How reproducible:
only once

Steps to Reproduce:
1. boot guest
/bin/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga qxl  \
    -global qxl-vga.vram_size=33554432  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20141124-184023-OgVOcYs6,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20141124-184023-OgVOcYs6,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20141124-184023-OgVOcYs6,path=/tmp/seabios-20141124-184023-OgVOcYs6,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20141124-184023-OgVOcYs6,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -device nec-usb-xhci,id=usbtest,bus=pci.0,addr=04 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=05 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win8-32.1-virtio.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:a9:aa:ab:ac:ad,id=idVEYbqn,vectors=4,netdev=id0yTnfc,bus=pci.0,addr=06  \
    -netdev tap,id=id0yTnfc,vhost=on,vhostfd=26,fd=25  \
    -m 32768  \
    -smp 16,maxcpus=16,cores=4,threads=2,sockets=2  \
    -cpu 'Opteron_G4',+sep,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -device usb-hub,id=usb-hub1,bus=usbtest.0,port=1 \
    -device usb-mouse,id=usb-testdev,bus=usbtest.0,port=1.1  \
    -spice port=3000,password=123456,addr=0,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off \
    -enable-kvm
2.
3.

Actual results:
guest BSOD with error ' MEMORY_MANAGEMENT'

Expected results:
no bsod and boot up successfully

Additional info:

2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************
 
MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 00001236, The subtype of the bugcheck.
Arg2: 87a43f60
Arg3: 87a43fec
Arg4: 00000080
 
Debugging Details:
------------------
 
 
BUGCHECK_STR:  0x1a_1236
 
DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
 
PROCESS_NAME:  System
 
CURRENT_IRQL:  0
 
ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre
 
LAST_CONTROL_TRANSFER:  from 815b0705 to 815625d4
 
STACK_TEXT:  
8e577af0 815b0705 0000001a 00001236 87a43f60 nt!KeBugCheckEx
8e577b38 820dcb09 87a43f60 0000021a 84bdd140 nt! ?? ::FNODOBFM::`string'+0x3477f
8e577b54 820e4361 00000000 00000000 84bdd108 rdyboost!ST_STORE<SMD_TRAITS>::StReleaseRegion+0x4c
8e577b78 820e41e0 84bdd108 00000004 84bdd108 rdyboost!ST_STORE<SMD_TRAITS>::StDmCleanup+0x166
8e577b88 820e416b 84bdd108 8e577bc0 820e4582 rdyboost!ST_STORE<SMD_TRAITS>::StEmptyStore+0x4b
8e577b94 820e4582 8e577bb8 820f85d8 84bdd108 rdyboost!ST_STORE<SMD_TRAITS>::StChangeState+0x15
8e577bc0 820d92e8 00000000 87596340 84549640 rdyboost!ST_STORE<SMD_TRAITS>::StWorkItemProcess+0xb64a
8e577c00 820e65d1 098bfbf6 00000000 87596340 rdyboost!SMKM_STORE<SMD_TRAITS>::SmStWorker+0xfc
8e577c30 814fc77a 84bdd108 12028f19 00000000 rdyboost!SMKM_STORE<SMD_TRAITS>::SmStWorkerThread+0x1d
8e577c70 81577fe1 820e65b4 825b7e28 00000000 nt!PspSystemThreadStartup+0x58
8e577c7c 00000000 00000000 00000003 33504f74 nt!KiThreadStartup+0x15
 
 
STACK_COMMAND:  kb
 
FOLLOWUP_IP:
rdyboost!ST_STORE<SMD_TRAITS>::StReleaseRegion+4c
820dcb09 6a00            push    0
 
SYMBOL_STACK_INDEX:  2
 
SYMBOL_NAME:  rdyboost!ST_STORE<SMD_TRAITS>::StReleaseRegion+4c
 
FOLLOWUP_NAME:  MachineOwner
 
MODULE_NAME: rdyboost
 
IMAGE_NAME:  rdyboost.sys
 
DEBUG_FLR_IMAGE_TIMESTAMP:  52412c08
 
BUCKET_ID_FUNC_OFFSET:  4c
 
FAILURE_BUCKET_ID:  0x1a_1236_rdyboost!ST_STORE_SMD_TRAITS_::StReleaseRegion
 
BUCKET_ID:  0x1a_1236_rdyboost!ST_STORE_SMD_TRAITS_::StReleaseRegion
 
ANALYSIS_SOURCE:  KM
 
FAILURE_ID_HASH_STRING:  km:0x1a_1236_rdyboost!st_store_smd_traits_::streleaseregion
 
FAILURE_ID_HASH:  {537671c7-bcf5-eadb-b8eb-6abfd076b08f}
 
Followup: MachineOwner
---------

Comment 3 ShupingCui 2014-11-25 06:01:22 UTC
Host cpu info:

processor	: 31
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 1
model name	: AMD Opteron(TM) Processor 6274                 
stepping	: 2
microcode	: 0x6000626
cpu MHz		: 2199.996
cache size	: 2048 KB
physical id	: 1
siblings	: 16
core id		: 7
cpu cores	: 8
apicid		: 79
initial apicid	: 47
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid amd_dcm aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext perfctr_core perfctr_nb arat cpb hw_pstate npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
bogomips	: 4399.77
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb

# free -m
              total        used        free      shared  buff/cache   available
Mem:          64379        1925       58505           8        3948       61822
Swap:         32191           0       32191

Comment 5 Ronen Hod 2014-11-25 16:04:37 UTC
QE, ShupingCui,
Can you please try to reproduce it. It looks like unrelated to virtio, but who knows.

Comment 6 ShupingCui 2014-11-26 02:26:05 UTC
(In reply to Ronen Hod from comment #5)
> QE, ShupingCui,
> Can you please try to reproduce it. It looks like unrelated to virtio, but
> who knows.

Hi Ronen,

OK, I will try 20 times reboot test, and update the result.

Comment 11 lijin 2015-04-02 08:15:25 UTC
try with build 94,reboot guest 30+ times,cannot reproduce this issue:guest bsod twice,but it's related to bug1167614,the error code is NOT 'MEMORY_MANAGEMENT';
try with build102,reboot guest 30+ times,guest works fine,no BSOD.

Comment 13 lijin 2015-07-17 07:23:39 UTC
change status to verified according to comment#11

Comment 15 errata-xmlrpc 2015-11-24 08:46:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.