Bug 1167600 - virt-manager show a domain processor rather than a domain performance when input "-show-domain-performance" in terminal
Summary: virt-manager show a domain processor rather than a domain performance when in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-25 06:57 UTC by Ye Lingfei
Modified: 2015-11-19 05:22 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.2.0-1-el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:22:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Description Ye Lingfei 2014-11-25 06:57:29 UTC
Description of problem:
virt-manager show a domain processor rather than a domain performance when input "-show-domain-performance" in terminal

Version-Release number of selected component (if applicable):
virt-manager-1.1.0-8.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Input "virt-manager --show-domain-performance=b7490d54-0f89-495f-a31a-94c743a07536 -c qemu:///system" in terminal
ps: with a right domain guest uuid 

Actual results:
virt-manager show a domain processor 

Expected results:
virt-manager show a domain performance

Additional info:
1.The details page comes out, but the "Details" button is not actived.

2.What's more, input "virt-manager --show-domain-editor=1054de4a-e4f3-9f6d-0f8b-79232fc8b3dd -c qemu:///system", the details page comes out, but the "Details" button is not actived.

Comment 2 Giuseppe Scrivano 2014-11-25 10:45:21 UTC
patch sent upstream:

https://www.redhat.com/archives/virt-tools-list/2014-November/msg00128.html

Comment 3 Giuseppe Scrivano 2014-11-26 07:44:12 UTC
fix upstream now:

commit ad1f0fa08180c5f42da94d5931878f6ca6b977c8
Author: Giuseppe Scrivano <gscrivan>
Date:   Tue Nov 25 11:40:31 2014 +0100

    details: fix --show-domain-performance
    
    the introspection page could be missing, in this case the tabs values
    are shifted by one.  The new code looks for the correct row number
    before selecting it.
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1167600
    
    Signed-off-by: Giuseppe Scrivano <gscrivan>

Comment 7 fwu 2015-05-11 10:06:56 UTC
I can reproduce this issue with package:
virt-manager-1.1.0-8.el7.noarch

Steps:
1.Input "virt-manager --show-domain-performance=b7490d54-0f89-495f-a31a-94c743a07536 -c qemu:///system" in terminal
ps: with a right domain guest uuid

Results:
virt-manager show a domain's processor details and the "Details" button is not actived.

Then try to verify with new build:
virt-manager-1.2.0-2.el7.noarch

Steps:
1.Input "virt-manager --show-domain-performance=b7490d54-0f89-495f-a31a-94c743a07536 -c qemu:///system" in terminal
ps: with a right domain guest uuid

Results:
virt-manager show a domain performance well, but the "Details" button is still not actived as well.

Addtional info:
Input "virt-manager --show-domain-editor=b7490d54-0f89-495f-a31a-94c743a07536 -c qemu:///system" in terminal, the "Details" button is not actived as well.

Please check the additional info and my results when available, grateful to your help!

Comment 8 Giuseppe Scrivano 2015-05-11 11:58:58 UTC
that is a minor UI glitch that we can leave for now, the issue was that the panel was not showed at all.

Comment 9 fwu 2015-05-13 02:34:31 UTC
(In reply to Giuseppe Scrivano from comment #8)
> that is a minor UI glitch that we can leave for now, the issue was that the
> panel was not showed at all.


Thanks for your help!

According to your reply and Comment 7, move this bug from ON_QA to VERIFIED.

Comment 11 errata-xmlrpc 2015-11-19 05:22:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.