Bug 116766 - IDE CD DMA + 4GB ia32e box == instant panic
IDE CD DMA + 4GB ia32e box == instant panic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-02-24 19:02 EST by Bill Nottingham
Modified: 2015-01-04 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 22:58:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the issue (426 bytes, patch)
2004-07-16 21:57 EDT, Suresh Siddha
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2004-02-24 19:02:20 EST
This is with kernel-2.6.3-1.104.

Booting the kernel and then accessing the CD (mount, checkisomd5) with
DMA gives an immediate panic, with a backtrace of:
 mark_clean + 172, pci_unmap_sg + 68, ide_destroy_dmatable + 42,
__ide_dma_end + 101, ide_cd:cdrom_read_intr:74

Booting with mem=4096M works OK.
DMA HD access works OK.

hdparm -d0 /dev/hdc causes it to then work OK.
Comment 1 Bill Nottingham 2004-03-04 10:54:49 EST
Works in 2.4, FWIW.
Comment 2 Dave Jones 2004-06-14 19:50:28 EDT
did this get fixed ?
Comment 3 Bill Nottingham 2004-06-28 16:56:08 EDT
Appears to have been.
Comment 4 Bill Nottingham 2004-07-09 18:37:02 EDT
It's baaaaaaaaaaack....

2.6.7-1.478

Mounting a CD fails, says it can't read the filesystem.
chkisomd5sum on the CD device panics.
Comment 5 Suresh Siddha 2004-07-16 21:57:53 EDT
Created attachment 101992 [details]
Patch fixing the issue

With swiotlb, pci_unmap_sg() was doing pci_unmap_single() instead of 
swiotlb_unmap_sg(). This will fail because, swiotlb_map_sg() is
setting up virtual address in sg->dma_address and pci_unmap_single()
expects physical address.

Attached patch will fix the issue.
Comment 6 Suresh Siddha 2004-11-02 17:05:40 EST
This issue is fixed in the base sometime back. Sorry forgot to update 
this bugzilla.
Comment 7 Bill Nottingham 2004-11-02 22:58:13 EST
Yeah, haven't seen this recently.

Note You need to log in before you can comment on or make changes to this bug.