Bug 1167765 - qemu-kvm-rhev process quit when hotplugging memory size overcommit host memory
Summary: qemu-kvm-rhev process quit when hotplugging memory size overcommit host memory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Igor Mammedov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-25 11:32 UTC by FuXiangChun
Modified: 2015-12-04 16:21 UTC (History)
6 users (show)

Fixed In Version: qemu 2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:21:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description FuXiangChun 2014-11-25 11:32:37 UTC
Description of problem:
Example: host memory size 8G. hotplug 14G size memory to qemu-kvm. 

result:
(qemu) object_add memory-backend-ram,id=mem1,size=15G
Cannot set up guest memory 'mem1': Cannot allocate memory

From QE pov. qemu-kvm should prevent this operation(As overcommit). and print a friendly information.  At least, qemu-kvm process shouldn't quit.  I am not sure upstream tool if have resolved this issue.  If need.  I will test it with virsh.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.2-13.el7.x86_64
3.10.0-208.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M pc -enable-kvm -m 4G,slots=4,maxmem=80G -monitor stdio

2.(qemu) object_add memory-backend-ram,id=mem1,size=14G
3.

Actual results:
qemu-kvm-rhev process quit
Cannot set up guest memory 'mem1': Cannot allocate memory

Expected results:


Additional info:

Comment 2 Igor Mammedov 2015-02-12 12:53:45 UTC
fixed upstream, please retest when 7.2 build is available

Comment 3 Miroslav Rezanina 2015-06-18 06:40:22 UTC
Moving to modified state as it is not TestOnly.

Comment 5 Lin Chen 2015-06-23 07:44:18 UTC
reproduce:
host kernel:3.10.0-267.el7.x86_64
host qemu:  qemu-kvm-rhev-2.1.2-21.el7.x86_64

QE retested this bug on the above environment,then got the same result.
So, the bug is reproduced on the above environment.


verify:
host kernel:3.10.0-267.el7.x86_64
host qemu:  qemu-kvm-rhev-2.3.0-4.el7.x86_64

QE retested this bug on the above environment. After hot-plugging memory size overcommit host memory, qemu-kvm process didn't quit and printed a friendly error info.
So, the bug fixed.

Comment 6 huiqingding 2015-06-24 03:44:28 UTC
Based on Comment 5, set this bug to VERIFIED.

Best regards,
Huiqing

Comment 8 errata-xmlrpc 2015-12-04 16:21:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.