Bug 1167855 - gdm does now show up, startx works
Summary: gdm does now show up, startx works
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 7.1
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-25 14:15 UTC by Martin Žember
Modified: 2015-11-19 04:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 04:23:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2198 normal SHIPPED_LIVE Xorg server and driver bug fix and enhancement update 2015-11-19 08:04:34 UTC

Description Martin Žember 2014-11-25 14:15:12 UTC
Description of problem:
gdm does not display anything besides the "7" background.
Switching to another console and launchinx 'startx' opens gnome.

Version-Release number of selected component (if applicable):
RHEL-7.0 kernel kernel-3.10.0-123.el7.x86_64, but also with other kernels:
3.10.0-205.el7.x86_64
3.10.0-175.el7.x86_64

RHEL-7.0 packages, but also with a system update of all packages to RHEL-7.1-20141121.n.0, like:
gdm-3.8.4-32.el7.x86_64
gnome-shell-3.8.4-45.el7.x86_64
gnome-settings-daemon-3.8.6.1-12.el7.x86_64

How reproducible:
Always

Steps to Reproduce:

Actual results:
No GDM; the system is unusable -- not possible to reliably lock the screen when away (this might be a separate issue: most of the times, the correct password is being rejected when unlocking; and if Ctrl+Alt+Backspace is enabled, locking is ineffective)

Expected results:
A login prompt, a session

Additional info:
journalctl keeps displaying these errors:

Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: [drm:intel_pipe_config_compare] *ERROR* mismatch in adjusted_mode.crtc_clock (expected 148500, found 0)
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: ------------[ cut here ]------------
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: WARNING: at drivers/gpu/drm/i915/intel_display.c:10197 check_crtc_state+0x235/0x350 [i915]()
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: pipe state doesn't match!
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: Modules linked in: btrfs zlib_deflate raid6_pq xor vfat msdos fat xfs libcrc32c binfmt_misc xt_CHECKSUM ipt_MASQUERADE tun 
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi iwlwifi uvcvideo videobuf2_vmalloc videobuf2_memops serio_r
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: CPU: 2 PID: 5156 Comm: X Tainted: G        W   --------------   3.10.0-205.el7.x86_64 #1
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: Hardware name: LENOVO 20ARS19C0B/20ARS19C0B, BIOS GJET72WW (2.22 ) 02/21/2014
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  ffff88030bb4b8d8 00000000ab68c73b ffff88030bb4b890 ffffffff81603c07
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  ffff88030bb4b8c8 ffffffff8106e241 ffff88030ccc66f8 ffff88030bb4b968
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  ffff880308d10000 ffff88030ccc6000 ffff880308d10340 ffff88030bb4b930
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: Call Trace:
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff81603c07>] dump_stack+0x19/0x1b
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff8106e241>] warn_slowpath_common+0x61/0x80
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff8106e2bc>] warn_slowpath_fmt+0x5c/0x80
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa021b7bb>] ? intel_pipe_config_compare+0x73b/0xab0 [i915]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa021d0e5>] check_crtc_state+0x235/0x350 [i915]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa022b92f>] intel_modeset_check_state+0x29f/0x7c0 [i915]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa022bee5>] intel_set_mode+0x25/0x30 [i915]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa022ce4c>] intel_crtc_set_config+0x92c/0xe00 [i915]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa0068761>] drm_mode_set_config_internal+0x61/0xe0 [drm]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa006c148>] drm_mode_setcrtc+0xe8/0x5c0 [drm]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffffa005cb6c>] drm_ioctl+0x1ec/0x660 [drm]
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff811d95e5>] do_vfs_ioctl+0x2e5/0x4c0
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff8126e70e>] ? file_has_perm+0xae/0xc0
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff811c89a1>] ? __sb_end_write+0x31/0x60
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff811d9861>] SyS_ioctl+0xa1/0xc0
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel:  [<ffffffff81613c29>] system_call_fastpath+0x16/0x1b
Nov 25 14:50:27 dhcp-25-60.brq.redhat.com kernel: ---[ end trace 81c2b0951231270d ]---

Comment 2 Martin Žember 2014-11-25 14:56:37 UTC
# journalctl -u gdm.service
-- Logs begin at Tue 2014-11-25 13:44:26 CET, end at Tue 2014-11-25 15:52:11 CET. --
Nov 25 13:45:11 dhcp-25-60.brq.redhat.com systemd[1]: Starting GNOME Display Manager...
Nov 25 13:45:11 dhcp-25-60.brq.redhat.com systemd[1]: Started GNOME Display Manager.
Nov 25 13:45:36 dhcp-25-60.brq.redhat.com gdm[2450]: Failed to set slave bus name on parent: Timeout was reached

Comment 3 Scott Dodson 2014-12-05 18:28:22 UTC
The kernel traceback is the same as in Bug 1163074 FWIW.

Comment 5 Martin Žember 2014-12-11 16:52:26 UTC
RHEL-7.1-Beta-1.5 has the same issue. 

In the startx mode, I encounter states when the screen flashes like a discotheque and I am able to reproduce it. But I doubt it will be dealt with, it is a low severity issue anyway.

I wonder what have I done to the system to break the gdm.

Comment 6 Martin Žember 2015-01-13 10:39:34 UTC
GDM works now. I am trying to find what has caused this, but I do not know. I have tried this command (and similar yum commands), but I see only an error:

# yum history packages-list
Error: Failed history packages-list

Comment 18 errata-xmlrpc 2015-11-19 04:23:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html


Note You need to log in before you can comment on or make changes to this bug.