Bug 116787 - packaged jfs_mkfs throws error, compiled doesn't
packaged jfs_mkfs throws error, compiled doesn't
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jfsutils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-25 01:56 EST by francisco
Modified: 2013-07-02 22:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:29:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description francisco 2004-02-25 01:56:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.6a)
Gecko/20040107

Description of problem:
Running "Fedora Core release 1.90 (FC2 Test 1)" on a Dell 1750,
patched up to last night and running kernel 2.6.3-1.97smp.  Whenever i
run jfs_mkfs i was getting an error message, so i grabbed the 1.1.3
src for jfsutils in order to compile a jfs_mkfs with more debugging
clues.  But by compiling the stock src and running the resultant
binary, i was able to format the same partition.

That is,

# jfs_mkfs /dev/sda2
jfs_mkfs version 1.1.3, 05-Sep-2003
Warning!  All data on device /dev/sda2 will be lost!

Continue? (Y/N) y
The specified disk did not finish formatting.
# mkfs/jfs_mkfs /dev/sda2
mkfs/jfs_mkfs version 1.1.3, 05-Sep-2003
ujfs_get_dev_size: size = 10487232000
number of blocks = 2560359
Warning!  All data on device /dev/sda2 will be lost!

Continue? (Y/N) y
size of dinode = 512
size of dinode = 512


Format completed successfully.

10241437 kilobytes total disk space.

In the above, jfs_mkfs is the binary that came with the system and
mkfs/jfs_mkfs is the one i compiled.  After succesful formatting by
mkfs/jfs_mkfs, i tried running jfs_mkfs again and it failed the same
way.  mkfs/jfs_mkfs worked again, and i've since been able to mount
and run benchmarks against the jfs partition.  Was the system's
jfsutils built against the wrong libraries?

Version-Release number of selected component (if applicable):
jfsutils-1.1.3-2

How reproducible:
Always

Steps to Reproduce:
1. jfs_mkfs /dev/partition
2.
3.
    

Actual Results:  The specified disk did not finish formatting.

Expected Results:  a formatted partition!

Additional info:
Comment 1 Milan Slanař 2004-04-29 10:16:54 EDT
Should be reopened. The bug is still here in FC2T2 and FC2T3. I cannot
format jfs partition during install. And even recompiling
jfsutils-1.1.4-1.src.rpm didn't help me. BTW version 1.1.6 is already out.
Comment 2 Pedro Fernandes Macedo 2004-05-02 09:24:57 EDT
this bug is happening on FC2T2 and FC2T3 here too. Tried rebuilding
from source and didnt work.
Comment 3 Nathan Ollerenshaw 2004-07-01 22:32:33 EDT
Seeing this on an up2date FC2 system trying to format 1.9TB.

Why was this bug closed?
Comment 4 Pedro Fernandes Macedo 2004-07-01 22:42:23 EDT
There's bug 122603 on the same subject. However , never got an answer
about the things I found out and posted there.

Note You need to log in before you can comment on or make changes to this bug.