Bug 116790 - Kernel panic: IO-APIC + timer doesn't work!
Kernel panic: IO-APIC + timer doesn't work!
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Jim Paradis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 03:28 EST by Josef Möllers
Modified: 2013-08-05 21:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 11:50:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Möllers 2004-02-25 03:28:43 EST
Description of problem:


Version-Release number of selected component (if applicable):
kernel-2.4.21

How reproducible:
Every time

Steps to Reproduce:
1.Just boot the kernel on the mentioned hardware
2.
3.
  
Actual results:
Kernel panic

Expected results:
Kernel boot

Additional info:

We have a problem with a IO-APIC + timer on a RedHat Linux 2.4.21
kernel:
 
    ESR value after enabling vector: 00000000
    Calibrating delay loop... 6107.95 BogoMIPS
    CPU: Trace cache: 12K uops, L1 D cache: 8K
    CPU: L2 cache: 512K
    CPU: Hyper-Threading is disabled
    Intel machine check reporting enabled on CPU#1.
    CPU1: Intel(R) Xeon(TM) CPU 3.06GHz stepping 09
    Total of 2 processors activated (6945.17 BogoMIPS).
    ENABLING IO-APIC IRQs
    Setting 7 in the phys_id_present_map
    ...changing IO-APIC physical APIC ID to 7 ... ok.
    Setting 8 in the phys_id_present_map
    ...changing IO-APIC physical APIC ID to 8 ... ok.
    Setting 9 in the phys_id_present_map
    ...changing IO-APIC physical APIC ID to 9 ... ok.
    ..TIMER: vector=0x31 pin1=2 pin2=0
    ..MP-BIOS bug: 8254 timer not connected to IO-APIC
    ...trying to set up timer (IRQ0) through the 8259A ...
    ..... (found pin 0) ... failed.
    timer doesn't work through the IO-APIC - disabling NMI Watchdog!
    ...trying to set up timer as Virtual Wire IRQ... failed.
    ...trying to set up timer as ExtINT IRQ... failed :(.
    Kernel panic: IO-APIC + timer doesn't work! pester mingo@redhat.com
    In idle task - not syncing
 
The hardware is
 
    Northbridge:    Intel E7505 Chipset, Plumas
    Southbridge:    Intel ICH3S
    Super-I/O:              NS PC87366/VLA
    FWH:                    SST 49LF004A
    Giga-LAN:               Intel 82546EB
    SCSI:                   Adaptec 7902
    Processors:             2 X Prestonia processors, 533 MHz FSB, 2.8
GHz -
    3.2 GHz
    Memory:         1 - 6 registered DIMMs, PC2100R, DDR 266
    Video:          ATI Rage XL
Comment 1 Arjan van de Ven 2004-02-25 03:33:18 EST
this looks like a bios bug in the mptable...
Comment 2 Josef Möllers 2004-11-22 04:26:37 EST
Although the customer had reported this bug as (very!) important,
neither he nor we were able to reproduce the problem. Systems which
have shown this problem have been replaced and the customer is now
satisfied and has released the systems for productive work. We now
assume that this was an intermittent board fault caused by defective
components or problems during the manufacturing process, not a serial
fault.

Please close this bug.
Comment 3 Jim Paradis 2004-11-22 11:50:45 EST
...or maybe a firmware bug fixed by the vendor.

In either case, closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.