Bug 1167943 - virt-who-0.10-8.el6 traceback when reporting between RHEV-M and 5 series satellite
Summary: virt-who-0.10-8.el6 traceback when reporting between RHEV-M and 5 series sate...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who
Version: 6.5
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: 6.5
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-25 16:52 UTC by Aaron Thomas
Modified: 2019-07-11 08:23 UTC (History)
5 users (show)

Fixed In Version: virt-who-0.12-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:15:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1377 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2015-07-20 17:58:35 UTC

Description Aaron Thomas 2014-11-25 16:52:56 UTC
Description of problem:
-----------------------------------------
virt-who-0.10-8.el6 traceback when reporting between RHEV-M and 5 series satellite. Everything is working as intended on version virt-who-0.8-9.el6, upon upgrading to virt-who 0.10-8.el6 we see the following traceback occur:


Traceback:
-----------------------------------------
014-11-25 10:34:43,298 [ERROR]  @satellite.py:160 - Unable to send host/guest assocaition to the satellite:
Traceback (most recent call last):
  File "/usr/share/virt-who/manager/satellite/satellite.py", line 158, in hypervisorCheckIn
    self.server.registration.virt_notify(hypervisor_systemid["system_id"], plan)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1243, in request
    headers
ProtocolError: <ProtocolError for sun-x4200-1.gsslab.rdu2.redhat.com:443/XMLRPC: 404 Not Found>


Version-Release number of selected component (if applicable):
-----------------------------------------
virt-who-0.10-8.el6


How reproducible:
-----------------------------------------
Easily reproducible, take a working configuration of virt-who reporting between RHEV-M and 5.6 satellite upgrade virt-who to the latest version.


Steps to Reproduce:
-----------------------------------------
1. configure virt-who to report from RHEV-M to satellite 5.6
2. yum upgrade virt-who -y
3. restart virt-who service and wait for traceback


Actual results:
-----------------------------------------
ProtocolError: <ProtocolError for sun-x4200-1.gsslab.rdu2.redhat.com:443/XMLRPC: 404 Not Found>


Expected results:
-----------------------------------------
virt-who reports UUID association to satellite 5.6 

Additional info: /etc/sysconfig/virt-who
-----------------------------------------

VIRTWHO_BACKGROUND=1

# Enable debugging output.
VIRTWHO_DEBUG=1

# Register guests using RHEV-M
VIRTWHO_RHEVM=1

# Options for RHEV-M mode
VIRTWHO_RHEVM_OWNER=1979710
VIRTWHO_RHEVM_ENV=Library
VIRTWHO_RHEVM_SERVER=https://sun-x4200-1.gsslab.rdu2.redhat.com:443
VIRTWHO_RHEVM_USERNAME=admin@internal
VIRTWHO_RHEVM_PASSWORD=**********

# Option for Satellite backend
VIRTWHO_SATELLITE_SERVER=satellite-sysmgmt.usersys.redhat.com
VIRTWHO_SATELLITE_USERNAME=**********
VIRTWHO_SATELLITE_PASSWORD=**********

Comment 2 Radek Novacek 2014-11-26 12:45:12 UTC

*** This bug has been marked as a duplicate of bug 1167451 ***

Comment 4 Radek Novacek 2015-02-26 09:59:02 UTC
I've tried to connect to given server with recent upstream git snapshot of virt-who and it doesn't fail with 404. Although I don't know password to that system so I got stuck on Unauthorized.

Aaron, do you think you try to reproduce it with rebased version of virt-who that will land today or tomorrow?

Comment 5 Radek Novacek 2015-02-27 19:38:18 UTC
Fixed by rebase to virt-who-0.12-1.el6.

Comment 7 Liushihui 2015-04-07 02:43:30 UTC
Verified it on virt-who-0.12-2.el6.noarch.

Verified version:
virt-who-0.12-2.el6.noarch
subscription-manager-1.14.1-1.el6.x86_64
python-rhsm-1.14.1-1.el6.x86_64
Satellite-5.7.0-RHEL6-re20150108.2-x86_64
rhevm-3.5.1-0.3

Verified process:
1.Register rhel to Satellite-5.7
[root@hp-z220-06 rhn]# rhnreg_ks --username virtwho_test --password=redhat123
[root@hp-z220-06 rhn]# subscription-manager identity
server type: RHN Classic
2.Configure virt-who run at rhevm mode, /etc/sysconfig/virt-who as the following:
[root@hp-z220-06 rhn]# cat /etc/sysconfig/virt-who
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=10
VIRTWHO_SATELLITE5=1
VIRTWHO_RHEVM=1
VIRTWHO_ESX_OWNER=ACME_Corporation
VIRTWHO_ESX_ENV=Library
VIRTWHO_ESX_SERVER=10.66.79.68
VIRTWHO_ESX_USERNAME=Administrator@vsphere.local
VIRTWHO_ESX_PASSWORD=qwer1234P!
3.Restart virt-who service and check the virt-who's log file.
[root@hp-z220-06 rhn]# service virt-who restart
Stopping virt-who:                                         [FAILED]
Starting virt-who:                                         [  OK  ]
[root@hp-z220-06 rhn]# tail -f /var/log/rhsm/rhsm.log
2015-04-07 10:39:13,529 [DEBUG]  @satellite.py:60 - Initializing satellite connection to https://satellite57.redhat.com/XMLRPC
2015-04-07 10:39:13,529 [INFO]  @satellite.py:66 - Initialized satellite connection
2015-04-07 10:39:13,529 [INFO]  @satellite.py:147 - Sending update in hosts-to-guests mapping: {'b907a9b3-1e68-4001-afce-011f16d3a779': [], '7a1a3ef3-4d6b-40fe-ae13-32e5289a7f95': []}
2015-04-07 10:39:13,530 [DEBUG]  @satellite.py:152 - Loading systemid for b907a9b3-1e68-4001-afce-011f16d3a779
2015-04-07 10:39:13,530 [DEBUG]  @satellite.py:74 - Loading system id info from /var/lib/virt-who/hypervisor-systemid-b907a9b3-1e68-4001-afce-011f16d3a779
2015-04-07 10:39:13,530 [DEBUG]  @satellite.py:155 - Building plan for hypervisor b907a9b3-1e68-4001-afce-011f16d3a779: []
2015-04-07 10:39:13,530 [DEBUG]  @satellite.py:159 - Sending plan: [[0, 'exists', 'system', {'uuid': '0000000000000000', 'identity': 'host'}], [0, 'crawl_began', 'system', {}], [0, 'crawl_ended', 'system', {}]]
2015-04-07 10:39:13,592 [DEBUG]  @satellite.py:152 - Loading systemid for 7a1a3ef3-4d6b-40fe-ae13-32e5289a7f95
2015-04-07 10:39:13,592 [DEBUG]  @satellite.py:74 - Loading system id info from /var/lib/virt-who/hypervisor-systemid-7a1a3ef3-4d6b-40fe-ae13-32e5289a7f95
2015-04-07 10:39:13,592 [DEBUG]  @satellite.py:155 - Building plan for hypervisor 7a1a3ef3-4d6b-40fe-ae13-32e5289a7f95: []
2015-04-07 10:39:13,593 [DEBUG]  @satellite.py:159 - Sending plan: [[0, 'exists', 'system', {'uuid': '0000000000000000', 'identity': 'host'}], [0, 'crawl_began', 'system', {}], [0, 'crawl_ended', 'system', {}]]

Result:
virt-who can send the host/gust mappping to satellite5.7 server and the hyeprvisor will show on the satellite web UI. Therefore, verify it.

Comment 9 errata-xmlrpc 2015-07-22 07:15:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1377.html


Note You need to log in before you can comment on or make changes to this bug.