Bug 1167948 - IOError: [Errno 9] Bad file descriptor
Summary: IOError: [Errno 9] Bad file descriptor
Keywords:
Status: CLOSED DUPLICATE of bug 1103452
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.1
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:cb33063161af75e13ab3d72bf9f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-25 17:00 UTC by Marian Csontos
Modified: 2014-11-25 17:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-25 17:47:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (423.32 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: anaconda.log (7.80 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: environ (404 bytes, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: lsblk_output (1.81 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: nmcli_dev_list (989 bytes, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: os_info (510 bytes, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: program.log (33.80 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: storage.log (91.24 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: syslog (59.26 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: ifcfg.log (1.10 KB, text/plain)
2014-11-25 17:00 UTC, Marian Csontos
no flags Details
File: packaging.log (138.13 KB, text/plain)
2014-11-25 17:01 UTC, Marian Csontos
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1162290 None None None Never

Internal Links: 1162290

Description Marian Csontos 2014-11-25 17:00:21 UTC
Description of problem:
Again nothing but installing system... Different stack trace but likely same issue than Bug 1162290

Version-Release number of selected component:
anaconda-19.31.109-1

The following was filed automatically by anaconda:
anaconda 19.31.109-1 exception report
Traceback (most recent call first):
  File "<string>", line 100, in next
  File "/usr/lib/python2.7/site-packages/yum/comps.py", line 822, in add
    for event, elem in parser:
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 964, in _getGroups
    self._comps.add(groupfile)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1102, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3836, in selectGroup
    thesegroups = self.comps.return_groups(grpid)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1294, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1409, in _applyYumSelections
    self._selectYumGroup("core")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1513, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 123, in checkSoftwareSelection
    self.payload.checkSoftwareSelection()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 211, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 9] Bad file descriptor

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   repo=http://10.34.48.241/pub/rhel/nightly/latest-RHEL-7/compose/Server/x86_64/os
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-206.el7.x86_64
product:        Red Hat Enterprise Linux 7"
release:        Red Hat Enterprise Linux Workstation release 7.1 Beta (Maipo)
release_type:   pre-release
type:           anaconda
version:        Red Hat Enterprise Linux Workstation"

Comment 1 Marian Csontos 2014-11-25 17:00:31 UTC
Created attachment 961290 [details]
File: anaconda-tb

Comment 2 Marian Csontos 2014-11-25 17:00:34 UTC
Created attachment 961291 [details]
File: anaconda.log

Comment 3 Marian Csontos 2014-11-25 17:00:36 UTC
Created attachment 961292 [details]
File: environ

Comment 4 Marian Csontos 2014-11-25 17:00:38 UTC
Created attachment 961293 [details]
File: lsblk_output

Comment 5 Marian Csontos 2014-11-25 17:00:40 UTC
Created attachment 961294 [details]
File: nmcli_dev_list

Comment 6 Marian Csontos 2014-11-25 17:00:43 UTC
Created attachment 961295 [details]
File: os_info

Comment 7 Marian Csontos 2014-11-25 17:00:46 UTC
Created attachment 961296 [details]
File: program.log

Comment 8 Marian Csontos 2014-11-25 17:00:50 UTC
Created attachment 961297 [details]
File: storage.log

Comment 9 Marian Csontos 2014-11-25 17:00:54 UTC
Created attachment 961298 [details]
File: syslog

Comment 10 Marian Csontos 2014-11-25 17:00:57 UTC
Created attachment 961299 [details]
File: ifcfg.log

Comment 11 Marian Csontos 2014-11-25 17:01:02 UTC
Created attachment 961300 [details]
File: packaging.log

Comment 13 David Shea 2014-11-25 17:47:19 UTC
This one we know, at least. It's a python bug.

*** This bug has been marked as a duplicate of bug 1103452 ***


Note You need to log in before you can comment on or make changes to this bug.