Bug 1167959 - Anaconda on Server DVD put on the usb by livecd-iso-to-disk --efi hangs in hub due to "probing storage"
Anaconda on Server DVD put on the usb by livecd-iso-to-disk --efi hangs in hu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1111722 (view as bug list)
Depends On:
Blocks: F21FinalBlocker
  Show dependency treegraph
 
Reported: 2014-11-25 12:38 EST by Petr Schindler
Modified: 2016-06-13 08:17 EDT (History)
16 users (show)

See Also:
Fixed In Version: anaconda-21.48.21-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-04 22:26:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updates.img (41.05 KB, application/x-gzip)
2014-11-25 15:02 EST, Brian Lane
no flags Details

  None (edit)
Description Petr Schindler 2014-11-25 12:38:16 EST
Description of problem:
I put server dvd on to usb using livecd-iso-to-disk --format --reset-mbr --efi /home/pschindl/Fedora/Fedora-Server-DVD-x86_64-21_TC4.iso /dev/sdb

When I boot to anaconda, I can see Probing storage in Installation source and Installation destination.

On the end of program.log of anaconda there is 'running... dosfsck /dev/sdc1'
When I run dosfsck /dev/sdc1 I got this output:
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.

/dev/sdc is usb with installation dvd.

Version-Release number of selected component (if applicable):
livecd-tools-21.4-1.fc21.x86_64

How reproducible:
Always on UEFI. Tested on two workstations and with two usbs

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Brian Lane 2014-11-25 13:55:54 EST
What happens if you run sync after litd is done? What if you run dosfsck on it before removing it?
Comment 2 Brian Lane 2014-11-25 14:46:31 EST
Actually, I can reproduce this here. It looks like dosfsck doesn't deal well with GPT maybe? The actual problem is that this is a side-effect of blivet running fsck before getting disk minimum size info for everything -- it gets stuck and needs to run in non-interactive mode.
Comment 3 Brian Lane 2014-11-25 15:02:02 EST
Created attachment 961362 [details]
updates.img

Give this updates.img a try.
Comment 4 Fedora Blocker Bugs Application 2014-11-25 16:50:54 EST
Proposed as a Blocker for 21-final by Fedora user bcl using the blocker tracking app because:

 UEFI Installation from a USB using a vfat filesystem should succeed. Without the fix for this it will hang waiting for user input to dosfsck.
Comment 5 Brian Lane 2014-11-25 17:12:56 EST
blivet master commit 95cbfcb069
Comment 6 Adam Williamson 2014-11-25 17:15:41 EST
The Alpha criteria has this little bit in "Installation Requirements":

"Except where otherwise specified, each of these requirements applies to all supported configurations described above. These requirements do not apply to images which do not use the installer. "

which probably should be read as applying to Beta and Final too (and I should add it in there). Thus this violates pretty much all the Installer Requirements for a UEFI install from a livecd-iso-to-disk-written stick, which is a 'supported configuration' from Beta onwards due to this Beta "Initialization requirements" criterion:

"All release-blocking images must boot in their supported configurations.

Supported media types

Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."

combined with this bit from the matching Alpha criterion:

"Supported firmware types

Release-blocking images must boot from all system firmware types that are commonly found on the primary architectures."
Comment 7 Scott Suehle 2014-11-26 14:56:44 EST
Discussed at today's blocker review meeting [1]. Accepted as a blocker. This bug is a clear violation of several criteria, namely: All release-blocking images must boot in their supported configurations. Fix committed above.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/
Comment 8 Fedora Update System 2014-11-26 15:47:17 EST
anaconda-21.48.17-1.fc21, python-blivet-0.61.11-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.11-1.fc21,anaconda-21.48.17-1.fc21
Comment 9 Fedora Update System 2014-11-27 14:29:03 EST
Package anaconda-21.48.17-1.fc21, python-blivet-0.61.11-1.fc21, pyparted-3.10.2-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.17-1.fc21 python-blivet-0.61.11-1.fc21 pyparted-3.10.2-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.11-1.fc21,anaconda-21.48.17-1.fc21
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-11-29 15:59:26 EST
Package pyparted-3.10.2-1.fc21, python-blivet-0.61.12-1.fc21, anaconda-21.48.18-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.10.2-1.fc21 python-blivet-0.61.12-1.fc21 anaconda-21.48.18-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.12-1.fc21,anaconda-21.48.18-1.fc21
then log in and leave karma (feedback).
Comment 11 Kamil Páral 2014-12-01 07:38:40 EST
I have created a flash drive from RC1, and it seems to work correctly for me, the installation destination has finished disk probing correctly. But I can't test starting the actual installation at the moment, so waiting for pschindl's confirmation as well.
Comment 12 Petr Schindler 2014-12-01 07:41:48 EST
This bug is fixed in RC1. Tested on machine where I saw problem before.
Comment 13 Fedora Update System 2014-12-04 22:26:45 EST
anaconda-21.48.21-1.fc21, python-blivet-0.61.13-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Kamil Dudka 2016-06-13 08:17:59 EDT
*** Bug 1111722 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.