Bug 1167965 - logvol swap --recommended fails [NEEDINFO]
Summary: logvol swap --recommended fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F21FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-11-25 18:19 UTC by Orion Poplawski
Modified: 2015-01-23 09:31 UTC (History)
11 users (show)

Fixed In Version: anaconda-21.48.21-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-05 03:26:36 UTC
vpodzime: needinfo? (dwinter_nospam)


Attachments (Terms of Use)
storage.log (225.64 KB, text/plain)
2014-11-25 18:22 UTC, Orion Poplawski
no flags Details
anaconda.log (3.55 KB, text/plain)
2014-11-25 18:23 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2014-11-25 18:19:11 UTC
Description of problem:

This is with 21_TC4:

15:23:49,504 ERR anaconda: storage configuration failed: The following problem occurred on line 29 of the kickstart file:

Logical volume size "196.05 KiB" must be larger than the volume group extent size of "4096 KiB".

15:24:06,710 INFO anaconda: fs space: 0 B  needed: 2861.02 MiB

Partitioning stanza:

clearpart --all --initlabel --drives=sda
part /boot --size=200 --ondisk=sda
part pv.1 --size=48000 --ondisk=sda --grow
volgroup vg_root pv.1
logvol / --vgname=vg_root --size=3500 --name=root
logvol swap --fstype=swap --vgname=vg_root --recommended --name=swap
logvol /var --vgname=vg_root --size=2000 --name=var
logvol /var/crash --vgname=vg_root --size=20000 --name=crash
zerombr
bootloader --location=mbr

Line 29 is the swap line.

Relevant storage.log appears to be:

15:23:49,200 DEBUG blivet: vg_root size is 74.3 GiB
15:23:49,229 DEBUG blivet: vg vg_root has 74.3 GiB free
15:23:49,256 DEBUG blivet: Adding vg_root-root/3500 MiB to vg_root
15:23:49,284 INFO blivet: added lvmlv vg_root-root (id 118) to device tree
15:23:49,284 INFO blivet: registered action: [120] create device lvmlv vg_root-root (id 118)
15:23:49,286 DEBUG blivet: getFormat('None') returning DeviceFormat instance with object id 122
15:23:49,289 DEBUG blivet:             LVMLogicalVolumeDevice._setFormat: vg_root-root ; current: ext4 ; type: ext4 ;
15:23:49,290 INFO blivet: registered action: [121] create format ext4 filesystem mounted at / on lvmlv vg_root-root (id 118)
15:23:49,295 DEBUG blivet:            DeviceTree.getDevicesByInstance: hidden: False ; incomplete: False ; device_class: <class 'blivet.devices.PartitionDevice'> ;
15:23:49,298 DEBUG blivet:            DeviceTree.getDevicesByInstance returned ['sda1', 'sda2']
15:23:49,300 INFO blivet: Detected 1024 MiB of memory
15:23:49,338 INFO blivet: Suggested swap size (2048 MiB) exceeds 10 % of disk space, using 10 % of disk space (196.05 KiB) instead.
15:23:49,409 INFO blivet: Swap attempt of 196.05 KiB

Not sure why it thinks 10% of disk space in 196.05 KiB.
Version-Release number of selected component (if applicable):

How reproducible:
Only tested on one machine so far.

Comment 1 Orion Poplawski 2014-11-25 18:22:51 UTC
Created attachment 961335 [details]
storage.log

Comment 2 Orion Poplawski 2014-11-25 18:23:17 UTC
Created attachment 961336 [details]
anaconda.log

Comment 3 Vratislav Podzimek 2014-11-26 09:23:12 UTC
This is already fixed on master, the patch just need to be ported to f21-branch.

Comment 4 Martin Kolman 2014-11-26 13:46:58 UTC
I've tested the backported patch and it fixes the issue.

Comment 5 Scott Suehle 2014-11-26 20:04:47 UTC
Discussed at today's blocker review meeting [1]. Accepted as a punt. More information is needed before we can decide whether this bug would block release. However, in the mean time we would accept a fix for this during freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/

Comment 6 Fedora Update System 2014-11-27 17:22:26 UTC
anaconda-21.48.18-1.fc21,python-blivet-0.61.12-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.18-1.fc21,python-blivet-0.61.12-1.fc21

Comment 7 Fedora Update System 2014-11-27 23:59:24 UTC
pyparted-3.10.2-1.fc21, python-blivet-0.61.12-1.fc21, anaconda-21.48.18-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.12-1.fc21,anaconda-21.48.18-1.fc21

Comment 8 Fedora Update System 2014-11-29 20:59:17 UTC
Package pyparted-3.10.2-1.fc21, python-blivet-0.61.12-1.fc21, anaconda-21.48.18-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.10.2-1.fc21 python-blivet-0.61.12-1.fc21 anaconda-21.48.18-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15910/pyparted-3.10.2-1.fc21,python-blivet-0.61.12-1.fc21,anaconda-21.48.18-1.fc21
then log in and leave karma (feedback).

Comment 9 Kamil Páral 2014-12-01 13:42:51 UTC
This works well in RC1.

Comment 10 Orion Poplawski 2014-12-01 16:24:13 UTC
Yeah, looks good to me.

Comment 11 Mike Ruckman 2014-12-01 16:28:47 UTC
Discussed in 2014-12-01 blocker review. This was fixed and the fix tested in RC1, so we decided to drop it from blocker consideration as the question is mostly moot.

Comment 12 Fedora Update System 2014-12-05 03:26:36 UTC
anaconda-21.48.21-1.fc21, python-blivet-0.61.13-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Daniel Winter 2015-01-22 18:57:31 UTC
In a special setup on prepartitioned space Anaconda still fails with recommended. However setting a fixed swap size works for me.


clearpart --none
part   /boot    --size    100	--onpart=sda2   --fstype ext4 --grow
part   pv.01    --size    100   --onpart=sda5   --grow
volgroup fedorasys pv.01
logvol swap     --recommended   --vgname fedorasys  --fstype swap --name swap
logvol /        --size  34816   --vgname fedorasys  --fstype ext4 --name root
logvol /var     --size  16384   --vgname fedorasys  --fstype ext4 --name var
logvol /tmp     --size  16384   --vgname fedorasys  --fstype ext4 --name tmp
part   pv.02    --size    100   --onpart=sda6 --grow 
volgroup fedoradata pv.02
logvol /local  	--size    100	--vgname fedoradata --fstype ext4 --name local --grow

on similar HW and other os:
free reports 8GB of RAM
vgs reports enough space.

VG         #PV #LV #SN Attr   VSize  VFree 
...
fedorasys    1   4   0 wz--n- 97.62g 23.72g

Comment 14 Vratislav Podzimek 2015-01-23 09:31:10 UTC
(In reply to Daniel Winter from comment #13)
> In a special setup on prepartitioned space Anaconda still fails with
> recommended. However setting a fixed swap size works for me.
> 
> 
> clearpart --none
> part   /boot    --size    100	--onpart=sda2   --fstype ext4 --grow
> part   pv.01    --size    100   --onpart=sda5   --grow
> volgroup fedorasys pv.01
> logvol swap     --recommended   --vgname fedorasys  --fstype swap --name swap
> logvol /        --size  34816   --vgname fedorasys  --fstype ext4 --name root
> logvol /var     --size  16384   --vgname fedorasys  --fstype ext4 --name var
> logvol /tmp     --size  16384   --vgname fedorasys  --fstype ext4 --name tmp
> part   pv.02    --size    100   --onpart=sda6 --grow 
> volgroup fedoradata pv.02
> logvol /local  	--size    100	--vgname fedoradata --fstype ext4 --name local
> --grow
> 
> on similar HW and other os:
> free reports 8GB of RAM
> vgs reports enough space.
> 
> VG         #PV #LV #SN Attr   VSize  VFree 
> ...
> fedorasys    1   4   0 wz--n- 97.62g 23.72g
Could you please attach the output of the 'lsblk' command so that I know how the prepartitioned setup looks like and so that I can reproduce the issue locally? If it really doesn't work, we should resolve this in a separate bug report.


Note You need to log in before you can comment on or make changes to this bug.