Bug 1167982 - dnf.conf man page is in the wrong section
dnf.conf man page is in the wrong section
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-25 14:17 EST by Mario Blättermann
Modified: 2015-02-20 03:32 EST (History)
7 users (show)

See Also:
Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-20 03:32:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Blättermann 2014-11-25 14:17:01 EST
Description of problem:
The dnf.conf man page is in the wrong mandb section.

Version-Release number of selected component (if applicable):
0.6.2-1.fc21

If someone searches for man pages of configuration files, the usual command would be "man 5 name.conf". But this doesn't work for dnf. Please move dnf.conf.8 to dnf.conf.5, where such files usually resides.

With "man man" you'll get more information about the purpose of certain mandb sections.
Comment 1 Michal Luscon 2014-11-26 11:13:36 EST
Thank you for report. We will fix it.
Comment 2 Mario Blättermann 2014-12-11 08:23:10 EST
OK, nothing happened since your response, and a new version of dnf has been released... It's terribly simple to fix, here's the patch:

diff --git a/doc/conf.py b/doc/conf.py
index f16f912..a77d27b 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -241,7 +241,7 @@ man_pages = [
     ('command_ref', 'dnf', u'DNF Command Reference',
      AUTHORS, 8),
     ('conf_ref', 'dnf.conf', u'DNF Configuration Reference',
-     AUTHORS, 8),
+     AUTHORS, 5),
 ]
 
 # If true, show URL addresses after external links.


(You can download it from https://mariobl.fedorapeople.org/Patches/dnf.conf.diff)


After applying the patch I get the following terminal output, and the man page lands in dnf/doc/dnf.conf.5:

[mariobl@localhost dnf]$ make doc-man
[100%] Building manpage documentation
Running Sphinx v1.2.2
loading pickled environment... not yet created
building [man]: all manpages
updating environment: 23 added, 0 changed, 0 removed
reading sources... [100%] user_faq                                             
looking for now-outdated files... none found
pickling environment... done
checking consistency... done
writing... dnf.automatic.8 { } dnf.8 { } dnf.conf.5 { } 
build succeeded.
[100%] Built target doc-man
Comment 3 Michal Luscon 2014-12-12 03:40:01 EST
Hi Mario,

my pull request has not been merged yet, probably as this is a non-critical issue(https://github.com/rpm-software-management/dnf/pull/182). The state of this bugzilla will be updated once the PR is merged. 

Michal
Comment 4 Mario Blättermann 2014-12-12 14:23:42 EST
OK, no problem. I had assumed you have direct write access to the DNF sources, and after all, the maintainer Jan Silhan is in the CC list of this ticket anyway. However, DNF upstream releases come quite often, so we (hopefully!) don't have to wait that long to get this fixed.
Comment 5 Fedora Update System 2015-02-15 19:03:24 EST
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
Comment 6 Fedora Update System 2015-02-17 03:04:18 EST
Package hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.3-2.fc21 dnf-plugins-core-0.1.5-1.fc21 dnf-0.6.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2139/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2015-02-20 03:32:37 EST
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.