Bug 116801 - Error on republishing multipart articles after editing sections
Error on republishing multipart articles after editing sections
Status: NEW
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
:
Depends On: 117503
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 06:44 EST by Cress Rolfe
Modified: 2008-05-01 11:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cress Rolfe 2004-02-25 06:44:46 EST
Description of problem: error on republishing certain MPAs listed 
below. May be related to earlier "unpublishable" items logged by 
Arturo Dell. 


Version-Release number of selected component (if applicable):


How reproducible: occasionally


Steps to Reproduce:
1. go into an already published mpa and into source code of a section
2. amend internal links (deleted old links back to camden.aplaws)
3. saved, republished
  
Actual results: unexpected error message on pressing Publish


Expected results: should publish


Additional info:
1) First one was when I was trying to edit a LINK (deleting the
http://www.camden.aplaws....etc - don't know whether this is relevant)

Content center>Content section: content>Business>Regeneration and
Partnership>Content item: The Regeneration and Partnership Team (en)

CCM issue report code: 194.202.210.41:4ee5595d:faebdc268f

I then tried to replicate this by going into another MPA  - Content
center>Content section: content>Business>Regeneration and
Partnership>Content item: Europe: Funding Opportunities August 2003 
(en)
This time I just did a formatting edit - added a <p="subhead">
This one republished OK


2) Again, this time again editing some old cms LINKs by deleting the 
aplaws
bit and adding /ccm: again,gave unexpected error

Content center>Content section: content>Business>Business
Regulations>Building Control>Content item: Application forms and 
guidance
(en)

CCM issue report code: 194.202.210.41:419dd95e:faebf6aaba


I've been back into both on a couple of occasions and tried to publish
without success.
Comment 1 Cress Rolfe 2004-03-05 04:57:05 EST
As the person who logged the bug I have been sent the email referring 
to the fact that this bug depends on 117503.  I am not authorised to 
access this bug so cannot see what this is all about. Please advise.
Comment 2 Daniel Berrange 2004-03-05 05:24:16 EST
The bug 117503 was mistakenly marked private.
Comment 3 Cress Rolfe 2004-03-05 05:53:46 EST
Thanks for making bug 117503 accessible.  However I don't understand 
how this relates to my bug, I would be grateful for a clearer 
explanation. 

Have just rechecked this bug - Went into the original item which 
prompted the bug log:

Content Centre>Content section: content>Business>Regeneration and 
Partnership>Content item: The Regeneration and Partnership Team (en)

to see if the "republish after editing section of MPA giving error" 
bug was any different
Item was actually published. How was it published since this was the 
bug?

Unpublished it, then republished without amending anything.
Gave error:
CCM issue report code: 194.202.210.41:5becba82:fb1a9d1693

***
I have had the same publishing problem with the following article 
(not MPA).
CCM issue report code: 194.202.210.41:2dd85872:fb0fd4f8a6

error on republishing after editing an article: 
Content center>Content section: content>Environment>Planning and 
Built Environment>Introduction to Planning>Content item: About 
Planning (en)

editing only involved adding stable internal links via the link tool 
in text editor (not using browse, just pasting stable url in)



Comment 4 Daniel Berrange 2004-03-05 06:00:09 EST
Basically, the related bug details a problem that occurrs when
re-publishing items containing related links. The error report
generated looks almost identical to the error reports you're getting,
so I believe, solving the related bug will also resolve your bug. I
don't believe it is specific to any particular content type - its just
that most of your content is Articles or MPA, so that's what its
occurring on most frequently.

Comment 5 Cress Rolfe 2004-03-15 09:04:05 EST
The bug linked to this one has been closed but this has not resolved 
the problem on the example items given above. 

Please advise.

Note You need to log in before you can comment on or make changes to this bug.