Bug 116804 - can't build tclx help files with current nroff
Summary: can't build tclx help files with current nroff
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: groff   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-25 13:32 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 10:09:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2004-02-25 13:32:00 UTC
Description of problem:
With groff-1.18.1-29 there is no problem, but with later builds
nroff appears to truncate lots of the help files generated
with nroff while building the tclhelp system that is a part of
tclx.

Version-Release number of selected component (if applicable):
groff >= 1.18.1-30

How reproducible:
every time

Steps to Reproduce:
1. install current groff
2. build tclx-8.3.5-1 and install the tclx-doc generated
3. % tclhelp
4. select for example: tk -> control -> bind 
5. % man n bind  # from tk-devel
6. Compare the output of (4) and (5)

Actual results:
The manpage text display is incomplete: notice how it
ends in mid-sentence.
 
Expected results:
The complete manpage to be displayed.

Additional info:
When I build with groff-1.18.1-29 installed the help pages
get generated completely.

Even using the nroff script from groff-1.18.1-29 with the newer
groff packages doesn't seem to be good enough.

Comment 1 Thomas Woerner 2004-02-25 13:36:22 UTC

*** This bug has been marked as a duplicate of 116596 ***

Comment 2 Jens Petersen 2004-02-26 05:36:11 UTC
">= 1.18.1-30" was inclusive of 1.18.1-32. ;-)

Comment 3 Thomas Woerner 2004-02-26 15:01:35 UTC
Be sure that you have the new man package installed, also.

Comment 4 Eido Inoue 2004-02-26 17:54:53 UTC
As long as the newest man is included, it will force the inclusion of
the new groff (due to a require/provide of nroff-i18n). It will not
however, force an inclusion of the new fixed nroff.

I'm pretty sure the fixed nroff in the latest rawhide will fix this
problem.

Comment 5 Jens Petersen 2004-02-27 04:34:35 UTC
I can still reproduce:

% rpm -q man groff
man-1.5m2-3
groff-1.18.1-32
% rpmbuild --rebuild tclx-8.3.5-1.src.rpm
:
% tclhelp
  [ tk/ -> control/ -> bind ]

I would be happy to hear that you can't. :)

Comment 6 Thomas Woerner 2004-03-02 10:09:34 UTC
Please use LANG=en_US.UTF-8 for the build of man pages if you want to
have UTF-8 encoding. LANG=C will generate ISO-8859-1 man pages.

groff-1.18.1-33 in rawhide fixes the build of non-UTF-8 files.


Comment 7 Jens Petersen 2004-03-02 11:07:16 UTC
Ah, right.  Thanks.

Comment 8 Eido Inoue 2004-03-02 15:41:32 UTC
Shouldn't the C/POSIX locale generate ASCII pages, not ISO-8859-1?

Comment 9 Thomas Woerner 2004-03-02 15:53:46 UTC
Ohh .. you are right, I meant:

LANG=C will generate ANSI_X3.4-1968 (=ASCII) output.



Note You need to log in before you can comment on or make changes to this bug.