Bug 116806 - gdm XKeepsCrashing should be run in English for CJK
Summary: gdm XKeepsCrashing should be run in English for CJK
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-02-25 13:44 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 21:38:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2004-02-25 13:44:01 UTC
Description of problem:
Since our default console can't display wide chars currently,
XKeepsCrashing should be run under LANG=C for Asian languages
that use widechars.

Steps to Reproduce:
1. make gdm crash continually on ja installed machine.
  
Actual results:
XKeepsCrashing run in ja, but text is completely
unreadable on text VC.

Expected results:
Readable text.

Comment 1 Jens Petersen 2004-02-25 13:55:41 UTC
Submitted upstream as:

http://bugzilla.gnome.org/show_bug.cgi?id=135387

Comment 2 Eido Inoue 2004-02-25 17:53:06 UTC
Actually, it shouldn't be run in locale C... but a universal UTF-8
locale. Not sure if the line drawing characters for drawing the window
will work with an ASCII-only locale such as C/POSIX. (unless
"unicode_stop" script is invoked beforehand)

Comment 3 Mark McLoughlin 2004-06-04 13:42:32 UTC
So, George has "fixed" this upstream by adding ConsoleCannotHandle
config key.

By default its switched off, and the set of languages are:

ConsoleCannotHandle=am,ar,az,bn,el,fa,gu,hi,ja,ko,ml,mr,pa,ta,zh

Jens, when we move to the new upstream version with the fix, are you
happy to just switch on ConsoleCannotHandle with this list of
languages.  Also, have you had a chance to confirm the upstream fix works?

Comment 4 Jens Petersen 2004-06-06 15:21:43 UTC
I was told through gnome bugzilla that a fix for this should now
be in gdm cvs.

Comment 5 Jens Petersen 2004-06-06 15:41:26 UTC
Doh, sorry missed comment 3.

Yes I think that will be fine. :)

Comment 6 Jens Petersen 2004-08-05 07:03:49 UTC
Also in reply to comment 3, no I haven't tested this yet.

But ok, I can re-open if there should still be problems. :)


Note You need to log in before you can comment on or make changes to this bug.