Bug 1168119 - [virtio-win][netkvm]win8.1.64 guest BSOD with error 'DRIVER_IRQL_NOT_LESS_OR_EQUAL' (netkvm.sys) after first reboot during os installation on AMD host
Summary: [virtio-win][netkvm]win8.1.64 guest BSOD with error 'DRIVER_IRQL_NOT_LESS_OR_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
: 1180349 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-26 08:06 UTC by ShupingCui
Modified: 2015-11-24 08:47 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
bsod - DRIVER_IRQL_NOT_LESS_OR_EQUAL (21.55 KB, image/jpeg)
2014-11-26 08:06 UTC, ShupingCui
no flags Details
dump log for virtio-win-1.7.3-1.el7 (3.94 KB, text/plain)
2015-03-09 06:27 UTC, ShupingCui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description ShupingCui 2014-11-26 08:06:21 UTC
Created attachment 961527 [details]
bsod - DRIVER_IRQL_NOT_LESS_OR_EQUAL

Description of problem:
win8.1.64 guest BSOD with error 'DRIVER_IRQL_NOT_LESS_OR_EQUAL' (netkvm.sys) after first reboot during os installation on AMD host

Version-Release number of selected component (if applicable):
[root@hp-dl385g7-05 ~]# rpm -q kernel
kernel-3.10.0-205.el7.x86_64
[root@hp-dl385g7-05 ~]# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-2.1.2-12.el7.x86_64

virtio-win-prewhql-0.1-94

How reproducible:


Steps to Reproduce:
1. install win8.1.64 guest
/bin/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -M pc  \
    -nodefaults  \
    -vga qxl  \
    -global qxl-vga.vram_size=33554432 \
    -device intel-hda,bus=pci.0,addr=03 \
    -device hda-duplex  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20141124-170407-r57CXTz8,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20141124-170407-r57CXTz8,server,nowait \
    -device isa-serial,chardev=serial_id_serial0 \
    -device virtio-serial-pci,id=virtio_serial_pci0,bus=pci.0,addr=04  \
    -chardev socket,id=devvs,path=/tmp/virtio_port-vs-20141124-170407-r57CXTz8,server,nowait \
    -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0  \
    -chardev socket,id=seabioslog_id_20141124-170407-r57CXTz8,path=/tmp/seabios-20141124-170407-r57CXTz8,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20141124-170407-r57CXTz8,iobase=0x402 \
    -device nec-usb-xhci,id=usb1,bus=pci.0,addr=05 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=06 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=threads,file=/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/images/win8-64.1-virtio.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:76:77:78:79:7a,id=idFhZdIn,vectors=4,netdev=idjO79sM,bus=pci.0,addr=07  \
    -netdev tap,id=idjO79sM,vhost=on,vhostfd=28,fd=27  \
    -m 16384  \
    -smp 8,maxcpus=8,cores=4,threads=1,sockets=2  \
    -cpu 'Opteron_G3',+sep,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=threads,media=cdrom,file=/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/isos/ISO/Win8.1/en_windows_8_1_enterprise_x64_dvd_2971902.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
    -drive id=drive_winutils,if=none,snapshot=off,aio=threads,media=cdrom,file=/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device ide-cd,id=winutils,drive=drive_winutils,bus=ide.0,unit=1 \
    -drive id=drive_unattended,if=none,snapshot=off,aio=threads,media=cdrom,file=/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/images/win8.1-64/autoinstall.iso \
    -device ide-cd,id=unattended,drive=drive_unattended,bus=ide.1,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,password=123456,addr=0,tls-port=3200,x509-dir=/tmp/spice_x509d,tls-channel=main,tls-channel=inputs,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off \
    -enable-kvm
2.
3.

Actual results:
win8.1.64 guest BSOD with error 'DRIVER_IRQL_NOT_LESS_OR_EQUAL' (netkvm.sys) after first reboot

Expected results:
guest install successfully

Additional info:

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 0000000000084001, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff80003611305, address which referenced memory

Debugging Details:
------------------

*** ERROR: Module load completed but symbols could not be loaded for netkvm.sys

READ_ADDRESS:  0000000000084001 

CURRENT_IRQL:  2

FAULTING_IP: 
netkvm+b305
fffff800`03611305 8a07            mov     al,byte ptr [rdi]

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  System

ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

DPC_STACK_BASE:  FFFFF801FB72FFB0

TRAP_FRAME:  fffff801fb7286c0 -- (.trap 0xfffff801fb7286c0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ffffe00002d8bc68 rbx=0000000000000000 rcx=ffffe00002d8bca8
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80003611305 rsp=fffff801fb728850 rbp=ffffe00002d8bc68
 r8=0000000000000000  r9=0000000000000000 r10=ffffe00002dcb2c0
r11=ffffe00002dcb000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz ac po nc
netkvm+0xb305:
fffff800`03611305 8a07            mov     al,byte ptr [rdi] ds:00000000`00000000=??
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff801f8f5c7e9 to fffff801f8f50ca0

STACK_TEXT:  
fffff801`fb728578 fffff801`f8f5c7e9 : 00000000`0000000a 00000000`00084001 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff801`fb728580 fffff801`f8f5b03a : 00000000`00000000 ffffe000`02d8bc68 fffff801`fb728600 fffff801`fb7286c0 : nt!KiBugCheckDispatch+0x69
fffff801`fb7286c0 fffff800`03611305 : 00000000`00000000 00000000`00000000 ffffe000`ffffffff fffff800`0361686b : nt!KiPageFault+0x23a
fffff801`fb728850 fffff800`03609f86 : ffffe000`02d939f0 ffffe000`02d8bc68 ffffe000`02d8b940 ffffe000`02db61a0 : netkvm+0xb305
fffff801`fb728880 fffff800`0360df89 : ffffe000`02d8b940 ffffe000`02d8bc10 ffffe000`02db61a0 00000000`00000000 : netkvm+0x3f86
fffff801`fb7288b0 fffff800`0360920f : fffff801`00000000 ffffe000`02d8b940 00000000`00000000 00000000`00000000 : netkvm+0x7f89
fffff801`fb728910 fffff800`03613ea8 : ffffe000`02d93010 00000000`00000040 fffff801`fb728a79 00000000`00000000 : netkvm+0x320f
fffff801`fb728950 fffff800`01aa0702 : ffffd000`223b9d00 00000000`00000000 00000000`00000002 fffff801`f958c4dd : netkvm+0xdea8
fffff801`fb7289b0 fffff801`f8e82840 : fffff801`fb728c60 ffffe000`023cd250 fffff801`f90f1180 ffffe000`023cd010 : ndis!ndisInterruptDpc+0x1b2
fffff801`fb728ae0 fffff801`f8e82520 : ffffe000`023cd010 00000000`00000001 fffff801`fb728d50 fffff801`f8e7daec : nt!KiExecuteAllDpcs+0x1b0
fffff801`fb728c30 fffff801`f8f547ea : fffff801`f90f1180 fffff801`f90f1180 00000000`001a3fe0 00000000`00000000 : nt!KiRetireDpcList+0xd0
fffff801`fb728da0 00000000`00000000 : fffff801`fb729000 fffff801`fb723000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
netkvm+b305
fffff800`03611305 8a07            mov     al,byte ptr [rdi]

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  netkvm+b305

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: netkvm

IMAGE_NAME:  netkvm.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  546c576e

FAILURE_BUCKET_ID:  AV_netkvm+b305

BUCKET_ID:  AV_netkvm+b305

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:av_netkvm+b305

FAILURE_ID_HASH:  {04f7b2ad-f4ea-886b-942a-161d0246cf97}

Followup: MachineOwner
---------

Host infos:
processor	: 15
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 9
model name	: AMD Opteron(tm) Processor 6128
stepping	: 1
microcode	: 0x10000d9
cpu MHz		: 2000.013
cache size	: 512 KB
physical id	: 1
siblings	: 8
core id		: 3
cpu cores	: 8
apicid		: 39
initial apicid	: 23
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid amd_dcm pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save pausefilter
bogomips	: 4000.06
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate

Comment 4 Yang Xue 2014-11-26 09:38:27 UTC
Also hit this problem on Win7.X86_64 guest:

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

KMODE_EXCEPTION_NOT_HANDLED (1e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: 0000000000000000, The exception code that was not handled
Arg2: 0000000000000000, The address that the exception occurred at
Arg3: 0000000000000000, Parameter 0 of the exception
Arg4: 0000000000000000, Parameter 1 of the exception

Debugging Details:
------------------

Page a1cbe not present in the dump file. Type ".hh dbgerr004" for details

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

BUGCHECK_STR:  0x1E

PROCESS_NAME:  smss.exe

CURRENT_IRQL:  2

ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

DPC_STACK_BASE:  FFFFF80000BA2FB0

EXCEPTION_RECORD:  fffff80000ba1638 -- (.exr 0xfffff80000ba1638)
ExceptionAddress: fffff8800167474c (ndis!NdisMAllocateNetBufferSGList+0x000000000000010c)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

TRAP_FRAME:  0000000000010000 -- (.trap 0x10000)
Unable to read trap frame at 00000000`00010000

LAST_CONTROL_TRANSFER:  from fffff800026c3ffe to fffff800026cc610

STACK_TEXT:  
fffff800`00ba0718 fffff800`026c3ffe : 00000000`00000000 00000000`00000000 fffff800`00ba0e90 fffff800`026f82a0 : nt!KeBugCheck
fffff800`00ba0720 fffff800`026f7f6d : fffff800`028d3a10 fffff800`0280fc78 fffff800`0264c000 fffff800`00ba1638 : nt!KiKernelCalloutExceptionHandler+0xe
fffff800`00ba0750 fffff800`026f6d45 : fffff800`02813028 fffff800`00ba07c8 fffff800`00ba1638 fffff800`0264c000 : nt!RtlpExecuteHandlerForException+0xd
fffff800`00ba0780 fffff800`02707dc1 : fffff800`00ba1638 fffff800`00ba0e90 fffff800`00000000 fffffa80`00000006 : nt!RtlDispatchException+0x415
fffff800`00ba0e60 fffff800`026cbcc2 : fffff800`00ba1638 fffffa80`0553cf50 fffff800`00ba16e0 fffffa80`04fe3078 : nt!KiDispatchException+0x135
fffff800`00ba1500 fffff800`026ca5ca : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiExceptionDispatch+0xc2
fffff800`00ba16e0 fffff880`0167474c : fffff800`00000000 fffffa80`0553cf50 00000000`00000000 00000000`000007ff : nt!KiGeneralProtectionFault+0x10a
fffff800`00ba1870 fffff880`0401ba62 : fffffa80`04ef61a0 fffff800`026ad42a fffffa80`04df9290 00000000`00000000 : ndis!NdisMAllocateNetBufferSGList+0x10c
fffff800`00ba1910 fffff880`0401a512 : fffffa80`04b68150 fffffa80`0553ce20 fffffa80`0553cf50 00000000`00000000 : netkvm+0x9a62
fffff800`00ba1950 fffff880`0401bf36 : fffffa80`04e499e0 fffffa80`04e499e0 fffffa80`04fdba90 00000000`00000000 : netkvm+0x8512
fffff800`00ba1980 fffff880`0401bb6d : fffffa80`04e499e0 fffffa80`04fdba90 fffffa80`04fe1580 fffff880`01767892 : netkvm+0x9f36
fffff800`00ba19b0 fffff880`017314f1 : fffff800`00ba1a80 fffffa80`04fe1580 fffffa80`04ef61a0 fffff880`0173136f : netkvm+0x9b6d
fffff800`00ba1ab0 fffff880`01674624 : 00000000`00000000 fffffa80`05542aa0 00000000`00000000 00000000`00000000 : ndis!ndisMSendNBLToMiniport+0xb1
fffff800`00ba1b10 fffff880`03695199 : fffffa80`04dd9c00 fffffa80`04ef61a0 00000000`00000000 fffff880`01731846 : ndis!NdisFSendNetBufferLists+0x64
fffff800`00ba1b50 fffff880`01674569 : 00000004`ffffffff fffff800`00ba1c58 fffff800`00ba1c88 fffffa80`04fe3088 : pacer!PcFilterSendNetBufferLists+0x29
fffff800`00ba1c50 fffff880`017315d5 : 00000000`00000000 00000000`00000000 fffffa80`04ef61a0 ffff0080`011eda75 : ndis!ndisSendNBLToFilter+0x69
fffff800`00ba1cb0 fffff880`019421de : 00000000`00000000 00000000`0000000e fffffa80`04ddc650 fffff880`0193f3b7 : ndis!NdisSendNetBufferLists+0x85
fffff800`00ba1d10 fffff880`0193f3b7 : fffff880`01a4d800 00000000`00000000 fffffa80`04b40000 fffff880`000086dd : tcpip!IppFragmentPackets+0x39e
fffff800`00ba1e30 fffff880`01941805 : 00000000`00000000 fffffa80`0553cf50 fffffa80`04b3ec38 fffff880`0193ff43 : tcpip!IppDispatchSendPacketHelper+0x87
fffff800`00ba1ef0 fffff880`0193ff43 : 00000000`0000003a 00000000`00000000 fffff800`00000028 fffff880`00000000 : tcpip!IppPacketizeDatagrams+0x2d5
fffff800`00ba2010 fffff880`01927026 : fffffa80`04b683c0 00000000`00000000 fffff880`01a4d800 fffffa80`04b4ddb0 : tcpip!IppSendDatagramsCommon+0x753
fffff800`00ba22e0 fffff880`0190aa22 : fffffa80`0553ce20 fffffa80`04b69301 fffffa80`04b69300 00000000`00000000 : tcpip!IppSendDatagrams+0x26
fffff800`00ba2320 fffff880`018e3c88 : 00000000`00000000 fffffa80`05565610 fffffa80`04b69368 fffffa80`04b683c0 : tcpip!IppSendDirect+0x112
fffff800`00ba2450 fffff880`018e3dd6 : fffffa80`05565610 fffff880`01a4d800 fffffa80`04b682f0 fffffa80`04dd9cb0 : tcpip!Ipv6pSendNeighborSolicitation+0x128
fffff800`00ba2500 fffff880`0196fb1a : 00060000`07000000 fffffa80`04b682f0 00000000`00000001 00000000`00000000 : tcpip!IppSendDadSolicitation+0x76
fffff800`00ba2560 fffff880`0196fd1e : fffffa80`04b60838 00000000`00000000 fffff800`00ba2830 00000000`00000004 : tcpip!IppAddressSetTimeout+0x19a
fffff800`00ba2680 fffff880`0196fc18 : fffffa80`04b60828 fffff800`00ba2830 00000000`ffff0000 00000000`00000001 : tcpip!Ipv6pInterfaceSetTimeout+0x7f
fffff800`00ba2700 fffff880`019702e9 : 00000000`ffff0000 fffff800`00ba2830 00000000`00000001 fffff800`026d505a : tcpip!IppCompartmentSetTimeout+0x88
fffff800`00ba2770 fffff800`026d8062 : 00000000`00000000 00000000`00000000 01535242`40dd0089 00000008`00000002 : tcpip!IppTimeout+0x89
fffff800`00ba27a0 fffff800`026d7f06 : fffff880`01a6e8e0 00000000`000002be 00000000`00000000 fffffa80`04c1b010 : nt!KiProcessTimerDpcTable+0x66
fffff800`00ba2810 fffff800`026d7dee : 00000000`0689b2cc fffff800`00ba2e88 00000000`000002be fffff800`02842a48 : nt!KiProcessExpiredTimerList+0xc6
fffff800`00ba2e60 fffff800`026d7bd7 : fffff800`0283eec1 00000000`000002be fffffa80`03c6f050 00000000`000000be : nt!KiTimerExpiration+0x1be
fffff800`00ba2f00 fffff800`026cf165 : 00000000`00000000 fffffa80`04e47580 00000000`00000000 fffff880`01136f5c : nt!KiRetireDpcList+0x277
fffff800`00ba2fb0 fffff800`026cef7c : 00000000`0002625a fffff800`026171c0 00000000`00000000 00000000`00020000 : nt!KyRetireDpcList+0x5
fffff880`03d620c0 fffff800`02718453 : fffff800`026c8ba0 fffff800`026c8c0c 00000000`00000010 fffff800`026333c0 : nt!KiDispatchInterruptContinue
fffff880`03d620f0 fffff800`026c8c0c : 00000000`00000010 fffff800`026333c0 fffff880`03d62180 fffffa80`03cafe40 : nt!KiDpcInterruptBypass+0x13
fffff880`03d62100 fffff800`02712634 : 00000000`00000000 00000000`00000002 00000000`00010000 fffff800`028926c0 : nt!KiInterruptDispatchNoLock+0x1fc
fffff880`03d62298 fffff800`0266566d : fffff8a0`00d36420 fffffa80`04e4e010 fffff880`03de7ee8 00000000`00000190 : nt!RtlFindNextAlignedForwardRunClear+0x9b
fffff880`03d622c0 fffff800`0292ae2f : fffff880`03d62390 fffff800`00000000 00000000`00010000 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x1bb63
fffff880`03d62360 fffff800`0292b657 : 00000000`00000000 fffff8a0`00000019 fffff880`03de6b40 fffff960`003ce288 : nt!MiInsertInSystemSpace+0xc7
fffff880`03d623d0 fffff800`0292b81b : 00000000`00000000 00000000`00000001 00000000`00000000 fffff880`03d62640 : nt!MiMapViewInSystemSpace+0x73
fffff880`03d62400 fffff960`003e98b6 : 00000000`00000000 00000000`00000000 00000000`00000000 fffff880`03d624b0 : nt!MmMapViewInSessionSpace+0x4f
fffff880`03d62430 fffff960`003e9597 : 00000000`00188000 00000000`00188000 fffffa80`05524a60 fffff880`03d62640 : win32k!Win32UserInitialize+0x96
fffff880`03d624b0 fffff800`02a491cf : 00000000`00000000 00000000`00000000 fffffa80`74636553 ffffffff`80000210 : win32k!DriverEntry+0x4f3
fffff880`03d62620 fffff800`02b406d5 : fffff960`000f0000 00000000`00000001 00000000`00000000 fffff800`00000001 : nt!ExpInitializeSessionDriver+0x3f
fffff880`03d627a0 fffff800`026cb8d3 : fffffa80`04e47580 fffff800`0283a010 09000000`a8bb4025 00000000`a8bb4121 : nt!NtSetSystemInformation+0x539
fffff880`03d62910 fffff800`026c7e70 : fffff800`02b4064f 00000000`00000000 00000000`00000018 fffff8a0`000f3840 : nt!KiSystemServiceCopyEnd+0x13
fffff880`03d62aa8 fffff800`02b4064f : 00000000`00000000 00000000`00000018 fffff8a0`000f3840 00000000`0010fb00 : nt!KiServiceLinkage
fffff880`03d62ab0 fffff800`026cb8d3 : fffffa80`04e47580 00000000`00010070 00000000`00000001 00000000`001a2890 : nt!NtSetSystemInformation+0x4b3
fffff880`03d62c20 00000000`76fd2a0a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0010fb08 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x76fd2a0a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
netkvm+9a62
fffff880`0401ba62 85c0            test    eax,eax

SYMBOL_STACK_INDEX:  8

SYMBOL_NAME:  netkvm+9a62

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: netkvm

IMAGE_NAME:  netkvm.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  546c5781

FAILURE_BUCKET_ID:  X64_0x1E_netkvm+9a62

BUCKET_ID:  X64_0x1E_netkvm+9a62

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:x64_0x1e_netkvm+9a62

FAILURE_ID_HASH:  {0ce2e21f-e7ec-ca17-e2b0-a99fe4f61620}

Followup: MachineOwner
---------

Comment 6 Ronen Hod 2014-12-02 18:25:15 UTC
Deferring. NetKVM work for 7.2.

Comment 11 Yossi Hindin 2014-12-04 15:57:26 UTC
Apparently, the bug has been already fixed in build 95.
Please, test the issue against build # 95.

   Regards,
       Joseph Hindin

Comment 12 Vadim Rozenfeld 2015-01-10 04:17:59 UTC
*** Bug 1180349 has been marked as a duplicate of this bug. ***

Comment 13 Steven Noonan 2015-01-18 08:29:09 UTC
I'm also seeing this issue sporadically (most frequently at boot) with a Windows 8.1 x86_64 guest.

Where can I get a copy of the build #95 virtio drivers? I only see build 94 here:

https://alt.fedoraproject.org/pub/alt/virtio-win/latest/

Comment 14 Yan Vugenfirer 2015-01-18 10:02:53 UTC
Please use the latest stable release: 
http://alt.fedoraproject.org/pub/alt/virtio-win/stable/

Comment 15 Steven Noonan 2015-01-18 11:01:21 UTC
You aren't interested in test results against build #95 per comment 11?

Comment 16 Yan Vugenfirer 2015-01-18 11:56:50 UTC
More interested in the results with the build with complete multi-queue feature. Will check when we are going to release it.

Comment 18 lijin 2015-01-21 03:18:03 UTC
Reproduced this issue on virtio-win-prewhql-94
Verified this issue on  virtio-win-prewhql-100

steps same as comment #0

Actual Results:
on build 94, guest bsod during os installation 
on build 100, guest can be installed correctly,no bsod,and guest network works fine after installation.

Based on above ,this issue has been fixed already .


package info:
kernel-3.10.0-121.el7.x86_64
qemu-kvm-rhev-1.5.3-60.el7ev.x86_64
seabios-1.7.2.2-12.el7.x86_64

Comment 19 Yan Vugenfirer 2015-01-21 09:07:01 UTC
(In reply to lijin from comment #18)
> Reproduced this issue on virtio-win-prewhql-94
> Verified this issue on  virtio-win-prewhql-100
> 
> steps same as comment #0
> 
> Actual Results:
> on build 94, guest bsod during os installation 
> on build 100, guest can be installed correctly,no bsod,and guest network
> works fine after installation.
> 
> Based on above ,this issue has been fixed already .
> 

Thanks!

Comment 20 ShupingCui 2015-03-09 06:14:15 UTC
Met the same issue using win8.1.64 guest on virtio-win-1.7.3-1.el7.
virtio-net: 62.70.104.8000 
virtio-scsi: 62.70.104.8000

Comment 21 ShupingCui 2015-03-09 06:24:58 UTC
(In reply to ShupingCui from comment #20)
> Met the same issue using win8.1.64 guest on virtio-win-1.7.3-1.el7.
> virtio-net: 62.70.104.8000 
> virtio-scsi: 62.70.104.8000

How reproducible:
Only once

Comment 22 ShupingCui 2015-03-09 06:27:48 UTC
Created attachment 999438 [details]
dump log for virtio-win-1.7.3-1.el7

Comment 23 Yan Vugenfirer 2015-03-09 08:36:31 UTC
(In reply to ShupingCui from comment #22)
> Created attachment 999438 [details]
> dump log for virtio-win-1.7.3-1.el7

Please open another BZ. The crash described in this BZ was related to changes that were introduced after 62.70.104.8000 release.

Comment 24 ShupingCui 2015-03-09 09:59:11 UTC
(In reply to Yan Vugenfirer from comment #23)
> (In reply to ShupingCui from comment #22)
> > Created attachment 999438 [details]
> > dump log for virtio-win-1.7.3-1.el7
> 
> Please open another BZ. The crash described in this BZ was related to
> changes that were introduced after 62.70.104.8000 release.

OK, opened it, bz#1199929

Thanks,
Shuping

Comment 26 lijin 2015-06-17 08:48:23 UTC
change status to verified according to comment#18

Comment 28 errata-xmlrpc 2015-11-24 08:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.