This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11683 - require downlevel gtk--
require downlevel gtk--
Status: CLOSED WONTFIX
Product: Red Hat Powertools
Classification: Retired
Component: cdrdao (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-25 23:24 EDT by Tim Pepper
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-28 01:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Pepper 2000-05-25 23:24:07 EDT
The cdrdao rpm in the PowerTools 6.2 requires the the gtk-- version that
ships with PowerTools 6.1 and balks at the 6.2 gtk--.  Seems like
cdrdao-1.1.3-1.i386.rpm should be happy to have gtk---1.0.3pre1-3.i386.rpm
instead of requiring gtk---1.0.3pre1-2.i386.rpm.  Was this an oversight or
is there a legitimate need for the version requirement to be hard set to
only that older gtk-- rpm?
Comment 1 Tim Powers 2000-05-26 09:04:59 EDT
It was definitely an oversight. When editing the "Requires:" line to read

	Requires: gtk-- >= 1.0.3

Are you able to rebuild it?

Tim
Comment 2 Tim Pepper 2000-06-10 22:01:36 EDT
Sorry it's taken me so long to get back on this.  Today I've finally edited the
requires line and had to scratch my head for a few minutes until I realised I
didn't have the gtk devel packages installed.  It does indeed rebuild.  I
haven't done any real testing or anything to make sure it works though...
Comment 3 Tim Powers 2000-06-19 17:30:28 EDT
OK. Just a heads up, the gtk-- package is going to be renamed to be gtkmm for
the nehxt release. I am closing this bug as "won't fix", if you have any more
problems with it reopen this bug.

Tim
Comment 4 Moritz Barsnick 2000-06-28 01:59:55 EDT
Furthermore, xcdrdao doesn't seem to be packaged in cdrdao-1.1.3-1.i386,
although that is actually _the_ component which is supposed to require gtk--.
(xcdrdao-1.1.4 [currently pre3] actually won't build at all without gtkmm >=
1.2.0. From then, find-requires will probably do.)

Actually, that's a bug, because there _is_ an applink in that package. (No,
xcdrdao isn't built in a separate package.)

Note You need to log in before you can comment on or make changes to this bug.