Bug 11683 - require downlevel gtk--
Summary: require downlevel gtk--
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: cdrdao (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2000-05-26 03:24 UTC by Tim Pepper
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-06-28 05:59:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Tim Pepper 2000-05-26 03:24:07 UTC
The cdrdao rpm in the PowerTools 6.2 requires the the gtk-- version that
ships with PowerTools 6.1 and balks at the 6.2 gtk--.  Seems like
cdrdao-1.1.3-1.i386.rpm should be happy to have gtk---1.0.3pre1-3.i386.rpm
instead of requiring gtk---1.0.3pre1-2.i386.rpm.  Was this an oversight or
is there a legitimate need for the version requirement to be hard set to
only that older gtk-- rpm?

Comment 1 Tim Powers 2000-05-26 13:04:59 UTC
It was definitely an oversight. When editing the "Requires:" line to read

	Requires: gtk-- >= 1.0.3

Are you able to rebuild it?


Comment 2 Tim Pepper 2000-06-11 02:01:36 UTC
Sorry it's taken me so long to get back on this.  Today I've finally edited the
requires line and had to scratch my head for a few minutes until I realised I
didn't have the gtk devel packages installed.  It does indeed rebuild.  I
haven't done any real testing or anything to make sure it works though...

Comment 3 Tim Powers 2000-06-19 21:30:28 UTC
OK. Just a heads up, the gtk-- package is going to be renamed to be gtkmm for
the nehxt release. I am closing this bug as "won't fix", if you have any more
problems with it reopen this bug.


Comment 4 Moritz Barsnick 2000-06-28 05:59:55 UTC
Furthermore, xcdrdao doesn't seem to be packaged in cdrdao-1.1.3-1.i386,
although that is actually _the_ component which is supposed to require gtk--.
(xcdrdao-1.1.4 [currently pre3] actually won't build at all without gtkmm >=
1.2.0. From then, find-requires will probably do.)

Actually, that's a bug, because there _is_ an applink in that package. (No,
xcdrdao isn't built in a separate package.)

Note You need to log in before you can comment on or make changes to this bug.