Bug 116837 - Kernel Panic: on rebuild of RAID1
Kernel Panic: on rebuild of RAID1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 12:21 EST by Rainer Sins
Modified: 2007-04-18 13:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 16:05:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Sins 2004-02-25 12:21:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
When i start the mirror (re)build (mkraid or raidhotadd) the System 
will unexpectly panic with "Killing Interrupthandler" 
Disks From other manufactor does'nt have problems (Seagate, ...).
I've make a Kernelupdate on 2.4.20-30.9 and see the same problem.
Also there is no way to get the System up with Fujitsu Disks.



Code: 8b 01 85 45 f0 75 1c 8b 02 89 d3 89 c2 0f 18 00 39 f3 75 e9
<0>Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing


I use two Fujitsu MAP-3367NC disks in with Intel SE7501WV2 
Serverboard and the onboard SCSI controller.

Version-Release number of selected component (if applicable):
raidtools-1.00.3-2, under Kernel 2.4.20-8bigmem

How reproducible:
Always

Steps to Reproduce:
1. Make 3 Partitions on two Fujitsu 36Gb SCSI disks
2. Setup /etc/raidtab
3. start "mkraid ..." on all partitions


Actual Results:  A installaion will work till the first boot! When 
the System is in rebuild of /dev/md3 it will panic.


Additional info:
Comment 1 Doug Ledford 2004-02-26 07:56:24 EST
A few comments.  First, this isn't a raidtools bug.  It's a kernel
panic after raidtools has already done its job.  Second, raidtools is
deprecated, you should use mdadm instead.  Third, to know what's
panic'ing I need to know the controller and driver version that the
Fujitsu disks are connected to.
Comment 2 Rainer Sins 2004-03-16 08:19:42 EST
Hello Doug,

I'm sorry for the delay...
Ok, so I think it must be a timing problem between the Fuji disks and 
the Kernel-Module. 
I have only this Problem with disk mirroring, Fuji disks and RedHat 
9. When I use RedHat AS 2.1 or AS 3.0, or Seagate disks the problem 
doesn't appears.
The output from "/proc/scsi/aic79xx/0" is (where the Fujitsu Disks 
are attached):

Adaptec AIC79xx driver version: 1.0.0
aic7902: Ultra320 WideChannel B, SCSI Id=7, PCI-X 67-100Mhz, 512 SCBs
...


By the way: I'm using now Seagate disks with the same configuration 
and they are working now for 2 Weeks without problems.

Rainer
Comment 3 Doug Ledford 2004-03-30 16:05:28 EST
I think this is a known issue between the version of aic79xx driver
and the version of firmware on the Fujitsu disks.  Either an updated
aic79xx driver or an updated disk firmware should solve the problem. 
I'm closing this out as NOTABUG since it's a firmware interaction
issue (which we obviously can't do anything about Fujitsu firmware,
and I think the later aic79xx driver just enables some sort of
workaround, but if you get the updated firmware then the workaround
isn't needed).

Note You need to log in before you can comment on or make changes to this bug.