Bug 116839 - 'su -' fails for root
'su -' fails for root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-25 12:30 EST by Bill Nottingham
Modified: 2014-03-16 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 23:15:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-02-25 12:30:30 EST
Logged in on the console as root, context is root:sysadm_r:sysadm_t

'su -' fails with 'su: incorrect password'.

Actual results:

It failed.

Expected results:

It should work.

Additional info:
Comment 1 Scott Sloan 2004-02-25 12:57:38 EST
How does this bug differ from 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=116347
Comment 2 Bill Nottingham 2004-02-25 15:58:55 EST
The errors didn't seem to come from the tty stuff. I'll need to get
the full list.
Comment 4 Tim Waugh 2004-03-03 12:36:53 EST
Now that I've had a chance to look at this, I can't reproduce it. :-/

From a clean rawhide-20040303 install, logging in as root on VT1 and
running 'su -' works, saying:

==>
Your default context is root:sysadm_r:sysadm_t

Do you want to choose a different one? [n]
<==

and 'exit' brings me back to the original shell.  Same in
gnome-terminal from a root login via gdm.
Comment 5 Bill Nottingham 2004-03-03 23:15:28 EST
Policy changed quite a bit. Will reopen if it persists.

Note You need to log in before you can comment on or make changes to this bug.