Bug 116840 - gdb c-c c-c break does not work in emacs (does work from xemacs and from bash)
gdb c-c c-c break does not work in emacs (does work from xemacs and from bash)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 12:34 EST by jerry asher
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 11:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jerry asher 2004-02-25 12:34:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007

Description of problem:
Using a very vanilla Redhat 9, with the emacs and gdb that comes on
the RH 9 disks, emacs 21.2, and gdb 5.3..., I cannot c-c c-c out of my
program back into gdb.

I can do this when I run gdb from bash, and when I run gdb from
xemacs.  Under emacs, there is no indication that anything ever saw
the c-c c-c.

This also when I completely eliminate by .emacs and any non-standard
emacs initializations.


Version-Release number of selected component (if applicable):
emacs 21.2.2-33 gdb 5.3post-0.20021129.18

How reproducible:
Always

Steps to Reproduce:
1. enter emacs
2. start gdb (m-x gdb)
3. run your program
4. c-c c-c
5. ???
6. Lose your profit
    

Actual Results:  Nothing happened

Expected Results:  Expected to break out of the program back into gdb
9 (which is what happens in xemacs and bash)

Additional info:

I couldn't find the WMDs either, I looked all around my neighborhood.
Comment 1 jerry asher 2004-02-25 13:50:16 EST
#include <stdio.h>
void main() {
    for (;;) {
       printf ("turn world\n");
    }
}
Comment 2 Jens Petersen 2004-04-15 11:20:45 EDT
This is fixed in 21.3 AFAICT.  Can you try that and if you still
have problems, please reopen this bug. 
Comment 3 Jens Petersen 2004-04-15 11:23:18 EDT
Urm, then again I can't reproduce the problem with 21.2...
Comment 4 jerry asher 2004-04-15 12:46:36 EDT
Hi Jen, thanks for reopening it with a need for more info, it's always
frustrating to see someone just close the bug immediately.

Do you know of an rpm for emacs 21.3?  I can't find one for Red Hat
Enterprise (or Red Hat 9) at rpmfind.net or at a mirror for the Red
Hat updates.  I am on a gov't configuration controlled machine -- it
is much easier to get approval to load an rpm than a tarball.

Thanks,

Jerry
Comment 5 Jens Petersen 2004-04-15 13:46:53 EDT
If you have a RHEL3 subscription you should be able to pull down
emacs-21.3 from RHN, otherwise the FC1 emacs probably needs rebuilding
to run on RHL9 iirc.

But like I say I can't reproduce your problem with the emacs in RHL9.
So it could be a local problem at your end?
Comment 6 Jens Petersen 2004-09-29 11:23:26 EDT
Closing for now.  Please re-open if necessary.

Note You need to log in before you can comment on or make changes to this bug.