Bug 116841 - autofs does not work quite right in enforcing mode
Summary: autofs does not work quite right in enforcing mode
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: James Morris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-25 17:37 UTC by Bill Nottingham
Modified: 2014-03-17 02:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 20:19:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2004-02-25 17:37:20 UTC
Description of problem:

autofs prints failure, but manages to mount the filesystem

Version-Release number of selected component (if applicable):

policy-1.6-6

How reproducible:

Every time

Steps to Reproduce:
1. cd to some autofs-mounted dir
  
Actual results:

avc: denied { read write } for pid=20425 exe=/bin/mount
path=socket:[28123] dev= ino=21823 scontext=system_u:system_r:mount_t
tcontext=system_u:system_r:automount_t tclass=tcp_socket

avc: denied { write } for pid=14897 exe=/bin/bash laddr=172.16.56.125
lport=799 faddr=192.168.10.8 fport=2049
scontext=root:sysadm_r:sysadm_t tcontext=system_u:system_r:mount_t
tclass=tcp_socket

RPC: sendmsg returned error 13
nfs: RPC call returned error 13
-bash: cd: /mnt/redhat/test: Permission denied

Yet, /mnt/redhat is mounted.

Expected results:

Considerably fewer errors.

Additional info:

Comment 1 Daniel Walsh 2004-02-26 21:10:47 UTC
According to Stephen Tweedie this looks like a kernel problem.

Dan

Comment 2 James Morris 2004-04-05 19:57:04 UTC
AFAIK, this shold be fixed.  Is this still a problem?


Comment 3 Bill Nottingham 2004-04-05 20:19:32 UTC
Yeah, it works now.


Note You need to log in before you can comment on or make changes to this bug.