Bug 116846 - nautilus crashes with any action
nautilus crashes with any action
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
Reported: 2004-02-25 12:59 EST by Alexander Farley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-03-23 13:29:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
results of ldd /usr/bin/nautilus (4.73 KB, text/plain)
2004-03-03 12:14 EST, Alexander Farley
no flags Details

  None (edit)
Description Alexander Farley 2004-02-25 12:59:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
Nautilus crashes upon action (i.e. trying to open the home folder
window). To crash dialog is provided. Running nautilus from the
commandline produces this error:

nautilus: relocation error: nautilus: undefined symbol:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Run GNOME desktop
2.nautilus attomatically starts
3.use nautilus

Actual Results:  nautilus crashed when I tried to use it.

Expected Results:  nautilus would not crash when accessed.

Additional info:

All components are up to date with fedora-devlopment (02/25/2004).
Comment 1 Alexander Farley 2004-02-25 13:01:03 EST
Oops, "To crash dialog is provided." should be "No crash dialog is
provided." (i.e. bug-buddy).
Comment 2 Alexander Larsson 2004-02-26 04:18:46 EST
Very strange. Its as if you have an older version of
libnautilus-private. Are you sure you fully logged out and got rid of
all running versions before trying?
Comment 3 Alexander Farley 2004-02-26 10:23:21 EST
Yes. I downgraded yesterday night, redownloaded this morning, logged
out, logged in as root and reinstalled from the terminal, rebooted (to
load the newest kernel) and got the same error when I restarted.

I can try recompiling nautilus myself to see if it is a problem unique
to my system.
Comment 4 Alexander Larsson 2004-03-03 11:12:56 EST
What does "ldd nautilus" output?
Comment 5 Alexander Farley 2004-03-03 12:14:26 EST
Created attachment 98246 [details]
results of ldd /usr/bin/nautilus

The results of ldd /usr/bin/nautilus are attached.
Comment 6 Alexander Larsson 2004-03-15 11:16:22 EST
Strange. nautilus_get_uri_shortname_for_display is surely in
/usr/lib/libnautilus-private.so.2, and your nautilus is using that. I
have no idea why its claiming its not there, but nobody but you is
seeing this. 
Comment 7 Alexander Larsson 2004-03-19 06:15:46 EST
Is this still happeneing with the latest version of nautilus?
Comment 8 Alexander Farley 2004-03-19 10:35:57 EST
Yes, I am still have crashes when I try to open a nautilus window.
After the crash trying to start nautilus from the command line still
produces the same error. nautilus-2.5.7-1 works flawlessly though. 

If the problem is only on my system, then the bug should be closed. A
clean install using fc2-test2 when it is released should fix whatever
is causing the problem.
Comment 9 Alexander Farley 2004-03-19 10:49:57 EST
I have found the source of the problem. When the new version of
nautilus was install the symlinks were being linked to an older
prelinked version of the various nautilus libraries (specifically
libnautilus-private.so.2.0.0.#prelink#.AhuPix from Feb 13). So this is
either notabug or or problem with prelink not allowing newer libraries
to be used after an upgrade. I have been getting several errors due to
improperly prelinked files lately. However, a freshly installed system
will presumably not have these problems.
Comment 10 Alexander Larsson 2004-03-22 10:22:03 EST
I dunno if this is a prelink problem or if nautilus is doing something
wrong. Reassigning to prelink.
Comment 11 Jakub Jelinek 2004-03-22 10:28:04 EST
The presence of file like:
means either that prelink process has been killed or the box powered
down while prelinking was in progress (in whcih case just remove
the file in question, rerun ldconfig and you should be all set),
or it could mean that prelink crashed while processing that library
(but in that case if it has been from the cron job you should have
received a mail about it).
If the latter is true, I need more details so that I can reproduce it
myself (particularly the library on which it crashed, all its dependencies
and prelink command line options and its version).
Comment 12 Alexander Farley 2004-03-23 13:29:30 EST
I do not think that that the problem was/is caused by one single
library, but that prelink was aborted at some point a few months ago
and the problem propagated out of control until I noticed.

It would be nice if there was a way for prelink to clean up previously
aborted sessions. As my system is now a mess a desperately in need a a
fresh install.

Note You need to log in before you can comment on or make changes to this bug.