Bug 11686 - Duplex printing to PS printers missing
Duplex printing to PS printers missing
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-26 10:25 EDT by Tero Manninen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 07:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tero Manninen 2000-05-26 10:25:19 EDT
ps-to-printer.fpi (version 1.63-1) does not seem to know anything about
duplex printing. Our PostScript printer however does and so does mpage
(which is used by the filter to get the N-UP feature).
Without any better knowledge, I made following hack to the filter:

RCS file: RCS/ps-to-printer.fpi,v
retrieving revision 1.0
diff -r1.0 ps-to-printer.fpi
35a36,39
> if [ "$DUPLEX" = "2" ]; then
>     duplex="-t"
> fi
>
45c49
<     mpage_cmd="mpage -b$mpage_paper $border -$NUP -m${RTLFTMAR}lr
-m${TOPBOTMAR}tb"
---
>     mpage_cmd="mpage -b$mpage_paper $border -$NUP $duplex -m${RTLFTMAR}lr
-m${TOPBOTMAR}tb"

In addition to the above change I added a line "DUPLEX=2" into my
printer spool directory "postscript.cfg", and everything seems to work
just great (ASCII and PS printing).

The problem is that "printtool" does not know anything about DUPLEX setting
either. Anyway, this solution works for me. Maybe there are better ways to
do this?
Comment 1 Crutcher Dunnavant 2000-08-08 16:00:11 EDT
printtool REALLY needs an overhaul, but this will have to wait.

We are looking for a re-write in 7.1 (I know we said we'd do one by 7.0)
defering this bug.

Note You need to log in before you can comment on or make changes to this bug.