Bug 116863 - RFE: RRDtool should be available along MRTG
RFE: RRDtool should be available along MRTG
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
http://people.ee.ethz.ch/~oetiker/web...
: FutureFeature
: 130089 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 15:58 EST by Petri T. Koistinen
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-18 10:30:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri T. Koistinen 2004-02-25 15:58:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040122 Debian/1.6-1

Description of problem:
If you know MRTG, you can think of RRDtool as a reimplementation of
MRTGs graphing and logging features. Magnitudes faster and more
flexible than you ever thought possible.

RRD is the Acronym for Round Robin Database. RRD is a system to store
and display time-series data (i.e. network bandwidth, machine-room
temperature, server load average). It stores the data in a very
compact way that will not expand over time, and it presents useful
graphs by processing the data to enforce a certain data density. It
can be used either via simple wrapper scripts (from shell or Perl) or
via frontends that poll network devices and put a friendly user
interface on it.

RRDtool is not a replacement for MRTG, as it does not implement the
frontend and data aquisition features of MRTG.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Use RRDtool.

Additional info:

Tobi Oetiker is author of both tools. RRDtool is developed after MRTG.
See homepage URL.
Comment 1 James Bourne 2004-06-21 00:39:34 EDT
I would also request this.  rrdtool is released under the GPL and
there is a spec file which works fine with FC2 with a small amount of
modification.
Comment 2 Reuben Farrelly 2004-07-19 05:37:08 EDT
Count me in on this also...
Comment 3 Terje Bless 2004-08-30 21:59:49 EDT
+1

RRDtool is a generic backend with multiple frontends that together make up complete 
replacements for MRTG. In particular, we use the Cricket frontend (on RHEL, not Fedora, 
but...) in preference to MRTG. RRDTool has bindings for multiple languages (can be used 
from Perl, TCL, etc. in addition to C), and provides a rich feature set for data series storage 
and graphing (not tied to network monitoring).

It's main drawback is that it's a slight pain to build correctly from source; so having it 
prebuilt and included in Fedora and RHEL would alleviate this problem, enable out-of-box 
use of the many frontends, and add a rich but targetted new tool for building new 
applications.
Comment 4 Miloslav Trmač 2004-11-16 09:25:04 EST
*** Bug 130089 has been marked as a duplicate of this bug. ***
Comment 5 Miloslav Trmač 2004-11-16 11:11:16 EST
The only rationale in this bug so far talks about the Cricket frontend.

Assuming this frontend is not included in Fedora Core, how useful
is RRDtool standing alone?  As far as I know, the distribution does not
include libraries not used by any application within the distribution,
and RRDtool seems to be similar to libraries in this regard.
Comment 6 Terje Bless 2004-11-16 11:32:38 EST
RRDTool does include a reusable (.so) library, yes.

However RRDtool as such is a framework for managing data series; it
includes command-line utilities for creating Round-Robin Databases,
managing and massaging this data, and visualizing it in various
usefull ways; in addition to the language bindings for Perl, Python,
and TCL (and of course the native C API).

As an example, the Cricket network monitoring system uses a Perl
wrapper around the command-line utilities instead of the Perl
modules or C API for some of its functions.


Quite apart from the various frontends such as MRTG and Cricket --
and there are quite a few of them -- it's extremely usefull for
managing time-series data from the command line (or the bundled CGI
wrapper).

See e.g. <http://www.rrdtool.org/manual/index.html> for details.

Fedora Extras doesn't seem to have it, but there's a set in Dag's
repo that might be a decent starting point.


Oh, and BTW, as I mentioned, I'd file an RFE for this against RHEL
because the Cricket frontend is one of our core applications for our
RHEL servers; except the sane path for new packages into RHEL these
days is by way of Fedora Core.
Comment 7 Holland Casino 2004-11-17 18:30:13 EST
*** Bug 130089 has been marked as a duplicate of this bug. ***
Comment 8 Miloslav Trmač 2004-12-18 10:30:03 EST
Thanks for your comments.

Let's start with getting RRDTool to Fedora Extras, in bug 143306.

Note You need to log in before you can comment on or make changes to this bug.