Bug 116871 - Can't get X to run with Fedora Core 2 Test 1
Can't get X to run with Fedora Core 2 Test 1
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-02-25 16:42 EST by Brian W. Masinick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-12 14:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian W. Masinick 2004-02-25 16:42:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
I installed Fedora Core 2 Test 1 on a Dell Dimension 4100 system that
had successfully run previous versions of Red Hat software, including
RH 8, RH 9, and most recently Fedora Core 1.  At first, I attempted to
try the unsupported upgrade, but I had nowhere near enough space to
pull in the packages and upgrade the system.  Next I tried installing,
but without reiniting the partition.  That didn't work either, for the
same reason - not enough space.  Fine, I could live with that.  So I
next attempted a clean installation, right over the top of the
previous Core 1, initializing the disk partition in the process.

The installation went very smoothly.  However, upon completion of the
installation, the first time the X server attempted to start, it
flashed several times, then failed and went back to the command line.
 Repeated attempts to install the X server failed.

Recently I've tried to install a 2.6 kernel on Debian and Mandrake
test systems and ran into similar problems, so I'm wondering if
perhaps some devices have changed between the 2.4 and 2.6 kernels that
aren't being automatically and properly handled.  Today I got a copy
of the Mandrake 10.0 RC1 kit and it installed OK.  Did anything change
with respect to the device naming convention?  Are there any known
kernel bugs that could affect the operation of the XFree86 server?  It
sure doesn't work for me.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Fedora Core 2 Test 1 on Dell Dimension 4100, NV graphics,
P991 monitor.
2. Configure the system to use the Dell P991 monitor at 1024x768.
3. Complete the installation and start X.

Actual Results:  The server flickers, but repeatedly won't start properly.

Expected Results:  Would expect to login to the X server normally. 
Currently restricted to console use.

Additional info:

I have several other disk partitions that are currently running Linux
software.  The X server works fine, performance and display is good.
Comment 1 Mike A. Harris 2004-02-25 18:47:56 EST
There are 2 or 3 different problems recently that result in X being
unable to start, or resulting in X hanging at startup.  Only one
of the 3 problems are XFree86 related, and a fix is in testing.

In order to know which problem you are experiencing, your X server
log, config file, and /var/log/messages are required as individual
uncompressed webbrowser viewable file attachments using the link

Comment 2 Mike A. Harris 2004-10-12 14:46:59 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:


If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.