Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1168784 - [virtio-win]win2012r2 guest shows black screen with error code "0x0000005c" after migration and reboot
Summary: [virtio-win]win2012r2 guest shows black screen with error code "0x0000005c" a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-28 02:04 UTC by Yang Meng
Modified: 2015-11-24 08:47 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:47:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
dump-debug-info (6.41 KB, text/plain)
2014-11-28 02:04 UTC, Yang Meng
no flags Details
bsod-0x0000005c (10.88 KB, image/png)
2014-11-28 02:05 UTC, Yang Meng
no flags Details
error (34.03 KB, image/png)
2014-11-28 02:06 UTC, Yang Meng
no flags Details
dump.txt(2014-12-3) (35.21 KB, text/plain)
2014-12-03 08:27 UTC, Yang Meng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Yang Meng 2014-11-28 02:04:55 UTC
Created attachment 962307 [details]
dump-debug-info

Description of problem:

win2012r2_x64 guest BSOD/error when start after migration.

Version-Release number of selected component (if applicable):
kernel: 3.10.0-206.el7.x86_64
qemu-kvm-1.5.3-79.el7.x86_64

How reproducible:
Tried 18 times ,3 times is like attachment "bsod.png",2 times is like "error.png"

3/18 

Steps to Reproduce:
1.Boot up source host:
qemu-kvm \
-M pc \
-nodefaults \
-vga qxl \
-global qxl-vga.vram_size=33554432 \
-chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmp,server,nowait \
-mon chardev=qmp_id_qmpmonitor1,mode=control \
-chardev socket,id=serial_id_serial0,path=/tmp/serial-serial,server,nowait \
-device isa-serial,chardev=serial_id_serial0 \
-chardev socket,id=seabioslog,path=/tmp/seabios-2014-11-24,server,nowait \
-device isa-debugcon,chardev=seabioslog,iobase=0x402 \
-device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
-drive id=drive-data-disk,if=none,cache=none,snapshot=off,format=raw,file=/mnt/2012win-meyang-1.raw \
-device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=04 \
-device scsi-hd,id=data-disk,bus=scsi1.0,drive=drive-data-disk \
-drive id=drive-data-disk1,if=none,cache=none,snapshot=off,format=raw,file=/mnt/2012win-meyang-2.raw \
-device virtio-scsi-pci,id=scsi2,bus=pci.0,addr=05 \
-device scsi-hd,id=data-disk1,bus=scsi2.0,drive=drive-data-disk1 \
-drive id=cdrom_d,if=none,file=/mnt/en_windows_server_2012_r2_x64_dvd_2707946.iso,media=cdrom,format=raw,readonly=on \
-device ide-drive,id=cdrom1,drive=cdrom_d \
-drive id=cdrom_d1,if=none,file=/mnt/driver.iso,media=cdrom,format=raw,readonly=on \
-device ide-drive,id=cdrom2,drive=cdrom_d1 \
-device intel-hda,id=sound0,bus=pci.0,addr=07 \
-device hda-duplex \
-device virtio-net-pci,mac=fa:f7:f8:5f:fa:5b,id=idn0VnaA,vectors=4,netdev=id8xJhp7,bus=pci.0,addr=06 \
-netdev tap,id=id8xJhp7,vhost=on \
-m 4096 \
-smp 2,maxcpus=3 \
-cpu 'Nehalem' \
-device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
-rtc base=utc,clock=host,driftfix=slew \
-boot order=cdn,once=c,menu=off \
-enable-kvm \
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 \
-spice port=8000,disable-ticketing \
-device nec-usb-xhci,id=xhci \
-device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x10 \
-device usb-bot,id=bot,bus=xhci.0 \
-drive file=/mnt/meyang-usb-cd.iso,if=none,id=usb-cdrom,format=raw \
-device scsi-cd,bus=bot.0,scsi-id=0,lun=1,drive=usb-cdrom,id=usb-cdrom \
-drive file=/mnt/meyang-usb-disk.qcow2,id=usb-disk,if=none,format=qcow2 \
-device scsi-hd,bus=bot.0,scsi-id=0,lun=0,drive=usb-disk,id=usb-disk \

2.Boot up Destination host:
just add -incoming "tcp:0:5800"
3.Start migration:
In source host qmp monitor,issue the following commands:
1)
{"execute": "qmp_capabilities"}
2)
{"execute": "migrate","arguments":{"uri": "tcp:10.66.84.16:5800"}}
3)wait for the migration until it is completed.
4.quit the source and destination
5.in source host ,start the vm again.

Actual results:
just like the screenshot in attachment or boot up successfully

Expected results:
no error ,no BSOD when start

Additional info:
1)source host cpu info:
processor	: 15
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E5-2650 v2 @ 2.60GHz
stepping	: 4
microcode	: 0x428
cpu MHz		: 3113.195
cache size	: 20480 KB
physical id	: 0
siblings	: 16
core id		: 7
cpu cores	: 8
apicid		: 15
initial apicid	: 15
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips	: 5187.72

2)destination host cpu info:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 44
model name	: Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz
stepping	: 2
microcode	: 0x10
cpu MHz		: 2394.067
cache size	: 12288 KB
physical id	: 0
siblings	: 8
core id		: 10
cpu cores	: 4
apicid		: 21
initial apicid	: 21
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt aes lahf_lm ida arat epb dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4788.13

Comment 1 Yang Meng 2014-11-28 02:05:48 UTC
Created attachment 962308 [details]
bsod-0x0000005c

Comment 2 Yang Meng 2014-11-28 02:06:12 UTC
Created attachment 962309 [details]
error

Comment 4 Ronen Hod 2014-12-01 14:38:57 UTC
Yang Meng, What version of virtio-win is used on the guest?
Vadim, I see 2012 QXL.

Comment 5 Vadim Rozenfeld 2014-12-01 20:25:34 UTC
(In reply to Ronen Hod from comment #4)
> Yang Meng, What version of virtio-win is used on the guest?
> Vadim, I see 2012 QXL.

Probably not related to QXL. Bugcheck error 0x5c indicates a problem,
happened during HAL initialization phase.

Comment 6 Yang Meng 2014-12-02 01:25:31 UTC
(In reply to Ronen Hod from comment #4)
> Yang Meng, What version of virtio-win is used on the guest?
> Vadim, I see 2012 QXL.

hi,the guest version is win2012r2-64.

Comment 7 Yang Meng 2014-12-02 01:59:32 UTC
(In reply to Ronen Hod from comment #4)
> Yang Meng, What version of virtio-win is used on the guest?
> Vadim, I see 2012 QXL.

hi,the virtio balloon driver version: 62.71.104.9400

Comment 12 Yang Meng 2014-12-03 08:27:31 UTC
Created attachment 964043 [details]
dump.txt(2014-12-3)

Comment 13 Yan Vugenfirer 2014-12-03 09:19:10 UTC
Is this dumb with build 95?

Comment 14 Yang Meng 2014-12-04 01:00:26 UTC
(In reply to Yan Vugenfirer from comment #13)
> Is this dumb with build 95?

no,i just opened the guest image i was using and using windbg to get the it.
i am on another job,when i finish it ,i could install the win2012r2 using build 95 drivers.thanks.

Comment 15 Yossi Hindin 2015-01-15 09:58:41 UTC
Please, test this bug usinh build virtio-win-prewhql-0.1-100

Comment 17 Yang Meng 2015-01-16 00:59:03 UTC
ok,i will do it as soon as i can.

Comment 18 Yang Meng 2015-04-17 03:21:55 UTC
Verified on:
3.10.0-230.el7.x86_64
qemu-kvm-1.5.3-86.el7.x86_64
virtio-win-prewhql-0.1-100.iso

source host:

processor	: 39
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E7-4830 v2 @ 2.20GHz
stepping	: 7
microcode	: 0x70d
cpu MHz		: 2200.000
cache size	: 20480 KB
physical id	: 1
siblings	: 20
core id		: 12
cpu cores	: 10
apicid		: 57
initial apicid	: 57
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms


dest host:

processor	: 23
vendor_id	: GenuineIntel
cpu family	: 6
model		: 45
model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
stepping	: 7
microcode	: 0x710
cpu MHz		: 1714.765
cache size	: 15360 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 43
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid



qemu-command:


/usr/libexec/qemu-kvm \
-M pc \
-nodefaults \
-vga qxl \
-global qxl-vga.vram_size=33554432 \
-chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmp,server,nowait \
-mon chardev=qmp_id_qmpmonitor1,mode=control \
-chardev socket,id=serial_id_serial0,path=/tmp/serial-serial,server,nowait \
-device isa-serial,chardev=serial_id_serial0 \
-chardev socket,id=seabioslog,path=/tmp/seabios-2015-04-17,server,nowait \
-device isa-debugcon,chardev=seabioslog,iobase=0x402 \
-device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
-drive id=drive-data-disk,if=none,cache=none,snapshot=off,format=raw,file=/mnt/win2012-64r2-virtio-scsi.raw \
-device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=04 \
-device scsi-hd,id=data-disk,bus=scsi1.0,drive=drive-data-disk \
-drive id=drive-data-disk1,if=none,cache=none,snapshot=off,format=raw,file=/mnt/2012win-meyang-2.raw \
-device virtio-scsi-pci,id=scsi2,bus=pci.0,addr=05 \
-device scsi-hd,id=data-disk1,bus=scsi2.0,drive=drive-data-disk1 \
-drive id=cdrom_d1,if=none,file=/mnt/virtio-win-prewhql-0.1-100.iso,media=cdrom,format=raw,readonly=on \
-device ide-drive,id=cdrom2,drive=cdrom_d1 \
-device intel-hda,id=sound0,bus=pci.0,addr=07 \
-device hda-duplex \
-device virtio-net-pci,mac=fa:f7:f8:5f:fa:5b,id=idn0VnaA,vectors=4,netdev=id8xJhp7,bus=pci.0,addr=06 \
-netdev tap,id=id8xJhp7,vhost=on \
-m 4096 \
-smp 2,maxcpus=3 \
-cpu 'Nehalem' \
-device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
-rtc base=utc,clock=host,driftfix=slew \
-boot order=cdn,once=c,menu=off \
-enable-kvm \
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 \
-spice port=8000,disable-ticketing \
-monitor stdio \

I tried 18 times and there is no black screeen after migration.so will mark the bug as verified ,if there is anything wrong ,please contact me.

Comment 19 jason wang 2015-04-17 03:26:49 UTC
(In reply to Yang Meng from comment #18)
> Verified on:
> 3.10.0-230.el7.x86_64
> qemu-kvm-1.5.3-86.el7.x86_64
> virtio-win-prewhql-0.1-100.iso
> 
> source host:
> 
> processor	: 39
> vendor_id	: GenuineIntel
> cpu family	: 6
> model		: 62
> model name	: Intel(R) Xeon(R) CPU E7-4830 v2 @ 2.20GHz
> stepping	: 7
> microcode	: 0x70d
> cpu MHz		: 2200.000
> cache size	: 20480 KB
> physical id	: 1
> siblings	: 20
> core id		: 12
> cpu cores	: 10
> apicid		: 57
> initial apicid	: 57
> fpu		: yes
> fpu_exception	: yes
> cpuid level	: 13
> wp		: yes
> flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
> pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb
> rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology
> nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx
> est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt
> tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt
> pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
> 
> 
> dest host:
> 
> processor	: 23
> vendor_id	: GenuineIntel
> cpu family	: 6
> model		: 45
> model name	: Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
> stepping	: 7
> microcode	: 0x710
> cpu MHz		: 1714.765
> cache size	: 15360 KB
> physical id	: 1
> siblings	: 12
> core id		: 5
> cpu cores	: 6
> apicid		: 43
> initial apicid	: 43
> fpu		: yes
> fpu_exception	: yes
> cpuid level	: 13
> wp		: yes
> flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
> pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb
> rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology
> nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx
> est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt
> tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts
> dtherm tpr_shadow vnmi flexpriority ept vpid
> 
> 
> 
> qemu-command:
> 
> 
> /usr/libexec/qemu-kvm \
> -M pc \
> -nodefaults \
> -vga qxl \
> -global qxl-vga.vram_size=33554432 \
> -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmp,server,nowait \
> -mon chardev=qmp_id_qmpmonitor1,mode=control \
> -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial,server,nowait \
> -device isa-serial,chardev=serial_id_serial0 \
> -chardev socket,id=seabioslog,path=/tmp/seabios-2015-04-17,server,nowait \
> -device isa-debugcon,chardev=seabioslog,iobase=0x402 \
> -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
> -drive
> id=drive-data-disk,if=none,cache=none,snapshot=off,format=raw,file=/mnt/
> win2012-64r2-virtio-scsi.raw \
> -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=04 \
> -device scsi-hd,id=data-disk,bus=scsi1.0,drive=drive-data-disk \
> -drive
> id=drive-data-disk1,if=none,cache=none,snapshot=off,format=raw,file=/mnt/
> 2012win-meyang-2.raw \
> -device virtio-scsi-pci,id=scsi2,bus=pci.0,addr=05 \
> -device scsi-hd,id=data-disk1,bus=scsi2.0,drive=drive-data-disk1 \
> -drive
> id=cdrom_d1,if=none,file=/mnt/virtio-win-prewhql-0.1-100.iso,media=cdrom,
> format=raw,readonly=on \
> -device ide-drive,id=cdrom2,drive=cdrom_d1 \
> -device intel-hda,id=sound0,bus=pci.0,addr=07 \
> -device hda-duplex \
> -device
> virtio-net-pci,mac=fa:f7:f8:5f:fa:5b,id=idn0VnaA,vectors=4,netdev=id8xJhp7,
> bus=pci.0,addr=06 \
> -netdev tap,id=id8xJhp7,vhost=on \
> -m 4096 \
> -smp 2,maxcpus=3 \
> -cpu 'Nehalem' \
> -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
> -rtc base=utc,clock=host,driftfix=slew \
> -boot order=cdn,once=c,menu=off \
> -enable-kvm \
> -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 \
> -spice port=8000,disable-ticketing \
> -monitor stdio \
> 
> I tried 18 times and there is no black screeen after migration.so will mark
> the bug as verified ,if there is anything wrong ,please contact me.

I think you should move the status to VERIFIED? :)

Comment 21 lijin 2015-07-17 07:26:58 UTC
changed status to verified according to comment#18

Comment 23 errata-xmlrpc 2015-11-24 08:47:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.