Bug 116883 - reboot with 2.6.3-1.100smp and 2.6.3-1.106smp fails
Summary: reboot with 2.6.3-1.100smp and 2.6.3-1.106smp fails
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-25 22:50 UTC by Peter J. Dohm
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 23:51:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter J. Dohm 2004-02-25 22:50:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
T312461; .NET CLR 1.1.4322)

Description of problem:
"Error: Cannot open device /dev/mirrored/root" error occurs in the 
following situation:

mirrored /boot
mirrored lvm physical volume
volume group /dev/mirrored created using above physical volume
root, usr, opt, var, etc, are logical volumes sliced out of the 
volume group above.
during "Checking root filesystem" this error occurs, and we drop into 
the single-user mode password check.

it appears to me that the LVM modules were not included in the last 
two kernels built.


Version-Release number of selected component (if applicable):
kernel-2.6.3-1.100smp and kernel-2.6.3-1.106smp

How reproducible:
Always

Steps to Reproduce:
1.build a machine with a disk layout described above
2.upgrade the kernel to one of the most recent ones
3.whine and cry like a baby :)
    

Actual Results:  dropped to single user mode

Expected Results:  worked in the prior kernels just fine, so i'd 
expect that it was intended to work at some point

Additional info:

i think it's simply that the LVM modules weren't compiled in, but i'm 
not 100% certain.

Comment 1 Jeremy Katz 2004-05-07 03:41:41 UTC
Is this working with newer kernels?


Note You need to log in before you can comment on or make changes to this bug.