Bug 116896 - Split screen waking up from sleep (horizontal)
Split screen waking up from sleep (horizontal)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 21:08 EST by charles livsey
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 03:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config file (3.17 KB, text/plain)
2005-03-07 10:25 EST, charles livsey
no flags Details
old X log (33.17 KB, text/plain)
2005-03-07 11:57 EST, charles livsey
no flags Details
X log (33.64 KB, text/plain)
2005-03-07 11:58 EST, charles livsey
no flags Details
from 2/2004 (31.86 KB, text/plain)
2005-03-07 11:59 EST, charles livsey
no flags Details

  None (edit)
Description charles livsey 2004-02-25 21:08:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
The toolbar at the bottom of the screen moves to the middle of the
screen and everything on the screen is horizontally split after going
into hibernation/sleep. I tried changing the apmd file
(/etc/sysconfig/apmd) to a different virual display other than 7 for
the X window but that didn't change anything.  I am considering
altering the apmscript file (/etc/sysconfig/apm-scrpts/apmscript)
despite being told not to (within the file), but I thought I would at
least report the problem first.  This was also a problem in RH 9, and
I was hoping it would be resolved in Enterprise.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Wait 15-20 minutes with battery power.
2.Screen goes black.
3.Bring display back with mouse or keyboard and screen is split.
    

Actual Results:  Screen was split.  Mouse still works in usual
location such that have to imagine where it should be acting to log
off.  Then you can relog on and everything works except one program,
Ximian Evolution.

Expected Results:  Screen should have returned to normal state.

Additional info:

A secondary resolution would be to prevent the computer from
hibernating until the battery became much closer to running out of
charge.  Now it everything is shutting down very early and there
doesn't seem to be an easy way of regulating that.
Comment 1 charles livsey 2004-03-09 08:14:02 EST
This doesn't seem to occur due simply to screen going blank, as when
screen goes blank after screen saver it does not occur; but when I
close the lid of computer and screen supposedly does not go blank (now
that I reset BIOS) it does occur.
Comment 2 Mike A. Harris 2005-03-06 18:10:15 EST
Does this problem still occur with the latest RHEL 3 update release,
with all current erratum applied?
Comment 3 charles livsey 2005-03-06 21:27:51 EST
Yes, I checked and it still produces the bug with the latest RHEL 3
update release, with all current erratum applied.
Comment 4 Mike A. Harris 2005-03-07 10:03:21 EST
Ok, please attach your X server log file and config file using
the file attachment link below.
Comment 5 charles livsey 2005-03-07 10:25:03 EST
Created attachment 111739 [details]
config file
Comment 6 charles livsey 2005-03-07 10:45:23 EST
Unable to locate log file.  Can you give me specific name?
Comment 7 Mike A. Harris 2005-03-07 11:38:55 EST
/var/log/XFree86*
Comment 8 charles livsey 2005-03-07 11:57:53 EST
Created attachment 111747 [details]
old X log
Comment 9 charles livsey 2005-03-07 11:58:26 EST
Created attachment 111748 [details]
X log
Comment 10 charles livsey 2005-03-07 11:59:34 EST
Created attachment 111749 [details]
from 2/2004
Comment 12 Mike A. Harris 2005-05-12 03:39:30 EDT
Problems of this nature are usually BIOS bugs, and are generally not
fixable except by upgrading the BIOS.  Please check to see if your
vendor has an updated BIOS and try updating to that if one is
available.  If that does not solve the problem, contacting your
hardware vendor might be your best bet.

Red Hat is unable to diagnose the problem without direct access to
the hardware however, and such problems usually turn out to be BIOS
problems.  It is rare that such problems are caused by video driver
bugs, and due to the obfuscated nature of the "nv" driver, and lack
of documentation for it (Nvidia doesn't provide hardware documentation),
we would most likely be unable to fix the problem if it were driver
related.

Setting status to "WONTFIX" due to lack of hardware, and unlikelyhood
of being able to resolve the issue even if hardware was available.

Note You need to log in before you can comment on or make changes to this bug.