Bug 116899 - Non-smooth video response while battery charge monitor applet running
Summary: Non-smooth video response while battery charge monitor applet running
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-26 05:07 UTC by Tim Keitt
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 13:10:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Keitt 2004-02-26 05:07:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
I've been noticing non-smooth scrolling and video playback on my Dell
610 (ATI Radeon Mobility). I belive the cause is having the "battery
charge monitor" applet running. It must be reading the charge
information from a /proc file every second or so, because video or
scrolling suddenly pauses for 1/10th second at roughly 1/2-1 second
intervals. My guess is that reading this information triggers a global
kernel lock and this stalls X updates noticably. Removing the applet
from the panel restores smooth scrolling and video playback. I'm using
acpi, but my recollection is that this also occurs with apm.

Version-Release number of selected component (if applicable):
2.4.1-1

How reproducible:
Always

Steps to Reproduce:
1. Run battery charge monitor applet
2. Scroll browser window or play video with mplayer, etc
3. 
    

Actual Results:  Scrolling stops for 1/10 second at 1/2-1 second
intervals.

Expected Results:  Smooth scrolling.

Additional info:

Comment 1 Bart Martens 2004-02-28 12:47:58 UTC
Have a look at bug #97322. Lowering the frequency of checks is
appropriate, but I guess that's not enough to solve your video problem.

Maybe the patch(es) of bug #104292 solve your problem?


Comment 2 Mark McLoughlin 2004-07-19 13:51:50 UTC
Do you still see this problem with Fedora Core 2?

Comment 3 Mark McLoughlin 2004-12-20 13:10:07 UTC
No response, assuming not


Note You need to log in before you can comment on or make changes to this bug.