Bug 116901 - Potential bug in xf86Elo.c
Potential bug in xf86Elo.c
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-26 01:12 EST by Miro Halas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 22:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed xf86Elo.c synced against version 1.17 of xfree86 (51.85 KB, patch)
2004-04-19 12:37 EDT, Miro Halas
no flags Details | Diff

  None (edit)
Description Miro Halas 2004-02-26 01:12:50 EST
Description of problem:

I have two elographics touchscreens connected to Matrox G450 running
Fedora Core 1 (whatever version of XFree86 it is using). I have 
problem that the cursor doesn't correctly follow the touch, that is 
when I tap in the second touchscreen than where the cursor is 
currently, it doesn't go there. I have to keep my finger on the 
touchscreen and eventually the cursor goes to the correct 
touchscreen. Once it is in correct touchscreen everything works just 
fine.

I poke around the code in xf86Elo.c and it seems like the call to
xf86XInputSetScreen doesn't get executed properly. THis calls is made 
in this driver in xf86EloConvert which is setup as conversion_proc.

I read the documentation for xf86XInputSetScreen in xf86XInput.c and 
it says that this method should be called in ReadInput method which 
is for this driver method xf86EloReadInput. COuld this be a potential 
problem causing the xf86XInputSetScreen to don't get executed?

I am not sure what is the correct process to fix this and I would like
to ask somebody more experienced. Could anybody please help me with 
this?
Comment 1 Mike A. Harris 2004-02-26 12:21:18 EST
I do not have access to the touchscreen hardware you are having this
problem with, so I am unable to assess wether it is really a bug, or
is just a misconfiguration.  There isn't really much I can do about
the problem.  The touchscreen drivers are more or less supplied
'as-is' how XFree86.org ships them.

Please report this bug in XFree86 bugzilla at http://bugs.xfree86.org
and include the full details of your problem there.  Paste the URL
here to the upstream bug report, and I can then track the issue in
the upstream bugzilla.

If a real bug is found and fixed upstream, I can review the patches
for consideration in future Red Hat XFree86 builds.

>I am not sure what is the correct process to fix this and I would
>like to ask somebody more experienced. Could anybody please help me
>with this?

The best place for seeking assistance debugging or developing
XFree86 drivers, is the devel@xfree86.org mailing list.  Hopefully
someone on the list is familiar with the driver in question.  You
may also try looking through the driver's source code to find the
names and possibly the email addresses of the author and other
contributors.  They will be much more likely able to help you
with the problem you're experiencing.

Please update the report with the upstream bug URL once you've
filed it in XFree86's bug tracker, and I'll track it there.

Thanks in advance.
Comment 2 Miro Halas 2004-04-19 12:36:39 EDT
Mike, I have found the bug, fixed it and we have intensively tested it
for about 2-3 months on several workstations with two touchscreens and
it worked perfectly. Since I see that Redhat is in progress of
switching to different X distribution, I will try to submit my patch
to both distributions and here as well so it doesn't get lost. Maybe
you can make sure it gets to merged. Thanks a lot and appreciate your
help.'

The xfree86 bug number is 1347
Comment 3 Miro Halas 2004-04-19 12:37:34 EDT
Created attachment 99532 [details]
Fixed xf86Elo.c synced against version 1.17 of xfree86
Comment 4 Miro Halas 2004-04-19 12:47:22 EDT
The x.org bug # is 506.
Comment 5 Mike A. Harris 2004-04-19 13:09:12 EDT
Please supply patches in unified diff format against the version of
the sources which we ship.  Patches need to apply cleanly with no
hunk offsets.  Also, please do not include any code from newer
XFree86 versions of the driver, as there are licensing issues in
the XFree86 tree, which may preclude our consideration of inclusion.

IOW, we need to have a unified diff (diff -u) of just the specific
bug fix against our own shipping source.

On a side note..  If the XFree86 source tree contains any other
fixes to this driver that postdate the license change, the
individual authors of those fixes need to be contacted and
explicit permission granted by them to use the fixes under an
MIT/X11 style license granted, as the terms of the XFree86
version 1.1 license are unacceptable.

Thanks in advance.
Comment 6 Mike A. Harris 2004-04-19 22:29:42 EDT
I've added myself to the upstream bug report to track this request
upstream.  Once the requested enhancements have been integrated
into the upstream X.org CVS, I will review via cvs rdiff for
consideration for future updates.

http://pdx.freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=506

Flagging bug as 'UPSTREAM' for tracking purposes.
Comment 7 Mike A. Harris 2004-09-01 07:15:53 EDT
Status update: The upstream bug report has not received comment
or review, and doesn't appear to have been committed to CVS for
the 6.8.0 release.  We'll continue to track the bug in the
upstream bugzilla, however you may want to ping the developers
in the upstream bug report, or discuss the patch on the xorg
mailing list, in hopes someone looks at it soon.

Updated upstream bug report URL:

    http://freedesktop.org/bugzilla/show_bug.cgi?id=506

Note You need to log in before you can comment on or make changes to this bug.