Bug 1169023 - Many translations missing from anaconda 21.48.18 and 21.48.19
Summary: Many translations missing from anaconda 21.48.18 and 21.48.19
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-29 03:35 UTC by Adam Williamson
Modified: 2014-12-05 19:08 UTC (History)
11 users (show)

Fixed In Version: anaconda-21.48.20-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-05 19:08:55 UTC


Attachments (Terms of Use)
Final TC4 Workstation live during-install hub, in Japanese (note full translations) (163.43 KB, image/png)
2014-12-02 00:08 UTC, Adam Williamson
no flags Details
Final pre-RC2 (anaconda 21.48-20) Workstation live during-install hub, in Japanese (note most translations missing) (122.50 KB, image/png)
2014-12-02 00:12 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2014-11-29 03:35:01 UTC
In Fedora 21 Final RC1, in multiple languages, many translations appear missing from the installer. For instance, in Russian, the entire 'Installation Destination' screen was translated in Final TC4 (anaconda 21.48.16); in Final RC1 (21.48.18), only one string plus the disk size units (GiB, KiB etc) are translated.

With 21.48.18 and 21.48.19, strings /usr/share/locale/ru/LC_MESSAGES/anaconda.mo | wc -l gives 444. With 21.48.16 and 21.48.17, it gives 1815. Not just Russian is affected, Japanese (474 vs. 2206), French (1107 vs. 3672) and others are also affected.

This may be causing or contributing to https://bugzilla.redhat.com/show_bug.cgi?id=1169019 and https://bugzilla.redhat.com/show_bug.cgi?id=1169020 .

Comment 1 Adam Williamson 2014-11-29 03:41:24 UTC
Proposing as a Final blocker, criterion https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Installer_translations - "The installer must correctly display all sufficiently complete translations available for use."

Comment 2 Adam Williamson 2014-11-29 03:58:25 UTC
The translations are bad in the tarballs. I'm guessing there's some subtlety to the tarball generation which Vratislav wasn't aware of (he built the 21.48.18 and 21.48.19 tarballs; Samantha had done all the others recently).

Comment 3 Vratislav Podzimek 2014-11-30 16:34:40 UTC
(In reply to Adam Williamson (Red Hat) from comment #2)
> The translations are bad in the tarballs. I'm guessing there's some subtlety
> to the tarball generation which Vratislav wasn't aware of (he built the
> 21.48.18 and 21.48.19 tarballs; Samantha had done all the others recently).
My guess is the same. Will try to find out what went bad in the build process tomorrow.

Comment 4 Vratislav Podzimek 2014-12-01 09:10:04 UTC
Turns out the way we download translations during tarball creation doesn't fetch translations for languages that already have some .po file downloaded even if it is totally out of date or even for a different branch. Fix sent to anaconda-patches.

Comment 5 Mike Ruckman 2014-12-01 16:26:26 UTC
Discussed in 2014-12-01 blocker review meeting. Accepted as a blocker: this is a clear violation of the criterion requiring translations be present "The installer must correctly display all sufficiently complete translations available for use."

Comment 6 Adam Williamson 2014-12-02 00:06:19 UTC
Somehow, a live image composed with .20 still does not seem to display a lot of translations.

The anaconda.mo files seem to be better in .20, but there's still a bug of some kind. I have one VM running an install in Japanese with Final TC4, and one with a smoketest live image composed with anaconda .20. On the 'during install' hub, every string is translated in Final TC4; in the smoketest image, only the orange alert bar at the bottom of the screen, the title at the very top of the screen next to the Fedora logo, and the 'Finish' button are translated.

Will attach screenshots.

Comment 7 Adam Williamson 2014-12-02 00:08:00 UTC
Created attachment 963454 [details]
Final TC4 Workstation live during-install hub, in Japanese (note full translations)

Comment 8 Adam Williamson 2014-12-02 00:12:01 UTC
Created attachment 963455 [details]
Final pre-RC2 (anaconda 21.48-20) Workstation live during-install hub, in Japanese (note most translations missing)

Comment 9 Adam Williamson 2014-12-02 01:09:31 UTC
Ah. So, a wild guess helps. It appears to be the 'fix' for https://bugzilla.redhat.com/show_bug.cgi?id=1169019 that breaks this. If I edit /usr/sbin/liveinst.py and comment out this block:

if [ -z $LC_ALL ]; then
    # LC_ALL not set, set it to $LANG to make Python's default encoding
    # detection work
    export LC_ALL=$LANG
fi

then the interface is fully translated when I run the installer.

Comment 10 Adam Williamson 2014-12-02 09:28:10 UTC
so yeah, this particular bug - that the .mo files themselves were incomplete - is definitely fixed in 21.48.20 (and 21.48.21), I have verified that. The cause of the translations not fully showing up in the UI in RC1 is completely different, and covered in #1169019. We can call this bug VERIFIED.

Comment 11 Rolle 2014-12-02 11:48:00 UTC
During installation with anaconda, the last information is not translated to (only?) german. When the installation process is finished it says "The instaltion is done. You can reboot now.". I don't remember the exact strings and may vary, but this info is in english and not german. Also the button to close anaconda is not translated yet. It is labeled with the english word "Quit".

Comment 12 Wolfgang Ulbrich 2014-12-03 13:29:35 UTC
All is now translated in German in the anaconda, exept the help button and help (yelp) itself. Testeted with TC4 netiso and mate live image, no crashes.

Comment 13 Rolle 2014-12-05 10:20:47 UTC
(In reply to Rolle from comment #11)
> During installation with anaconda, the last information is not translated to
> (only?) german. When the installation process is finished it says "The
> instaltion is done. You can reboot now.". I don't remember the exact strings
> and may vary, but this info is in english and not german. Also the button to
> close anaconda is not translated yet. It is labeled with the english word
> "Quit".

In "Fedora-Live-Workstation-x86_64-21-5.iso" this is fixed. Fine.

Comment 14 Rolle 2014-12-05 10:29:00 UTC
(In reply to Wolfgang Ulbrich from comment #12)
> All is now translated in German in the anaconda, exept the help button and
> help (yelp) itself. Testeted with TC4 netiso and mate live image, no crashes.

In "Fedora-Live-Workstation-x86_64-21-5.iso" there are already strings shown in english (not german). I don't know if this has to do with the mentioned bug in "Comment 10" (#1169019).
The strings on the "manual partition" page is on the right bottom the "Update"-Button and underneath an informational text. Both (the button and the informational text) are shown in english.

Comment 15 Adam Williamson 2014-12-05 19:08:55 UTC
rolle: the German translation is listed as 92% complete on transifex:

https://fedora.transifex.com/projects/p/anaconda/

so it's expected that some bits aren't done yet. If you see the same incompletions in TC4, it's probably just a translation that didn't get done yet. This bug was about translations that the translators had written not being included in the anaconda packages.

This bug is verified fixed in the anaconda package shipped in Final, so closing.


Note You need to log in before you can comment on or make changes to this bug.