Bug 116909 - fgrep gives false negatives
Summary: fgrep gives false negatives
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grep   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target 479150
TreeView+ depends on / blocked
 
Reported: 2004-02-26 11:31 UTC by Tim Waugh
Modified: 2009-01-07 16:10 UTC (History)
0 users

Fixed In Version: 2.5.1-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 23:15:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:449 normal SHIPPED_LIVE Updated grep package 2005-05-19 04:00:00 UTC

Description Tim Waugh 2004-02-26 11:31:08 UTC
Description of problem:
fgrep fails to report some matches.

Version-Release number of selected component (if applicable):
2.5.1-25 (happens in 2.5.1-16 too)

How reproducible:
100%

Steps to Reproduce:

cat >a <<EOF
a
b
c
EOF
cat >b <<EOF
a
barn
c
EOF
fgrep -w -f a b

Actual results:
a

Expected results:
a
c

Comment 1 Tim Waugh 2004-02-26 11:31:29 UTC
Might be the cause of bug #97526.

Comment 3 Dennis Gregorovic 2005-05-20 03:25:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-449.html



Note You need to log in before you can comment on or make changes to this bug.