Bug 116911 - APLAWS+: 'Quick Start Install Guide' Suspected Errors/Omissions
Summary: APLAWS+: 'Quick Start Install Guide' Suspected Errors/Omissions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Daniel Berrange
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-26 12:10 UTC by Chris Kelly
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 11:25:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Kelly 2004-02-26 12:10:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
Q312461)

Description of problem:
Discovered when installing APLAWS+ Production Server on RHEL 3:

Appendix B1 
- instead of 'up2date postgresql-server' use 'up2date rh-postgresql-
server'*

'4.1.2. CCM Runtime' 
- to avoid conflicts with existing packages which ship with RHEL, 
before doing anything else, execute the following from the terminal 
window as root 'rpm -e junit ant ant-libs'

'4.1.3. APLAWS Applications'
P19 - It's implied that both the CCM_CONFIG... env variables are 
required, but they don't seem to be.

'4.3.2. Loading APLAWS+'
- for 'ccm set waf.runtime.db_pool_size=100' we got a 'no such 
parameter' message

Discovered when installing on Fedora:

'4.3.2. Loading APLAWS+'
- we needed to modify rights to /opt/resin/2.1.12/bin and wrapper.pl 
within it.

* Not actually tested by us, due to problems with the RHN
 

Version-Release number of selected component (if applicable):
February 2004 Beta

How reproducible:
Didn't try


Additional info:

Comment 1 Daniel Berrange 2004-02-26 16:21:00 UTC
The above points have all been incorporated in the documentation
updates, with the exception of:

> '4.3.2. Loading APLAWS+'
> - we needed to modify rights to /opt/resin/2.1.12/bin and wrapper.pl 
> within it.

Please provide more detailed information on this point, since we are
unable to reproduce it & the above information is not sufficient to
include in documentation

Comment 2 Chris Kelly 2004-02-27 10:59:50 UTC
Apologies but I can't give much more information, except to say that 

1. in our experience, the 'ccm load-bundle --interactive --name 
aplaws-standard' command didn't do much without changing rights to 
wrapper.pl. 

2.we saw this problem twice, once on Red Hat 9 & once on Fedora.

Comment 3 Daniel Berrange 2004-02-27 11:04:17 UTC
This sounds dubious because 'ccm load-bundle' has nothing todo with
starting resin (& thus running wrapper.pl). The only thing that will
use wrapper.pl is 'ccm start' / 'ccm stop'. Before we can document it,
at minimum we need to know what command was failing, what the original
permissions were & what you changed them too.

Comment 4 Chris Kelly 2004-02-27 11:23:48 UTC
As I said, I don't have further information since I personally didn't 
actually do the install on Fedora. If you are saying you have done so 
following the  'Quick Start Install Guide' & you didn't see this 
problem, I'll take your word for it.







Comment 5 Daniel Berrange 2004-02-27 11:25:22 UTC
Ok I'm closing this bug as resolved then. If you come across it again,
please collect as much information as possible & open a new bugzilla
ticket.



Note You need to log in before you can comment on or make changes to this bug.