Bug 116920 - Add/Remove Programs will not
Add/Remove Programs will not
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-02-26 09:22 EST by Sean Earp
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 11:16:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Earp 2004-02-26 09:22:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5) Gecko/20031026 Firebird/0.7

Description of problem:
I have tried to install several different packages (ABI Word, GNU
Cash, OpenSSL) using the "Add/Remove Programs" utility.  The programs
I have tried to add each happen to be located on different CDs.  After
checking dependencies, the program asks me to insert the appropriate
CD (which I do), and after scanning the CD, the error message:

----------

Error installing packages

There was an error installing packages.

Exiting

----------

Pops up... After hitting "OK", the entire program exits.  This happens
with every program I try to add.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Add/Remove programs utility
2.Attempt to add a program that is not already installed
3.
    

Actual Results:  Add/Remove programs exits with error message above

Expected Results:  The additional programs I chose should be
installed.  If I have inserted the wrong CD, or the package can not be
read, a more descriptive error message should be displayed, and the
program should move to a recoverable state, not completely exit.

Additional info:
Comment 1 Sean Earp 2004-02-28 14:27:51 EST
I see that bug 109276 relates to the exact same problem.  According to
the post, however, the issue was resolved with redhat-config-packages
1.2.7.

I am using system-config-packages-1.9.3-2.1    and the problem is back...
Comment 2 Sean Earp 2004-02-28 14:31:00 EST
And in case it helps, you asked for the following in the last bug:

$ cat /usr/share/comps/i386/.discinfo
1075909814.768367
Fedora Core 1.90
i386
1,2,3
Fedora/base
Fedora/RPMS
Fedora/pixmaps
Comment 3 Sean Earp 2004-04-04 21:35:26 EDT
Alrighty... just installed FC2 Test 2 from scratch, and the problem
still exists.  Version is now:  system-config-packages-1.2.10-1
Comment 4 Robert Hostetter 2004-04-30 18:48:56 EDT
Having this same problem in test 3.
Comment 5 Jef Spaleta 2004-05-06 00:35:01 EDT
Just tried this on my fresh test3 install, upgraded today to the
available updates from rawhide. I'm not seeing this specific problem
mentioned by the original reporter. I'm pretty sure the only problem
I'm currently seeing is magicdev automounting related.

s-c-packages seems to be working, asking for the next cd and then
letting me continue once i put the cd in the tray. Automounting seems
to still be getting in the way sometimes giving me a can not access
disc error...magicdev is so not my friend.  But if I just place the
new install disc thats being asked for in the tray and do not manually
close the tray, s-c-p will close the tray for me and see the disk
correctly consistently.  And if i turn off magicdev completely s-c-p
seems to be working flawlessly for me to install packages from across
multiple install cds 1,2 and 3 in one software add session.

system-config-packages version 1.2.12-1
Comment 6 Jeremy Katz 2004-11-01 11:16:49 EST
This should be fixed with newer versions.

Note You need to log in before you can comment on or make changes to this bug.