Bug 1169332 - Product CSS replaces (rather than supplementing) anaconda's, various visual problems in Product installs (no highlight in custom part, blue not orange, etc etc)
Summary: Product CSS replaces (rather than supplementing) anaconda's, various visual p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-productimg-workstation
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-12-01 10:58 UTC by Kamil Páral
Modified: 2014-12-04 23:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-04 23:10:28 UTC
Type: Bug


Attachments (Terms of Use)
custom-part-TC4.png (110.22 KB, image/png)
2014-12-01 10:59 UTC, Kamil Páral
no flags Details
custom-part-RC1.ogv (206.87 KB, application/ogg)
2014-12-01 10:59 UTC, Kamil Páral
no flags Details
warning-TC4.png (184.12 KB, image/png)
2014-12-01 11:00 UTC, Kamil Páral
no flags Details
warning-RC1.png (177.77 KB, image/png)
2014-12-01 11:00 UTC, Kamil Páral
no flags Details
password-TC4.png (46.37 KB, image/png)
2014-12-01 11:00 UTC, Kamil Páral
no flags Details
password-RC1.png (47.51 KB, image/png)
2014-12-01 11:00 UTC, Kamil Páral
no flags Details
rpm-qa.TC4 (46.08 KB, text/plain)
2014-12-01 11:00 UTC, Kamil Páral
no flags Details
rpm-qa.RC1 (46.19 KB, text/plain)
2014-12-01 11:00 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2014-12-01 10:58:29 UTC
Description of problem:
In RC1 a lot of widgets have a totally different color than in TC4. For example:

* the warning bar (bottom of the screen) used to be orange, now it blue. It's quite hard to notice it now, especially with the Workstation product (a lot of blue graphics)
* item selection in custom part used to have a blue background, now it has transparent background -> you can't see which partition is selected
* the password strength meter used to be red, now it orange
* maybe something I haven't noticed

I guess the change is somehow related to added branding and was not intentional. The biggest issue is I believe the custom partitioning, it's quite difficult to work with it when you don't see which partition is selected. The second biggest issue is probably the bottom bar being quite invisible, so people might be quite confused (e.g. waiting for installation to finish, but anaconda is actually waiting for them, they just haven't noticed).

Some additional info from Vratislav:

<vpodzime> kparal: append the information that the product CSS is not applied as an update, but replacement for the original anaconda's CSS (might be a lorax issue)
<vpodzime> kparal: it's either a lorax issue that it replaces the anaconda's CSS with the product's one or productization issue because they provide uncomplete CSS or a wrong path for their CSS

Reporting against fedora-productimg-workstation, because I don't know which component is the best fit, but this also applies to server branding.

Version-Release number of selected component (if applicable):
RC1 all images (Workstation, Server)
anaconda-21.48.18-1.fc21.x86_64

Comment 1 Kamil Páral 2014-12-01 10:59:53 UTC
Created attachment 963229 [details]
custom-part-TC4.png

Comment 2 Kamil Páral 2014-12-01 10:59:57 UTC
Created attachment 963230 [details]
custom-part-RC1.ogv

Comment 3 Kamil Páral 2014-12-01 11:00:00 UTC
Created attachment 963231 [details]
warning-TC4.png

Comment 4 Kamil Páral 2014-12-01 11:00:02 UTC
Created attachment 963232 [details]
warning-RC1.png

Comment 5 Kamil Páral 2014-12-01 11:00:05 UTC
Created attachment 963233 [details]
password-TC4.png

Comment 6 Kamil Páral 2014-12-01 11:00:07 UTC
Created attachment 963234 [details]
password-RC1.png

Comment 7 Kamil Páral 2014-12-01 11:00:17 UTC
Created attachment 963235 [details]
rpm-qa.TC4

Comment 8 Kamil Páral 2014-12-01 11:00:20 UTC
Created attachment 963236 [details]
rpm-qa.RC1

Comment 9 Kamil Páral 2014-12-01 11:05:24 UTC
Proposing for a freeze exception, or potentially even a blocker, if we deem the custom partitioning issue as too important.

Comment 10 Stephen Gallagher 2014-12-01 13:29:53 UTC
For what it's worth, I'm -1 blocker on this.

Comment 11 Stephen Gallagher 2014-12-01 13:31:17 UTC
(In reply to Stephen Gallagher from comment #10)
> For what it's worth, I'm -1 blocker on this.

Disregard that. I started typing that, re-read the bit about the custom partitioning and changed my mind. I then CCed the people needed to fix it and forgot to remove my -1 blocker comment before hitting save.

Comment 12 Stephen Gallagher 2014-12-01 15:19:45 UTC
OK, so the problem here is that lorax is replacing the anaconda-gtk.css with the custom one contained in the fedora-productimg-* packages. The truly correct behavior would be for them to somehow make their way to /run/install/product/anaconda-gtk.css where anaconda would automatically merge them instead of replacing it.

However, this is difficult to accomplish at this late stage, so our workaround will be to manually merge the CSS contents in the fedora-productimg-* packages so that the replacement results in the correct behavior. I'm working on this right now.

Comment 13 Stephen Gallagher 2014-12-01 16:24:23 UTC
Fixes are building in Koji right now.

Comment 14 Fedora Update System 2014-12-01 16:50:43 UTC
fedora-productimg-workstation-21-8.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fedora-productimg-workstation-21-8.fc21

Comment 15 Fedora Update System 2014-12-01 16:52:49 UTC
fedora-productimg-server-21-8.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fedora-productimg-server-21-8.fc21

Comment 16 Fedora Update System 2014-12-01 16:54:39 UTC
fedora-productimg-cloud-21-8.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fedora-productimg-cloud-21-8.fc21

Comment 17 Matthew Miller 2014-12-01 16:59:09 UTC
(Three separate updates, since the packages conflict and bodhi doesn't let them go together. I marked the workstation one as closing this bug, as it's the most visible, but the server one is obviously pretty important too -- probably that's where the angry messages about custom partitioning will be clustered....)

Comment 18 Mike Ruckman 2014-12-01 17:25:20 UTC
Discussed in 2014-12-01 blocker review meeting. Accepted as an FE: the combination of broken elements here leads to a significantly degraded user experience, and is a clear regression from all previous tested composes.

Comment 19 Fedora Update System 2014-12-02 01:04:36 UTC
Package fedora-productimg-workstation-21-8.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-productimg-workstation-21-8.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16088/fedora-productimg-workstation-21-8.fc21
then log in and leave karma (feedback).

Comment 20 Adam Williamson 2014-12-02 19:59:55 UTC
Fix for this looks good in RC2.

Comment 21 Fedora Update System 2014-12-03 17:15:46 UTC
fedora-productimg-workstation-21-8.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-12-03 17:15:53 UTC
fedora-productimg-cloud-21-8.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2014-12-03 17:16:07 UTC
fedora-productimg-server-21-8.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Adam Williamson 2014-12-04 21:00:15 UTC
Re-opening for Rawhide, this is not addressed there yet.

Comment 25 Adam Williamson 2014-12-04 21:01:21 UTC
This was Final FE for F21, propose Alpha FE for F22, it's pretty ugly and makes custom part a bit confusing. Should it be against anaconda for F22, to merge CSS instead of replacing it?

Comment 26 Adam Williamson 2014-12-04 21:02:26 UTC
Ah. "The truly correct behavior would be for them to somehow make their way to /run/install/product/anaconda-gtk.css where anaconda would automatically merge them instead of replacing it."

so, no.

Comment 27 Matthew Miller 2014-12-04 22:19:10 UTC
(In reply to Adam Williamson (Red Hat) from comment #26)
> Ah. "The truly correct behavior would be for them to somehow make their way
> to /run/install/product/anaconda-gtk.css where anaconda would automatically
> merge them instead of replacing it."
> 
> so, no.

I think #1170800 supplants this for rawhide.

Comment 28 Adam Williamson 2014-12-04 23:10:28 UTC
Fair enough.


Note You need to log in before you can comment on or make changes to this bug.