Bug 1169440 - SoaS anaconda is missing font does not display some language samples on first screen
SoaS anaconda is missing font does not display some language samples on first...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-01 11:38 EST by satellitgo
Modified: 2015-01-13 22:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-13 22:22:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description satellitgo 2014-12-01 11:38:01 EST
Description of problem:
SoaS anaconda is missing font does not display some language samples on first screen

Version-Release number of selected component (if applicable):
SoaS live x86_64 RC1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
please fix spin kickstarts
Comment 1 Fedora Blocker Bugs Application 2014-12-01 11:49:18 EST
Proposed as a Freeze Exception for 21-final by Fedora user satellit using the blocker tracking app because:

 kickstart is missing font?
Comment 2 Adam Williamson 2014-12-01 13:06:39 EST
Missing for me are:

Amharic
Arabic
Persian
Gujarati
Japanese
Kannada
Korean
Oriya
Sinhala
Tamil
Telugu
Thai
Urdu
Chinese

basically, some Indic languages and the CJKs.
Comment 3 Mike Ruckman 2014-12-01 13:19:48 EST
Discussed in 2014-12-01 blocker review meeting. Accepted as an FE: we will accept a fix for SoaS if it is constrained to SoaS.
Comment 4 Adam Williamson 2014-12-01 14:39:43 EST
So, I looked into this a bit. The SoaS kickstart explicitly drops the @fonts group which would presumably provide the necessary fonts:

%packages
-@fonts

This has been in place since mid-2012 (at least), so I don't think this is new for F21. Right now SoaS for F21 is over its size target - the RC1 image is 720MiB, the target is 700MiB.

It would probably be best to get pbrobinson's opinion and explanation of the -@fonts before making any changes here.
Comment 5 Peter Robinson 2014-12-01 17:06:50 EST
I seem to remember we dropped the fonts due to size constraints in F-18 and that there weren't actual sugar localisation for most of the languages with issues so ultimately they might be able to install it in their own language but not use it. I'll review the various options and see what we can do
Comment 6 satellitgo 2014-12-01 19:11:15 EST
I tested fix in flattened koji soas.ks
entry is now:

-@fonts

remove the -
did remix in f21 RC1
remix.iso Boots in VirtualBox with all languages correctly rendered
Comment 7 satellitgo 2014-12-02 17:48:22 EST
https://bugzilla.redhat.com/show_bug.cgi?id=1169979

may be related?
Comment 8 Adam Williamson 2014-12-05 15:45:45 EST
21 is done, cleaning blocker/FE process metadata.

Note You need to log in before you can comment on or make changes to this bug.