Bug 116951 - make check hangs while build dbus-0.20-4 on x86_64
Summary: make check hangs while build dbus-0.20-4 on x86_64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-26 18:37 UTC by Mark Lane
Modified: 2013-03-13 04:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 18:03:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Lane 2004-02-26 18:37:55 UTC
Description of problem: 
make check hangs on build of dbus-0.20-4.  
 
All 1 tests passed 
================== 
make[2]: Leaving directory `/home/mark/rpm/BUILD/dbus-0.20/glib' 
make[1]: Leaving directory `/home/mark/rpm/BUILD/dbus-0.20/glib' 
Making check in test 
make[1]: Entering directory `/home/mark/rpm/BUILD/dbus-0.20/test' 
Making check in glib 
make[2]: Entering directory 
`/home/mark/rpm/BUILD/dbus-0.20/test/glib' 
make  check-TESTS 
make[3]: Entering directory 
`/home/mark/rpm/BUILD/dbus-0.20/test/glib' 
escaped service dir is: ..\/..\/test\/data\/valid-service-files 
Created configuration file ./run-test.conf 
Using daemon dbus-daemon-1 is ../../bus/dbus-daemon-1 
Started test bus pid 9937 at unix:abstract=/tmp/dbus-JIpSHi7SlD 
Services on the message bus: 
  :1.0 
Got EXPECTED error from calling unknown method: D-BUS error 
org.freedesktop.DBus.Error.UnknownMethod: org.freedesktop.DBus does 
not understand message ThisMethodDoesNotExist 
Activation of echo service = 0x0 
Duplicate activation of echo service = 0x1 
String echoed = "my string hello" 
 
 
Version-Release number of selected component (if applicable): 
0.20-4 
 
How reproducible: 
I have tried is a couple of times. Building 0.20-3 worked fine but 
dbus didn't run nor did cups-1.1.20-4. dbus-0.20-4 is suppose to fix 
that problem. 
 
Steps to Reproduce: 
1. rpmbuild -ba dbus.spec 
2. 
3. 
   
Actual results: 
make check doesn't finish. 
 
Expected results: 
dbus build and makes packages. 
 
Additional info: 
I ran "strace -f make check" but it will be a very long output 
(177MB).

Comment 1 Mark Lane 2004-02-27 23:39:32 UTC
I upgraded my machine today to newest devel rpms (save some 
gnome/evolution stuff) and it now builds. So it looks like I was 
just missing a build requirement.  

Comment 2 John (J5) Palmieri 2004-08-25 18:03:56 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.